Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Autofill cannot be disabled

more options

(Current version shows 21.0.) Several months ago, after an automatic update, Firefox began to do autofill every time I filled out any field. I have tried every procedure I could find on Help to disable it, with no change. On OPTIONS>PRIVACY History, I selected Use Custom Settings and unchecked the Remember Search & Form History box. Have tried erasing individual line items in dropdown lists on a specific field, as per Firefox Help instructions, but they don't erase. Have tried clearing all history. Have tried checking Clear History When Firefox Closes box. Have tried selecting Never Remember History but it just reverts back to Use Custom Settings. How the heck do you disable autofill?

All Replies (2)

more options

It sounds like a very stubborn case.

You've done the right things to prevent future entries being saved.

The following should clear all existing saved form information:

History menu > Clear Recent History

Set only the Form & Search History checkbox, change the time to clear to Everything, then click Clear Now.

Does that work?

(Note: Clear Recent History was on the Tools menu for a long time; you've probably seen this dialog before.)

Endret av jscher2000 - Support Volunteer

more options

By the way, if you notice that Firefox doesn't save your changes (not including the Never Remember History drop-down, which is a different issue), perhaps something in this article will help: How to fix preferences that won't save.