Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Firefox injects itself into RunOnce at shutdown

  • 10 antwoorden
  • 1 heeft dit probleem
  • 30 weergaven
  • Laatste antwoord van FredMcD

more options

I always shut down my system without shutting down any programs. When I do this with Firefox open, it puts itself inside the registry key RunOnce, and will run on the next Windows start. Which for me is every single Windows start. How can I stop Firefox from doing this?

Note that "Restore previous session" and whatnot is already disabled in the settings.

Gekozen oplossing

This is a new feature. To turn it off:

  1. Visit about:config
  2. Seach for toolkit.winRegisterApplicationRestart and set its value to false.
Dit antwoord in context lezen 👍 1

Alle antwoorden (10)

more options

Oops .....

Bewerkt door McCoy op

more options

Gekozen oplossing

This is a new feature. To turn it off:

  1. Visit about:config
  2. Seach for toolkit.winRegisterApplicationRestart and set its value to false.
more options

TyDraniu said

This is a new feature. To turn it off:
  1. Visit about:config
  2. Seach for toolkit.winRegisterApplicationRestart and set its value to false.

Thanks man. Exactly what I wanted.

more options

McCoy said

Oops .....

If that "Oops" is there because you had something to do with the implementation of this feature. Then it's a fine enough idea. It's a problem that RunOnce opens so slowly. I will turn on my PC. Open Firefox. Start looking into the thing I turned my PC on for - and *then* a RunOnce'd Firefox instance will spawn on top of my existing Firefox window, with nothing in it. If you think there's value in reopening if Firefox was closed improperly, then maybe check whether Firefox is already running before opening a new window.

more options

Separate Security Issue: Update your Flash Player or remove it using these links; Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link}

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 32.0.0.101

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

FredMcD said

Separate Security Issue: Update your Flash Player or remove it using these links; Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link} Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox). Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player Version: Version 32.0.0.101 https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

What's this a response to?

more options

nar00w said

If that "Oops" is there because you had something to do with the implementation of this feature. Then it's a fine enough idea.

No, that "Oops" means that I deleted a long post that I hoped would solve your problem, but then I saw TyDraniu's brilliant solution ......

more options

FredMcD said

Separate Security Issue: Update your Flash Player or remove it using these links;

nar00w said

What's this a response to?

Your flash player is outdated and should be updated or removed.

more options

FredMcD said

FredMcD said
Separate Security Issue: Update your Flash Player or remove it using these links;

nar00w said

What's this a response to?

Your flash player is outdated and should be updated or removed.

How do you know, and why are you telling me this in a question about something else entirely?

more options

Your System Details shows;

Installed Plug-ins

Shockwave Flash 24.0 r0

the current player is Version 32