X
Tap here to go to the mobile version of the site.

Support Forum

Web page doesn't display a gif link image

Posted

When I use Ie8 the image appears properly but it doesn't appear using Mozilla 28.0

When I use Ie8 the image appears properly but it doesn't appear using Mozilla 28.0

Chosen solution

Hi Bob, glad you've sorted out the image problem.

Regarding the tree structures, you keep mentioning Java (which runs on the server) when I think you mean JavaScript (which runs in the client's browser). The page says I need JavaScript enabled and the page's source code includes a block of JavaScript which claims to deal with the folding menu tree (although it only seems like part of the code that is needed). I have found the instructions for implementing the tree here on dynamicdrive.com and their demonstration of it works, so try following what they say. You might also want to remove any of the JavaScript already on that page that might get in the way. Tell us if you have any problems with that.

P.S. I'd be happy to try my hand at coding some other things that you might need (JavaScript, Java, or something else), but I don't do anything for money (I'm only 17 and I look for any experience I can get).

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Citrix Online App Detector Plugin
  • Shockwave Flash 12.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1
  • iTunes Detector Plug-in
  • ActiveTouch General Plugin Container Version 105
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.9.149
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:28.0) Gecko/20100101 Firefox/28.0

More Information

WilIP 13 solutions 64 answers

Can we have a link to the page please, and also a screenshot if possible. Without this it will be very difficult to solve your problem. Thanks.

If the site is one you are developing and isn't online, can you please give us the HTML code by pasting it in this forum thread or posting a link to it on a site such as pastebin. You should also upload the gif in question and tell us the layout of the directories. Thanks.

Can we have a link to the page please, and also a screenshot if possible. Without this it will be very difficult to solve your problem. Thanks. If the site is one you are developing and isn't online, can you please give us the HTML code by pasting it in this forum thread or posting a link to it on a site such as [http://pastebin.com/ pastebin]. You should also upload the gif in question and tell us the layout of the directories. Thanks.

Question owner

Hello and thanks for the reply. The url is:

http://www.pcshomepage.com/links.asp

As I mentioned in the original post, the graphic displays fine in IE8 but not in Mozilla v28.0.

Hello and thanks for the reply. The url is: http://www.pcshomepage.com/links.asp As I mentioned in the original post, the graphic displays fine in IE8 but not in Mozilla v28.0.
WilIP 13 solutions 64 answers

I've looked in both Firefox 28, Chrome 34 and Internet Explorer 11 and the page seems the same (but neater looking in Firefox and Chrome). There are at least 10 gifs on this page, so could you please tell me which one you are having problems with.

In the meantime, please check that images aren't blocked for this website:

  1. Right-click somewhere on the page and select 'View Page Info'.
  2. Click the 'Media' heading/tab.
  3. Ensure that 'Block Images from www.pcshomepage.com' is unchecked.
  4. Close the 'Page Info' window and refresh the page.
I've looked in both Firefox 28, Chrome 34 and Internet Explorer 11 and the page seems the same (but neater looking in Firefox and Chrome). There are at least 10 gifs on this page, so could you please tell me which one you are having problems with. In the meantime, please check that images aren't blocked for this website: # Right-click somewhere on the page and select 'View Page Info'. # Click the 'Media' heading/tab. # Ensure that 'Block Images from www.pcshomepage.com' is unchecked. # Close the 'Page Info' window and refresh the page.

Question owner

I did the steps you mentioned but still not there. The image should appear under this text: "Click on the banner below for more information."

I did see the gif image listed in the page info under media and it is: http://www.appliedi.net/affiliates/banners/applied2-120x60.gif

Bob

I did the steps you mentioned but still not there. The image should appear under this text: "Click on the banner below for more information." I did see the gif image listed in the page info under media and it is: http://www.appliedi.net/affiliates/banners/applied2-120x60.gif Bob

Question owner

I just tested this page on my development machine and it displays properly. It is a very old version (3.6) as is this machine too.

Is there any way to attach screenshots here?

Bob

I just tested this page on my development machine and it displays properly. It is a very old version (3.6) as is this machine too. Is there any way to attach screenshots here? Bob
WilIP 13 solutions 64 answers

Hi bob, it definitely works for me (even on my phone's browsers), and looking at the source code I don't see anything wrong with it other than the containment of the image. An image is a block level element, but this image is contained within an <a> tag, which is an inline element. I suggest you try adding style="display:block" to the <a> tag which contains the image, and if it still doesn't work for you, also try removing the < p > tag that contains the <a> tag with the image (but don't remove the <a> tag and < img > tag).

Read this for taking a screenshot and uploading (save it on your computer then click the browse button above the 'Post a Reply' box and then find it in the browse window).

Hi bob, it definitely works for me (even on my phone's browsers), and looking at the source code I don't see anything wrong with it other than the containment of the image. An image is a block level element, but this image is contained within an <a> tag, which is an inline element. I suggest you try adding style="display:block" to the <a> tag which contains the image, and if it still doesn't work for you, also try removing the < p > tag that contains the <a> tag with the image (but don't remove the <a> tag and < img > tag). Read [https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem this] for taking a screenshot and uploading (save it on your computer then click the browse button above the 'Post a Reply' box and then find it in the browse window).

Question owner

I will try your suggestion. If you are using the same Mozilla version, 28.0, it must be something with my computer or security software?

This is a sidebar to our current thread but can you go to either the CLIENTS or SERVICES pages or both and let me know if the tree structure (folders) function properly for you?

Bob

I will try your suggestion. If you are using the same Mozilla version, 28.0, it must be something with my computer or security software? This is a sidebar to our current thread but can you go to either the CLIENTS or SERVICES pages or both and let me know if the tree structure (folders) function properly for you? Bob
WilIP 13 solutions 64 answers

Helpful Reply

Hi Bob, neither of the portfolios (Services or Clients) work for me. I see the message that I don't have JavaScript or that it is disabled, but I definitely do have JavaScript and it is fully enabled. I looked at the JavaScript source code and I think it's not working because the versions of JavaScript used are way out of date - and I should know, as I originally learned JavaScript from a book that was about 10 years old and most of the stuff in there didn't work. I can't make sense of much of it and I can't see where it checks whether I have JavaScript enabled (although I see it checks whether I am using Netscape and I can't think why that would be other than an outdated check for JavaScript availability).

Hi Bob, neither of the portfolios (Services or Clients) work for me. I see the message that I don't have JavaScript or that it is disabled, but I definitely do have JavaScript and it is fully enabled. I looked at the JavaScript source code and I think it's not working because the versions of JavaScript used are way out of date - and I should know, as I originally learned JavaScript from a book that was about 10 years old and most of the stuff in there didn't work. I can't make sense of much of it and I can't see where it checks whether I have JavaScript enabled (although I see it checks whether I am using Netscape and I can't think why that would be other than an outdated check for JavaScript availability).
cor-el
  • Top 10 Contributor
  • Moderator
17481 solutions 157964 answers

Helpful Reply

If images are missing then check that you do not block images from some domains.

  • Press the F10 key or tap the Alt key to bring up the hidden Menu bar.

Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"

Check "Tools > Page Info > Media" for blocked images

  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain.

Make sure that you do not block (third-party) images, the permissions.default.image pref on the about:config page should be 1.


Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

See also:


There are extensions like Adblock Plus (Firefox/Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also:

If images are missing then check that you do not block images from some domains. *Press the F10 key or tap the Alt key to bring up the hidden Menu bar. Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions" Check "Tools > Page Info > Media" for blocked images *Select the first image link and use the cursor Down key to scroll through the list. *If an image in the list is grayed and "<i>Block Images from...</i>" has a checkmark then remove this checkmark to unblock images from this domain. Make sure that you do not block (third-party) images, the <b>permissions.default.image</b> pref on the <b>about:config</b> page should be 1. ---- Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings. Make sure that you allow pages to choose their own colors. *Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above" Note that these settings affect background images. See also: *http://kb.mozillazine.org/Website_colors_are_wrong ---- There are extensions like Adblock Plus (Firefox/Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content. See also: *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *http://kb.mozillazine.org/Images_or_animations_do_not_load *http://kb.mozillazine.org/Websites_look_wrong

Question owner

Will P,

Thanks for all your help. I think you are right about the JavaScript problem. I check for Java, cookies, etc. in the Session Startup event. Perhaps the browser checking code is wrong or faulty there.

The folding tree Java code wasn't working before I added the Session code so might have two problems...:-(

Bob

Will P, Thanks for all your help. I think you are right about the JavaScript problem. I check for Java, cookies, etc. in the Session Startup event. Perhaps the browser checking code is wrong or faulty there. The folding tree Java code wasn't working before I added the Session code so might have two problems...:-( Bob

Question owner

Hello cor-el,

Thanks for the reply. I must admit it is a bit baffling since everyone else can see the image...:-(

I will check all the options you noted:

1. I do use Adblock 2. My Firewall/Anit-virus is Kaspersky

I will let you know how the testing goes...

Bob

Hello cor-el, Thanks for the reply. I must admit it is a bit baffling since everyone else can see the image...:-( I will check all the options you noted: 1. I do use Adblock 2. My Firewall/Anit-virus is Kaspersky I will let you know how the testing goes... Bob

Question owner

Will P,

It was Adblock causing the problem. Once I disabled it for my domain, the image appeared.

So, since you have Java experience, how would you like to earn some extra $$$ redoing the folding tree code...:-)

Bob

Will P, It was Adblock causing the problem. Once I disabled it for my domain, the image appeared. So, since you have Java experience, how would you like to earn some extra $$$ redoing the folding tree code...:-) Bob

Question owner

Cor-el,

Adblock was causing the problem. Once I disabled it for my domain, the image appeared.

Thanks for your help!

Bob

Cor-el, Adblock was causing the problem. Once I disabled it for my domain, the image appeared. Thanks for your help! Bob
WilIP 13 solutions 64 answers

Chosen Solution

Hi Bob, glad you've sorted out the image problem.

Regarding the tree structures, you keep mentioning Java (which runs on the server) when I think you mean JavaScript (which runs in the client's browser). The page says I need JavaScript enabled and the page's source code includes a block of JavaScript which claims to deal with the folding menu tree (although it only seems like part of the code that is needed). I have found the instructions for implementing the tree here on dynamicdrive.com and their demonstration of it works, so try following what they say. You might also want to remove any of the JavaScript already on that page that might get in the way. Tell us if you have any problems with that.

P.S. I'd be happy to try my hand at coding some other things that you might need (JavaScript, Java, or something else), but I don't do anything for money (I'm only 17 and I look for any experience I can get).

Hi Bob, glad you've sorted out the image problem. Regarding the tree structures, you keep mentioning Java (which runs on the server) when I think you mean JavaScript (which runs in the client's browser). The page says I need JavaScript enabled and the page's source code includes a block of JavaScript which claims to deal with the folding menu tree (although it only seems like part of the code that is needed). I have found the instructions for implementing the tree [http://www.dynamicdrive.com/dynamicindex1/navigate1.htm here on dynamicdrive.com] and their demonstration of it works, so try following what they say. You might also want to remove any of the JavaScript already on that page that might get in the way. Tell us if you have any problems with that. P.S. I'd be happy to try my hand at coding some other things that you might need (JavaScript, Java, or something else), but I don't do anything for money (I'm only 17 and I look for any experience I can get).

Question owner

Hi Will,

Wow, 17 and you are already involved in the tech world...very good!

I guess with respect to the JavaScript issue here are some puzzling observations:

1. You are correct about the two folding tree pages on my site as both use JavaScript 1.2 and they don't work.

2. The interesting thing, which doesn't make sense to me, is you will note the ADD TO FAVORITES icon on all pages displays Ctrl-D when using a Mozilla browser. It is interesting because it also JavaScript 1.2 which for some reason does execute properly...?????

Bob

Hi Will, Wow, 17 and you are already involved in the tech world...very good! I guess with respect to the JavaScript issue here are some puzzling observations: 1. You are correct about the two folding tree pages on my site as both use JavaScript 1.2 and they don't work. 2. The interesting thing, which doesn't make sense to me, is you will note the ADD TO FAVORITES icon on all pages displays Ctrl-D when using a Mozilla browser. It is interesting because it also JavaScript 1.2 which for some reason does execute properly...????? Bob
cor-el
  • Top 10 Contributor
  • Moderator
17481 solutions 157964 answers

I notice that a lot of the scripts are versions from 2008 or older.
Make sure that you have the latest versions of all the JavaScript libraries that you use on your site.

I notice that a lot of the scripts are versions from 2008 or older.<br /> Make sure that you have the latest versions of all the JavaScript libraries that you use on your site.
WilIP 13 solutions 64 answers

Hi Bob, the bookmark/add to favourites script doesn't work properly (older scripts will still run, but often not as intended, sometimes meaning nothing happens at all). 'Ctrl-D' is shown because the script checks for navigator.appName being equal to 'Netscape'; all of the main browsers now have this set to 'Netscape' in their latest versions (IE being the latest to change) for compatibility reasons. Therefore, IE 11 isn't recognised for what it is and the script incorrectly displays 'Bookmark (Ctrl-D)' as opposed to 'Add to Favorites'.

If your browser is detected as being IE (which it won't be in modern IE versions) the script will also create a link which would add the page to your favourites when clicked. However, I have looked at several sources which describe different methods to add a bookmark/favourite using JavaScript (including the one used in this script), but testing them showed me that none of them work in modern browser versions (allowing websites to add bookmarks/favourites automatically without the user's consent would be an advertising nightmare). Anyone who uses bookmarks/favourites already knows how to add one anyway, so this link is not essential (especially as we can tell the user they need to hit Ctrl+D).

Taking this into account, I think you should try replacing the current script with this script I wrote:

   <script type="text/javascript">
           var userAgent = navigator.userAgent;
           if (/trident/i.test(userAgent)) {
               document.write('Add to favourites (Ctrl-D)');
           } else {
               document.write('Bookmark (Ctrl-D)');
           }
   </script>

This will say 'Add to Favourites (Ctrl-D)' in IE and 'Bookmark (Ctrl-D)' in all other browsers.

Hi Bob, the bookmark/add to favourites script doesn't work properly (older scripts will still run, but often not as intended, sometimes meaning nothing happens at all). 'Ctrl-D' is shown because the script checks for navigator.appName being equal to 'Netscape'; all of the main browsers now have this set to 'Netscape' in their latest versions (IE being the latest to change) for compatibility reasons. Therefore, IE 11 isn't recognised for what it is and the script incorrectly displays 'Bookmark (Ctrl-D)' as opposed to 'Add to Favorites'. If your browser is detected as being IE (which it won't be in modern IE versions) the script will also create a link which would add the page to your favourites when clicked. However, I have looked at several sources which describe different methods to add a bookmark/favourite using JavaScript (including the one used in this script), but testing them showed me that none of them work in modern browser versions (allowing websites to add bookmarks/favourites automatically without the user's consent would be an advertising nightmare). Anyone who uses bookmarks/favourites already knows how to add one anyway, so this link is not essential (especially as we can tell the user they need to hit Ctrl+D). Taking this into account, I think you should try replacing the current script with this script I wrote: <script type="text/javascript"> var userAgent = navigator.userAgent; if (/trident/i.test(userAgent)) { document.write('Add to favourites (Ctrl-D)'); } else { document.write('Bookmark (Ctrl-D)'); } </script> This will say 'Add to Favourites (Ctrl-D)' in IE and 'Bookmark (Ctrl-D)' in all other browsers.
cor-el
  • Top 10 Contributor
  • Moderator
17481 solutions 157964 answers

It is probably best to test for trident and MSIE

<script type="text/javascript">
 var userAgent = navigator.userAgent;

 if (/trident|msie/i.test(userAgent)) {
    document.write('Add to favourites (Ctrl-D)');
 } else {
    document.write('Bookmark (Ctrl-D)');
 }
</script>

It is probably best to test for trident and MSIE <pre><nowiki><script type="text/javascript"> var userAgent = navigator.userAgent; if (/trident|msie/i.test(userAgent)) { document.write('Add to favourites (Ctrl-D)'); } else { document.write('Bookmark (Ctrl-D)'); } </script></nowiki></pre> ---- *http://msdn.microsoft.com/en-us/library/ms537503%28v=vs.85%29.aspx
WilIP 13 solutions 64 answers

Yes, you are absolutely right Cor-el; your version should be compatible with IE 2 and upwards, whereas my original script is only compatible with IE 8 and and upwards. Thanks for that.

Yes, you are absolutely right Cor-el; your version should be compatible with IE 2 and upwards, whereas my original script is only compatible with IE 8 and and upwards. Thanks for that.