X
Tap here to go to the mobile version of the site.

Support Forum

Which version is best for Windows 8, 64 bit

Posted

I am currently running Firefox 22.0 and my browser keeps crashing.

I am using windows 8 on a brand new 64 bit computer. When I investigated the upgrade to 22 i see that it is not recommended for 64 bit computers.

What version of firefox is my best bet on this computer?

I am currently running Firefox 22.0 and my browser keeps crashing. I am using windows 8 on a brand new 64 bit computer. When I investigated the upgrade to 22 i see that it is not recommended for 64 bit computers. What version of firefox is my best bet on this computer?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Google Update
  • A plugin to detect whether the Adobe Creative Cloud is installed on this machine.v_2_0_0_0
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • HP Pit Plugin
  • HP Product Detection Plugin
  • HP Active Check Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Website Logon Plugin
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • NPWLPG
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5315 solutions 23468 answers

Helpful Reply

hello, could you provide your latest few submitted crash reports? please enter about:crashes into the location bar, copy the latest few report ids from there & paste them here into a forum reply. this will give us a better understanding what may be triggering those crashes.

the information that the current firefox builds wouldn't be recommended for 64bit computers is wrong: https://www.mozilla.org/firefox/23.0/system-requirements/

hello, could you provide your latest few submitted crash reports? please enter '''about:crashes''' into the location bar, copy the latest few report ids from there & paste them here into a forum reply. this will give us a better understanding what may be triggering those crashes. the information that the current firefox builds wouldn't be recommended for 64bit computers is wrong: https://www.mozilla.org/firefox/23.0/system-requirements/
Tyler Downer
  • Top 25 Contributor
  • Moderator
1535 solutions 10702 answers

Helpful Reply

You should be using Firefox 23, it works perfectly fine on 64bit computers and wherever you read that is false.

You should be using Firefox 23, it works perfectly fine on 64bit computers and wherever you read that is false.
kobe 441 solutions 5048 answers

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

Hello, Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: *Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Did this fix your problems? Please report back to us! Thank you.