Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am unable to install Firefox at all on my PC. When I click RUN, it does absolutely nothing. We have a 64bit Windows 7.

  • 6 replies
  • 10 have this problem
  • 5580 views
  • Last reply by mariost

more options

We have tried repeatedly to install Firefox on our HP 64bit Windows 7. It gets to the run screen and then nothing happens. We even waited half an hour. I had no problem loading it on my lap top, but the desk top will not load. We even changed from Administrator to user. We changed our Admin password and it still will not load. Any help would be greatly appreciated. I hate Internet Explorer and would really love to have Firefox!

All Replies (6)

more options

Is this with running the Firefox installer to install Firefox or with starting the installed Firefox program?

You can try to disable your Anti-virus software temporarily to see if that allows to install Firefox if you try to do that.

See also:

more options

We are using the installer from Firefox. We disabled our firewall on our security program, avast. It still will not let us install the program. It has never been on this computer before.

more options

I just tried all suggestions and I still cannot install the program. Any other suggestions? Any help will be greatly appreciated.

more options

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

Thank you so much!! We finally have it on the desktop! I never would have gone to save mode. Again, thank you.

more options

I have been running Firefox for over 2 years on my Win 7 64 bit machine. This AM, I cannot start it. I get a message that it crashed & have option to Restart FF> When I click that I get option to start in safe mode. I cannot get it ti run in normal mode. I uninstalled & re-installed. Did not work. I uninstalled again & re-installed while Win 7 was in Safe Mode. It seemed t install & run fine. Rebooted & same thing.

Kinda frustrating. Any ideas?

Modified by mariost