Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

What is the minimum version of Windows supported by Firefox 3.0 or 4.0? I am running Windows 98SE.

  • 2 replies
  • 3 have this problem
  • 64 views
  • Last reply by cor-el

more options

I don't want to try installing Firefox 3.17 or 4.01 if they don't support Windows 98SE. I can't seem to find any minimum system requirements for these newer versions.

All Replies (2)

more options

Firefox 2.0.0.20 is the last ever version of Firefox for Win98 / SE / ME.

more options