Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My bookmarks have disappeared and I can't add new bookmarks.

  • 3 replies
  • 15 have this problem
  • Last reply by funkypam

more options

All my bookmarks have disappeared, including the defaults on the toolbar of most visited, etc. I can't add new bookmarks either. I have tried all the Help Topics on lost bookmarks. I tried restoring bookmark backups, but the backup from the date I lost bookmarks says "unable to process backup file." All the later dates will load, but they have no bookmarks saved in them. All of the other Help Topic attempts went fine but did not solve the problem.

All Replies (3)

more options

What I would say is that if you have any bookmarks at all at present that you make a manual backup of them, and then continue to make manual backups as any recovery efforts proceed.

There is a possibility that you had corrupt files, and may then have inadvertently overwritten any files that may have contained bookmarks. It is a good idea to make manual backups, for cases where the auto backups do not. work as expected.

If you have already followed the instructions carefully about Recover lost or missing Bookmarks and without resolving the situation, there may not be much you can do about your personal bookmarks. If they are important and you are willing to try there may be a possibility using file recovery software, &/or sqlite editors that something could be salvaged, but not something I can advise on, I am not currently a Mac user.

The default bookmarks should be fairly easy to restore. You can probably also start the bookmarks working again. Trying the simplest options first:

  1. work from [safe mode]
    • at this stage when you see the first dialogue window with options do not make changes, press the continue button
  2. use the customise / customize option from the toolbars and reset defaults
  3. if that has failed to resolve the problem go back to safe mode as in step 1 but this time use reset toolbars and controls.

By now you should have the default bookmarks back and maybe the bookmarks work and will save new bookmarks, try it whilst still in safe mode, before going back to try in ordinary mode. If it works in safe mode but not in ordinary mode you probably have some add-on managing to cause problems

If you still have problems and bookmarks will not save see Can't add, change or save bookmarks - How to fix that probably indicates corrupt places.sqlite &/or localstore.rdf the linked article explains how to find and delete them.

more options

That combination of problems indicates a problem with the file that stores bookmarks. For details on fixing it see

more options

I also can't use the back or forward buttons on my toolbar, it's not saving any history, and I can't add new bookmarks. I tried running it in Safe Mode and resetting the toolbar. I'm not really worried about recovering my old bookmarks as long as I can add new ones!! I will read that article, thanks and I will see if any of that helps....fingers crossed.