X
Tap here to go to the mobile version of the site.

Support Forum

When I click on the icon to start firefox, the screen dims and I get this question in a dialogue box from User Account Control....."Do you want to allow the following program to make changes to this computer"

Posted

Every time I start firefox

Every time I start firefox

Additional System Details

Installed Plug-ins

  • -Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.0 r45
  • iTunes Detector Plug-in
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • Google Update
  • Java(TM) Platform SE binary
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)

More Information

I found this problem on the help site but was unable to access the solution. The run as administrator box is not checked!

Shawn
  • Moderator
42 solutions 549 answers

1. Right-click the Firefox icon

2. Click Properties

3. Click The Compatibility tab

4. IsRun this program as an administrator checked?

If it is, disable it.

1. Right-click the Firefox icon 2. Click '''Properties''' 3. Click The '''Compatibility''' tab 4. Is'''Run this program as an administrator''' checked? If it is, disable it.

Question owner

That didn't help

That didn't help

Question owner

That didn't fix it

That didn't fix it

Question owner

I've tried it both ways, the message still appears every time.

I've tried it both ways, the message still appears every time.
Shawn
  • Moderator
42 solutions 549 answers

http://windows.microsoft.com/en-us/Windows7/What-are-User-Account-Control-settings You may want to change your Uac (User account control) settings

Windows may be set to always notify you

http://windows.microsoft.com/en-us/Windows7/What-are-User-Account-Control-settings You may want to change your Uac (User account control) settings Windows may be set to always notify you

Question owner

I still have the message. The only way it did not appear was when I set the user control to the lowest value(not recommended). any more thoughts?

I still have the message. The only way it did not appear was when I set the user control to the lowest value(not recommended). any more thoughts?
dan2352 0 solutions 5 answers

If you have Windows-7: Home Basic and Home Premium this works.

1. Create a new text file

2. Copy the text below into it.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System] "ConsentPromptBehaviorAdmin"=dword:00000000

3. Save as, e.g. DisableUACadmin.reg The reg extension is recognized by the registry editor.

4. Double-click your file and accept everything.Then do PART II below.


If you have Windows-7: Professional (Business), Enterprise and Ultimate Editions this works.


1. From the START MENU open the Control Panel and click on the Administrative Tools icon.

2. Double click on Local Security Policy to open it.

3. Browse down to Local Policies and then down to Security Options

4. In the list find: “User Account Control: Behavior of the elevation prompt for administrators in Admin Approval

Mode” and double-click on it.

5. Using the dropdown window change the setting to “Elevate without prompting”.

6. Close out all your windows and do PART II below


PART II

For all versions of Windows-7, now you can right-click the FireFox icon and select properties. Click on the Compatibility tab and select "Run this program as an Administrator".

No more UAC for Firefox.

'''If you have Windows-7: Home Basic and Home Premium this works.''' 1. Create a new text file 2. Copy the text below into it. <code> Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System] "ConsentPromptBehaviorAdmin"=dword:00000000 </code> 3. Save as, e.g. DisableUACadmin.reg The reg extension is recognized by the registry editor. 4. Double-click your file and accept everything.Then do PART II below. '''If you have Windows-7: Professional (Business), Enterprise and Ultimate Editions this works.''' 1. From the START MENU open the Control Panel and click on the Administrative Tools icon. 2. Double click on Local Security Policy to open it. 3. Browse down to Local Policies and then down to Security Options 4. In the list find: “User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode” and double-click on it. 5. Using the dropdown window change the setting to “Elevate without prompting”. 6. Close out all your windows and do PART II below '''PART II''' For all versions of Windows-7, now you can right-click the FireFox icon and select properties. Click on the Compatibility tab and select "Run this program as an Administrator". No more UAC for Firefox.
cor-el
  • Top 10 Contributor
  • Moderator
17535 solutions 158559 answers

You shouldn't run Firefox as Administrator and you should leave that box unchecked. You also need to check the compatibility setting of the Firefox program in the Firefox program folder to make sure that the Firefox program also doesn't have a check-mark to run as Administrator. If you run Firefox as Administrator then Windows will ask for permission if changes are to be made to the registry or program folder. As a normal user you can't make such changes and Windows will silently divert them to a virtual storage location where they can't do any harm. See also http://support.microsoft.com/kb/927387 (Common file and registry virtualization issues in Windows Vista)

If you run Firefox as Administrator and download something malicious (e.g. Java or data for another plugin or program) then you make yourself highly vulnerable to malware.

You shouldn't run Firefox as Administrator and you should leave that box unchecked. You also need to check the compatibility setting of the Firefox program in the Firefox program folder to make sure that the Firefox program also doesn't have a check-mark to run as Administrator. If you run Firefox as Administrator then Windows will ask for permission if changes are to be made to the registry or program folder. As a normal user you can't make such changes and Windows will silently divert them to a virtual storage location where they can't do any harm. See also http://support.microsoft.com/kb/927387 (Common file and registry virtualization issues in Windows Vista) If you run Firefox as Administrator and download something malicious (e.g. Java or data for another plugin or program) then you make yourself highly vulnerable to malware.
dan2352 0 solutions 5 answers

As for Plugins, when I was running FireFox as not Admin and UAC was appearing I was still able to add in extensions and Add-ons to FireFox.

I would never trust Microsoft to protect my system so I rely on ESET Smart Security to fulfill that function and when I do add something to FireFox or my system in general, I run it in a sandbox first.

So with the Admin-registry problem dealt with that leaves me with the annoying UAC confirmation dialog and that I dealt with using the steps in the post I provided.

Thanks cor-el for the advice though, as I am new to Firefox it's great to see people contributing their time to help others out :)

As for Plugins, when I was running FireFox as not Admin and UAC was appearing I was still able to add in extensions and Add-ons to FireFox. I would never trust Microsoft to protect my system so I rely on ESET Smart Security to fulfill that function and when I do add something to FireFox or my system in general, I run it in a sandbox first. So with the Admin-registry problem dealt with that leaves me with the annoying UAC confirmation dialog and that I dealt with using the steps in the post I provided. Thanks '''cor-el''' for the advice though, as I am new to Firefox it's great to see people contributing their time to help others out :)