Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Secure Connection Failed

  • 5 replies
  • 2 have this problem
  • 23 views
  • Last reply by cor-el

more options

Greetings, Firefox community.

So a couple of months ago my Firefox browser (in a 2017 Macbook Air running MacOS Monterey 12.1) began having problems connecting specifically with Google websites (address bar search engine, Drive, Calendar, Gmail, YouTube, etc.).

Some days, my first search will go through, but then, with all posterior attempts, all I get is the "SSL_ERROR_HANDSHAKE_UNEXPECTED_ALERT" error code.

I have tried logging off my Firefox account, reinstalling the browser, resetting all settings ("Refresh Firefox" button), cleared startup caché, and clearing all caché and data from these websites, but I keep getting the code and can't get through to the website.

The websites work normally in Safari.

I'd really appreciate your help, as it is very frustrating to have to use another browser only for Google searches, YouTube and GMail (Firefox continues being my favorite browser).

Attached screenshots

All Replies (5)

more options

I've been having this issue as well. Infact, I just made a thread about it: https://support.mozilla.org/en-US/questions/1366148

I'm really wondering what causes this and I hope we both manage to find a solution :P

GM

Helpful?

more options

It's a different error code, isn't it?

Greymagic27 said

I've been having this issue as well. Infact, I just made a thread about it: https://support.mozilla.org/en-US/questions/1366148 I'm really wondering what causes this and I hope we both manage to find a solution :P GM

Modified by Juan

Helpful?

more options

Helpful?

more options

Helpful?

more options

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.