Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Images that I upload are not displaying

  • 3 replies
  • 1 has this problem
  • 14 views
  • Last reply by user3452858

more options

Whatever image I upload from firefox is not displaying properly. The images turned into grey or green colour.

Attached screenshots

Chosen solution

Actually, the image looks like it has vertical stripes or bars. If so, that is characteristic of the privacy.resistFingerprinting feature that blurs images extracted from a canvas. I assume you turned that on intentionally?

While you are on that site, is there a canvas permission icon toward the left end of the toolbar? If so, you can use that to give the site permission to extract images from a canvas without blurring.

If there's no icon for it, try the Page Info dialog. While you are on the relevant page, you can call that up using either:

  • Ctrl+i (for Mac, Command+i)
  • right-click a blank area of the page > View Page Info
  • (menu bar) Tools > Page Info

When the dialog comes up, click the Permission icon at the top to show that panel.

Near the top, you'll find "Extract Canvas Data" and you can uncheck the "Use default" box and select the Allow permission. (Note: this permission only appears if privacy.resistFingerprinting has been enabled.)

That change is saved immediately. You can close Page Info and it should be effective on your next upload.

Was that it?

Read this answer in context 👍 1

All Replies (3)

more options

Hello subit,

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (e.g. Adblock Plus, NoScript, Ghostery, uBlock Origin) always make sure such extensions do not block (wanted) content.

  • make sure your extensions and filters are updated to the latest version

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" to reload the page and bypass the cache to generate a fresh log.

If images are missing then check that you do not block images from some domains.

  • you can tap the Alt key or press the F10 key to show the hidden Menu Bar temporarily

Check the permissions for the domain in the currently selected tab in "Tools -> Page Info -> Permissions".

Check "Tools -> Page Info -> Media" for blocked images

  • select the first image and use the cursor Down key to scroll through the list
  • if an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain

You can check these preferences on the about:config page and make sure they have the default value.

  • permissions.default.image (1)
  • network.http.sendRefererHeader (2)

There is Tracking Protection that can block (wanted) content, so check the location/address bar for special icons.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (e.g. Adblock Plus, NoScript, Ghostery, uBlock Origin) always make sure such extensions do not block (wanted) content.

  • make sure your extensions and filters are updated to the latest version

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

See also:

Helpful?

more options

Chosen Solution

Actually, the image looks like it has vertical stripes or bars. If so, that is characteristic of the privacy.resistFingerprinting feature that blurs images extracted from a canvas. I assume you turned that on intentionally?

While you are on that site, is there a canvas permission icon toward the left end of the toolbar? If so, you can use that to give the site permission to extract images from a canvas without blurring.

If there's no icon for it, try the Page Info dialog. While you are on the relevant page, you can call that up using either:

  • Ctrl+i (for Mac, Command+i)
  • right-click a blank area of the page > View Page Info
  • (menu bar) Tools > Page Info

When the dialog comes up, click the Permission icon at the top to show that panel.

Near the top, you'll find "Extract Canvas Data" and you can uncheck the "Use default" box and select the Allow permission. (Note: this permission only appears if privacy.resistFingerprinting has been enabled.)

That change is saved immediately. You can close Page Info and it should be effective on your next upload.

Was that it?

Helpful?

more options

Thanks jscher2000 (jscher2000) I was having this problem from the past one year. It was because of privacy.resistFingerprinting = true

I gave the permission & used Canvas Defender & it solved the problem.

Once again Thanks

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.