X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Amazon Prime Video will not play. Just get yellow bannerFirefox is installing components needed to play the audio or video on this page. Please try again later

Posted

Amazon Prime Video will not play. Just get yellow banner,"Firefox is installing components needed to play the audio or video on this page. Please try again later" Have tried the suggested toggle on off of drm and no change. Have no such problem with Chrome or with IE.

Amazon Prime Video will not play. Just get yellow banner,"Firefox is installing components needed to play the audio or video on this page. Please try again later" Have tried the suggested toggle on off of drm and no change. Have no such problem with Chrome or with IE.
Attached screenshots

Additional System Details

Installed Plug-ins

ad block, adblock plus both are disabled on amazon

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17846 solutions 161524 answers

Try to toggle DRM off/on to see if that makes Firefox (re)load DRM components.

  • Options/Preferences -> General: Play DRM

You can possibly check the Browser Console for Widevine (gmp) related XHR messages.

See also:

Try to toggle DRM off/on to see if that makes Firefox (re)load DRM components. *Options/Preferences -> General: Play DRM You can possibly check the Browser Console for Widevine (gmp) related XHR messages. *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Browser_Console See also: *https://support.mozilla.org/en-US/kb/enable-drm
FireLinux 0 solutions 2 answers

Same problem. CentOD 6.10, FF 68.2.0esr I tried toggling the DRM setting. I also read numerous threads about faking out the version of Widevine in the <profile directory>/.mozilla/firefox/<profile name>/gmp-widevinecdm but none of that helped.

It does have widevine 4.10.1440.18 plugin installed

Same problem. CentOD 6.10, FF 68.2.0esr I tried toggling the DRM setting. I also read numerous threads about faking out the version of Widevine in the <profile directory>/.mozilla/firefox/<profile name>/gmp-widevinecdm but none of that helped. It does have widevine 4.10.1440.18 plugin installed