Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

wattsupwiththat.com is throwing an 'insecure' error. I trust them more than I trust your guys. Please fix this. [email removed]

  • 5 replies
  • 1 has this problem
  • 13 views
  • Last reply by jscher2000

more options

The error shown is: Your connection is not secure

"The owner of wattsupwiththat.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox may only connect to it securely. As a result, it is not possible to add an exception for this certificate.

Learn more…

Report errors like this to help Mozilla identify and block malicious sites."

It appeared about 3:15PM EDT. I expect his may be an attack, since it is a climate skeptic site. BTW, WUWT is an award winning science web site hosted on wordpress.org. These people know what they're doing. I see that you guys are insilicon valley, which is why I saidI trust them more than you.

Modified by cor-el

Chosen solution

Oh, wait, you already were redirected from WordPress to the site's own domain. That domain does not have a site-specific certificate, so you can't use HTTPS on that site (at least as of this moment). From clicking the "Advanced" button on the error page:

wattsupwiththat.com uses an invalid security certificate.

The certificate is only valid for the following names: *.pressable.com, pressable.com

Error code: SSL_ERROR_BAD_CERT_DOMAIN
Read this answer in context 👍 0

All Replies (5)

more options

The site is hosted on WordPress.com, and that home page is covered by a valid WordPress wildcard SSL certificate (*.wordpress.com).

Do you get errors with other WordPress sites, such as

https://mozillagfx.wordpress.com/

If possible, please try to extract the encoded version of the certificate that Firefox finds untrustworthy. To do that, click the "Advanced" button and see whether you have a SEC_ERROR code that is a link you can click to get the certificate.

More info:

more options

I get redirected via a 302 move permanently response

A server check gives the site A grade for both records.

more options

It looks like it's just WUWT - my site on wordpress (us-issues.com) works fine. (Mine is on wordpress.com, and I think WUWT is on wordpress.org, but I don't think that should make a difference.)

BTW, I tried IE and it doesn't work there either.

more options

Hi Bob_Shapiro, a valid comparison requires a domain name that contains one word followed by .wordpress.com, otherwise the site would use a different certificate. Did the the link I provided earlier work for you?

https://mozillagfx.wordpress.com/

Does this one?

https://seleniumhq.wordpress.com/

more options

Chosen Solution

Oh, wait, you already were redirected from WordPress to the site's own domain. That domain does not have a site-specific certificate, so you can't use HTTPS on that site (at least as of this moment). From clicking the "Advanced" button on the error page:

wattsupwiththat.com uses an invalid security certificate.

The certificate is only valid for the following names: *.pressable.com, pressable.com

Error code: SSL_ERROR_BAD_CERT_DOMAIN