Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do you stop and get rid of the side ads (hide ad-open ad) that continually bombard every screen while using Firefox

  • 2 replies
  • 49 have this problem
  • 27272 views
  • Paskiausią atsakymą parašė Wesley Branton

more options

When you click on hide ad a whole bunch of ad sites come up. Whoever in Mozella thought up this ought to Sh_t!!!!!!



title edited by a moderator

Modified by the-edmeister

Chosen solution

Stop, firefox doesnt come with ads, likely happened due to you installing malware. You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.


Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

Skaityti atsakymą kartu su kontekstu 👍 4

All Replies (2)

more options

Chosen Solution

Stop, firefox doesnt come with ads, likely happened due to you installing malware. You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.


Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

more options

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • Open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Please report back to us soon.