Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Add search engine with non standard port

  • Atsakymų nėra
  • 1 has this problem
  • 5 views
more options

Hello, I am trying to add searx as my default search engine. Searx runs on port 8080 on my localhost therefore it's url is https://localhost:8080. I can successfully visit this url and use searx; however when I add searx using the green button to my search engine list, it strips the port resulting in an error when searching. This is very frustrating with no ability to change this setting as far as I can tell. Is there any work around for this issue?

Chosen solution

I figured out how to change it but the process was unnecessarily complicated. First you have to figure out a way to open mozlz4 files. Conveniently, there is a simple open source Firefox extension for this called mozlz4-edit which can be found on the Firefox extension store or at github https://github.com/serj-kzv/mozlz4-edit.

From here you need to access your Firefox profile (https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data) and find the file labeled "search.json.mozlz4"

Open this file in mozlz4-edit and append the needed port to your search engine in all locations.

replace the file in your profile folder with your newly edited "search.json.mozlz4" and your search engine should work.

Skaityti atsakymą kartu su kontekstu 👍 0

All Replies (1)

more options

Chosen Solution

I figured out how to change it but the process was unnecessarily complicated. First you have to figure out a way to open mozlz4 files. Conveniently, there is a simple open source Firefox extension for this called mozlz4-edit which can be found on the Firefox extension store or at github https://github.com/serj-kzv/mozlz4-edit.

From here you need to access your Firefox profile (https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data) and find the file labeled "search.json.mozlz4"

Open this file in mozlz4-edit and append the needed port to your search engine in all locations.

replace the file in your profile folder with your newly edited "search.json.mozlz4" and your search engine should work.

Modified by trexd

Helpful?

Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.