Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mulongo oyo etiyamaki na archive. Tuna motuna mosusu soki osengeli na lisalisi

Cannot stop the multiple tab closing warning?

more options

When I close firefox with multiple tabs open I get the warning. I've checked the box not to warn me again many times and quit and I still get the warning. I tried checking the box and hit the save and quit button but when I open firefox back up it goes to the tabs that were open when I closed it and I have to go back into preferences and switch it back to open my home page again???

FYI, this is in Linux Mint 12 with Gnome3 and Cinnamon desktop and this is the only version of Linux that I've ever had to do this but it's my first version of Linux with Gnome3 as the desktop??

Is this a bug in firefox or Gnome2/Cinnamon?

Thanks

Solution eye eponami

UPDATE: Downloaded Ubuntu 12.04 last week. Install that on a "mule box" then installed Cinnamon desktop and this problem is NOT seen in Firefox Browser on that OS/Desktop.

Having said that, one could "assume" that the problem lies within Linux Mint, not Firefox or Cinnamon.

Will post this problem in the Mint forum.

So as far as Firefox is concerned, I guess we could consider the issue "resolved" but not fixed since that will have to be done by the Linux Mint group.

And BTW, Ubuntu 12.04 looks good with the Cinnamon desktop!  ;-) Probably a "keeper"!

Tanga eyano oyo ndenge esengeli 👍 0

All Replies (10)

more options

Have you read the article, Preferences are not saved ? It might be able to help you out with this.

more options

Went through your suggestion link and got no help and BTW, I have TWO different computers running Linux Mint v12 with Gnome3/Cinnamon and BOTH are doing the exact same thing??

I see two other ppl have stated that they have the same problem?

Bug in Firefox or Gnome3/Cinnamon??

Thanks

more options

It is possible that there is a problem with the files sessionstore.js and sessionstore.bak in the Firefox Profile Folder.

Delete the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox Profile Folder.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost, so you will have to create them again (make a note or bookmark them).

See also:

more options

FYI, I went in and changed the name of those two files to .old. Closed out the browser then reopened it and tried to close with two tabs open and got the warning. Checked the box to not notify me again, quit and reopened and tried to close again with two tabs open and still got the warning???

So, I went back into "Open Containing Folder" and checked and there were two new files there, ie, sessionstore.js and sessionstore.bak along with the two original files I renamed to .old. So Firefox made two new files on it's own with around 25k bytes of data in them but I still have the same problem.

What next?

Ezalaki modifié na Lone_Gunman45

more options

If prefs change then you need to check for problems with prefs.js.
If you have a user,js file then all prefs in that file are set accordingly each time that you start Firefox , so changes from the previous session are lost and you need to remove them from user.js if you want to change them permanently.

more options

Know what? This is getting to be more complicated than I want to mess with as I got more important things to do than rebuild a browser to try to get rid of what is obviously a bug in someone's software. Neither Opera nor Chrome seem to have this problem??

Maybe someone there will fix it in the next release of Firefox!

I'm done!

more options

Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

more options

One last reply on this..........Firefox 12 was included in daily updates from Mint yesterday and there was joy in muddville thinking this bug was fixed!! IT WASN'T??

So does Mozilla consider this a Linux Mint issue or what??

And while I'm complaining, I use the "old location bar" and in that dropdown menu, the MOST frequently used sites normally wind up at the top of the list? NOT ANY MORE? Still works on Winders and Ubuntu but not in Mint running Cinnamon? Is this another bug for Mint or Mozilla where Cinnamon/Gnome3 is concerned???

more options

I installed Linux Mint 12 on three different computers this month (with Gnome and/or MATE), and all have this same problem. I guess we can easily conclude the fixing has to come through a global patch.

Ezalaki modifié na Clairval

more options

Solution eye oponami

UPDATE: Downloaded Ubuntu 12.04 last week. Install that on a "mule box" then installed Cinnamon desktop and this problem is NOT seen in Firefox Browser on that OS/Desktop.

Having said that, one could "assume" that the problem lies within Linux Mint, not Firefox or Cinnamon.

Will post this problem in the Mint forum.

So as far as Firefox is concerned, I guess we could consider the issue "resolved" but not fixed since that will have to be done by the Linux Mint group.

And BTW, Ubuntu 12.04 looks good with the Cinnamon desktop!  ;-) Probably a "keeper"!