Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 7.0 is not compatible with Angel Learning

  • No replies
  • 12 have this problem
more options

I work at a college that uses the Angel Learning service for online classes. Since upgrading to Firefox 7.0 I am unable to send inter-class mail using the Angel interface. I get script errors. While our help desk works on this, is there a way to download and reload Firefox 6.0?

I can successfully use IE 9 with Angel right now - is this my only recourse?