On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disabling dark mode

  • 9 replies
  • 1 has this problem
  • 17 views
  • Last reply by Paul

more options

With a new update that came out a little bit ago, firefox decided to match themes and dark/light mode. I don't like this. I use the darkfox theme, but like light mode for everything.

I previously changed browser.theme.content-theme, which fixed the content, but not toolbars/popups/etc.

Today I found out about browser.theme.toolbar-theme and changed that, which did make everything else light mode (temporarily).

It seems that the changes in about:config are tied to the theme as well. Every time I close firefox, the changes revert. When I switched the theme from darkfox to the default light theme, it changed the preferences to light mode, and when I went back to darkfox it changed the preferences to dark mode.

On darkfox, the preferences are: browser.theme.content-theme 2 browser.theme.toolbar-theme 0

On the light theme, they are: browser.theme.content-theme 1 browser.theme.toolbar-theme 1

Is there some way to unlink theme and preferences, or otherwise lock these two specific preferences so firefox stops trying to match my theme and dark mode?

With a new update that came out a little bit ago, firefox decided to match themes and dark/light mode. I don't like this. I use the darkfox theme, but like light mode for everything. I previously changed browser.theme.content-theme, which fixed the content, but not toolbars/popups/etc. Today I found out about browser.theme.toolbar-theme and changed that, which did make everything else light mode (temporarily). It seems that the changes in about:config are tied to the theme as well. Every time I close firefox, the changes revert. When I switched the theme from darkfox to the default light theme, it changed the preferences to light mode, and when I went back to darkfox it changed the preferences to dark mode. On darkfox, the preferences are: browser.theme.content-theme 2 browser.theme.toolbar-theme 0 On the light theme, they are: browser.theme.content-theme 1 browser.theme.toolbar-theme 1 Is there some way to unlink theme and preferences, or otherwise lock these two specific preferences so firefox stops trying to match my theme and dark mode?

All Replies (9)

more options

Try to enter 'about:config' in the URL bar and set layout.css.prefers-color-scheme.content-override = 2 or 1.

Helpful?

more options

Helpful?

more options

terry21 said

You could try userChrome.css. https://support.mozilla.org/en-US/questions/1364054#answer-1473397

So it only took me two weeks to respond -- boy, my work has been so busy that I haven't even had time to fix the most annoying thing that I see every time I turn on my computer.

Anyway, thanks for this, it helps in part. My menue bar (the one from the 3 little lines) is in light mode now, but my right-click menues are in dark, as is my history window still. Any further CSS things I could use to fix those? thanks!

Modified by natoboo101

Helpful?

more options

TyDraniu said

Try to enter 'about:config' in the URL bar and set layout.css.prefers-color-scheme.content-override = 2 or 1.

Unfortunately, no change from this.

Helpful?

more options

OK, try these. I am not using black on white but I have made those the colours. These don't affect the history window; perhaps ask about that on the FirefoxCSS sub on reddit. 'panelview' may also affect the 3 bar menu.

menupopup, panel {
  --panel-background: White !important;
  --panel-color: Black !important;
}
panelview {
  --arrowpanel-background: White !important;
  --arrowpanel-color: Black !important;
  color: Black !important;
}

Helpful?

more options

terry21 said

OK, try these. I am not using black on white but I have made those the colours. These don't affect the history window; perhaps ask about that on the FirefoxCSS sub on reddit. 'panelview' may also affect the 3 bar menu.
menupopup, panel {
  --panel-background: White !important;
  --panel-color: Black !important;
}
panelview {
  --arrowpanel-background: White !important;
  --arrowpanel-color: Black !important;
  color: Black !important;
}

Getting closer! My right-click menues are light mode now. History window is still dark though.

Helpful?

more options

As I said, you may have to ask on the reddit sub. I have never been able to find code for the library window in the time I have had available. The Browser Tool Box is supposed to help but it's a devil to use.

Helpful?

more options

terry21 said

As I said, you may have to ask on the reddit sub. I have never been able to find code for the library window in the time I have had available. The Browser Tool Box is supposed to help but it's a devil to use.

Yup, I'm asking the reddit now. Hopefully I can get something good.

Helpful?

more options

WARNING from the moderator team: userChrome.css scripts are not provided by Mozilla and is not officially supported. Firefox is a work in progress and, to allow for continuous innovation, Mozilla cannot guarantee future updates won’t impact your customizations. For this reason, Mozilla does not officially support style rules customization.

Please read Firefox advanced customization and configuration options to learn more.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.