חיפוש בתמיכה

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

IAOSS No Script plug-in, webpage opens when FF launched

  • 11 תגובות
  • 7 have this problem
  • 95 views
  • תגובה אחרונה מאת brynn2

more options

Hi Friends, Sometimes when I open FF, 2 tabs open. And this is not from restoring the last session, because actually I'm not sure how to do that. Anyway, it opens my homepage in one tab, and in the 2nd tab is Inform Action Open Source Software for the No Script add-0n. It opened automatically when I first installed the No Script add-on, and it opens from time to time spontaneously when I first launch FF (from desktop icon). This is the URL from the address field on that page: http://noscript.net/?ver=2.2.9&prev=2.2.8.

How can I stop that page from opening automatically, against my wishes?

I should say that I quite like that add-on, and use it frequently. I expect I will make a donation, if I continue to use it without any problems. But I don't appreciate the contant reminders, if that's what the purpose is. I just want to stop that page from opening without my wish or need to open it.

Thanks for your help :-)

פתרון נבחר

Many Add-ons, including NoScript, will open a new tab after an update so that the user can be informed of the changes. In your question, http://noscript.net/?ver=2.2.9&prev=2.2.8. , is the update page for NoScript from version 2.2.8 to version 2.2.9.

You can try changing a setting in NoScript to see if it stops that tab from loading after an update to NoScript (I have never used this myself, since I prefer to at least look at the update page; see NOTE below):

  1. click the NoScript icon and choose "Options"
  2. on the NoScript Options window, click the "Notifications" tab
  3. un-check "Display the release notes on updates" (last item on the display)

NOTE: I have found no explanation of that option; you can inquire about that item and any other NoScript questions at the NoScript forum:


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Read this answer in context 👍 0

כל התגובות (11)

more options

Check and tell if its working.


Not related to your problem but do the following:

-> Update Firefox to the latest version 10

-> Update All your Firefox Plugins -> https://www.mozilla.org/en-US/plugincheck/

  • When Downloading Plugins Update setup files, Remove Checkmark from Downloading other Optional Softwares with your Plugins (e.g. Toolbars, McAfee, Google Chrome, etc.)
more options

Ah, well I only had one homepage in the first place. But I did follow your instructions and restored the default. Then I reset the homepage.

Since this problem does not happen every time I start FF, I'll have to wait awhile to learn whether it's going to happen again. (I would say every 6 to 8 times I start FF, approx. this page comes up.)

Since that page wasn't a homepage, I'm guessing that resetting the homepage won't fix it. But I certainly will let you know.

Please don't mark this topic solved. I will return in a week and report.

Thank you very much :-)

more options

Hi again, Ok, so that did NOT solve the problem. But I may have a new clue.

Today when I opened FF (from desktop icon) I had to wait a moment for updates (which had been downloaded yesterday) to be installed. When it finished installing and opened, there again were 2 tabs -- one my homepage, and the active tab is the IAOSS No Script plug-in webpage.

I don't think that it always shows up after updating, but honestly, I'm not sure. It seems to me that it just happens spontaneously. Does anyone have any other ideas about this?

Please let me know if there is any info that you need from my system.

If no one still has any ideas what's causing this, or how to stop it, of course I will continue to pay close attention, and note and report to you anything that might help narrow down the problem/solution.

But I'm hoping someone will be able to explain/solve/fix?

Thanks for your help :-)

more options

Perform the suggestions mentioned in the following articles:

If Firefox again opens another tab (besides the default homepage) when you Start Firefox, perform the suggestions mentioned in the following article:

Check and tell if its working.

השתנתה ב־ על־ידי Hasan

more options

פתרון נבחר

Many Add-ons, including NoScript, will open a new tab after an update so that the user can be informed of the changes. In your question, http://noscript.net/?ver=2.2.9&prev=2.2.8. , is the update page for NoScript from version 2.2.8 to version 2.2.9.

You can try changing a setting in NoScript to see if it stops that tab from loading after an update to NoScript (I have never used this myself, since I prefer to at least look at the update page; see NOTE below):

  1. click the NoScript icon and choose "Options"
  2. on the NoScript Options window, click the "Notifications" tab
  3. un-check "Display the release notes on updates" (last item on the display)

NOTE: I have found no explanation of that option; you can inquire about that item and any other NoScript questions at the NoScript forum:


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

more options

Thanks for everyone's help.

I found the setting for "Display release notes on updates" and deselected that option. I'm not sure if that page was showing up after updates only. So I will have to just keep an eye on it, and notice if it happens again, and if it does, whether updates had just been installed.

If I haven't seen the page after 2 or 3 more weeks, I will assume the problem is solved, and then I will mark this topic solved. But until then, I won't be sure.

Thanks again for your help, and I will keep you posted :-)

more options

This problem appears to be solved :-)

Thanks again.

more options

Please take a few minutes to explain how the problem was resolved so that other users experiencing the problem that you originally posted might be informed as to the solution.

If you need to change your "Solved It" selection to make the solution more apparent to other users, please do so using the "Undo" button below the currently selected solution and choosing another solution to the problem.

Thanks.

more options

Well if you read the whole thread, it will be clear. But for those who want a quick answer, I said this, in my last reply before marking the topic solved:

"Thanks for everyone's help.

I found the setting for "Display release notes on updates" and deselected that option. I'm not sure if that page was showing up after updates only. So I will have to just keep an eye on it, and notice if it happens again, and if it does, whether updates had just been installed.

If I haven't seen the page after 2 or 3 more weeks, I will assume the problem is solved, and then I will mark this topic solved. But until then, I won't be sure.

Thanks again for your help, and I will keep you posted :-) "

By the way, why can I not stay logged in on this forum? I have cookies enabled, but every time I visit, I have to log in again! Thanks!

more options

I am very familiar with the prior replies, however, when other users are looking for a solution, marking your own reply "This problem appears to be solved :-)" is not the solution. Without reading the entire thread, other users would not know which of the previous replies actually solved the issue. You should mark the correct reply as the solution so that it is clear to other users.

  • An example: You take an exam consisting of 5 question. Your exam answer sheet is returned with a note at the bottom saying "4 incorrect, 1 correct" without markings on any of your test answers. So, how do you or anyone else know which one is correct?

Servers may time out a user after a period of inactivity to free up the server. Having a cookie in place is not a guarantee of an automatic log in.

more options

Sorry, I didn't realize that I had to mark the exact message. I thought I was marking the problem or the topic as solved, not which reply made the solution. I guess folks are just so lazy these days!