חיפוש בתמיכה

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

javascript not enabled; but it shows it is

  • 18 תגובות
  • 6 have this problem
  • 1 view
  • תגובה אחרונה מאת jenteller

more options

running: Windows XP, firefox 30.0, java version 7 update 60 (build1.7.0_60-b19) I get this message: This content requires JavaScript to be enabled. Turn your browser JavaScript settings on. When I go to about:config and search - JavaScript is showing enabled. Any ideas? (Besides updating WIndows? I'm working on that...)

כל התגובות (18)

more options

Is there a website you are trying to get to that is requiring the Javascript and is giving you the error? What is the URL so we can test.

השתנתה ב־ על־ידי cmosqueda

more options

Yes - I have to do some security stuff so I can accept credit cards for my job.It's the trustwave website.

more options

Oops. Here's the website - https://sagepayments.pci.trustwave.com

It also tells me that Flash player needs to be installed - that's been clean installed on my computer (version 14.0) and FireFox doesn't pick it up either.

more options

My guess is that making Flash visible will resolve the script error.

Adobe has two installers, one for IE (ActiveX control) and one for other browsers (Netscape-style plugin). Could you verify that you have the plugin used by Firefox? On 32-bit Windows XP, this should be stored in the following folder:

C:\Windows\System32\Macromed\Flash

There usually are several files, but the one used by Firefox will have a name that fits this pattern:

NPSWF32_14_0_0_125.dll

If that's not there, the installer may not have run to completion, or Adobe's site might have given you the ActiveX installer instead of the plugin installer.


Assuming that DLL is there, Firefox will find the plugin using a key in the Windows registry created by Adobe's installer.

By default, Firefox scans the registry at startup. However, this can be disabled. To make sure your Firefox is still scanning, you can double-check this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste scan and pause while the list is filtered.

(3) Make sure plugin.scan.plid.all preference is set to its default value of true, or double-click it to switch it from false to true.


If the DLL is there and Firefox is checking the registry, the problem may be that Firefox's plugin data file has become corrupted. To address that:

From inside Firefox, open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information

In the first table on the page, click the "Show Folder" button

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename pluginreg.dat to something like pluginreg.bad

Start Firefox back up again and Firefox should rebuild the file with a fresh registry scan.

more options

You talked about Java.

To avoid confusion:


Do you see the Flash plugin as installed and enabled (or at least "Ask to Activate") on the "Firefox/Tools > Add-ons > Plugins" page?

You can find the latest Flash player versions for Firefox on this page:

more options

Aargh. Jscher2000 - thank you so much. I checked everything that you listed & I also changed pluginreg.dat to pluginreg.bad. No difference. Plugin.sca.plid.all was set to true. Anything else to try?

more options

@cor-el - thanks for your help. I have un-installed flash player & done a clean install many times. Nothing seems to work.

more options

I have done a few test. I am on Windows 8 using Firefox 30 and the video seems to work in the modal.

I just happened to have a Windows XP machine floating around. Wow slow. I downloaded Firefox. I got the message in the modal that asks me to allow Flash to work. There is a small link in the modal I go that asks to allow the video to play. That seems to work for me. The video is playing. I am not getting any Javascript errors.

You could look at hosting your video on Youtube or Vimeo instead of using the Brightcove code to run the video.

more options

Hi jenteller

Do you see the Flash plugin on the "Firefox/Tools > Add-ons > Plugins" page?

more options

That is what my next question was going to be. Was to see if Flash was in the Plugins tab in Add-ons

more options

Cor-el & cmosqueda --

Flash / shockwave is NOT showing up in the plugins...how do I get it to show up?

Thank you!!

more options

@jenteller. Have you tried installing Adobe Flash on you machine?

http://get.adobe.com/flashplayer/

Try installing Flash and see if that works. After it installs. Restart Firefox and see if it is there again.

more options

You also might be able to manually choose which version you want if the Adobe site is not picking the correct one for you.

http://get.adobe.com/flashplayer/otherversions/

more options

You can find the latest Flash player versions for Firefox on this page:

more options

@cor-el - did a clean download of flash player from your link (I uninstalled flash player from control panel & then re-installed from your link) And then did a reboot. Firefox still doesn't show shockwave / flash at all and I'm asked to download it again. Thanks for your help.

more options

Shockwave for director is now showing in my plugins - there are two versions - 12.1.3.153 & versions 12.1.2.152 - should both be always activated or should one be deleted?

more options

Shockwave is not Flash, can you confirm you are actually installing Flash for Firefox

more options

@Tyler Downer - Yes, I am installing Flash for Firefox. It shows that I have the plug-in version. And, I thought that Shockwave was somehow related to Flash and how it functions. Thanks for looking at this for me!  :)