Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How to reconcile: "It is strongly recommended that you apply this update..." with "Unfortunately the latest version of Firefox isn't compatible ...."

  • 7 bhfreagra
  • 3 leis an bhfadhb seo
  • 37 views
  • Freagra is déanaí ó James

more options

"Firefox 3.6.22 It is strongly recommended ......"

Made to make the Web a better place

"Unfortunately the latest version ....."

Réiteach roghnaithe

Firefox 4 and later require at least OS X 10.5 and an Intel Mac.


If there are problems with updating or with the permissions then easiest is to download the full version and trash the currently installed version to do a clean install of the new version.

Download a new copy of the Firefox program and save the DMG file to the desktop

  • Trash the current Firefox application to do a clean (re-)install
  • Install the new version that you have downloaded

Your profile data is stored elsewhere in the Firefox Profile Folder, so you won't lose your bookmarks and other personal data.

Read this answer in context 👍 0

All Replies (7)

more options

Réiteach Roghnaithe

Firefox 4 and later require at least OS X 10.5 and an Intel Mac.


If there are problems with updating or with the permissions then easiest is to download the full version and trash the currently installed version to do a clean install of the new version.

Download a new copy of the Firefox program and save the DMG file to the desktop

  • Trash the current Firefox application to do a clean (re-)install
  • Install the new version that you have downloaded

Your profile data is stored elsewhere in the Firefox Profile Folder, so you won't lose your bookmarks and other personal data.

more options

Thank you for trying to help me.

Despite having used computers since 1986 (Commodore), I don't know enough to follow your instructions; e.g., what does DMG mean?

more options

On Mac Firefox comes as a disk image file (.dmg) that contains the Firefox application with all files.

See:

more options

Thanks, but my son solved the problem for me. He pointed out that my Mac is only 10.4, and I need 10.5 to upgrade Firefox!

more options

flemme

The current Firefox 3.6.22 update can be found at http://www.mozilla.com/en-US/firefox/all-older.html if the software updater is not updating you to it.

Firefox 3.6.22 is indeed compatible just like the 3.6.19 you are using http://www.mozilla.org/en-US/firefox/3.6/system-requirements/


You do need OSX 10.5 and newer if you want to use Firefox 4.0 and newer including the current 6.0.* release.