On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

PDFs download to unwanted directory when "Always Ask" is set

  • 1 freagra
  • 1 leis an bhfadhb seo
  • 6 views
  • Freagra is déanaí ó pg_78

more options

Steps to reproduce (FF 98.0.2 on Windows 10):

1) Set the Downloads directory to "Always ask you where to save files" (screenshot 1)

2) Set the handling choice for application/pdf to "Always ask" (screenshot 2)

3) Click on a link to a PDF file

4) In the dialog that pops up, choose "Open in Firefox" (screenshot 3)


Desired behaviour:

The PDF opens in Firefox, with a copy temporarily saved in the web cache (not in the filesystem).


Actual behaviour:

The PDF opens in Firefox, but a copy is saved in the greyed-out "default" directory from screenshot 1 (R:\Temp): see screenshot 4.


This seems wrong for two reasons:

i) The documented behaviour of Firefox is to save downloaded PDFs in the web cache, so that they get cleared when the cache is cleared.

ii) In screenshot 1, I've instructed Firefox to always ask me where to save files. But FF has instead assumed it can save files in a directory without asking me.


This can be sort-of worked around by changing the handling choice to "Open in Firefox". In that case, PDFs do seem to be stored in the cache, not in the filesystem. Then if I want to save a PDF, I can manually save it from the tab it opens in.

But is there a better way to fix this?

Steps to reproduce (FF 98.0.2 on Windows 10): 1) Set the Downloads directory to "Always ask you where to save files" (screenshot 1) 2) Set the handling choice for application/pdf to "Always ask" (screenshot 2) 3) Click on a link to a PDF file 4) In the dialog that pops up, choose "Open in Firefox" (screenshot 3) Desired behaviour: The PDF opens in Firefox, with a copy temporarily saved in the web cache (not in the filesystem). Actual behaviour: The PDF opens in Firefox, but a copy is saved in the greyed-out "default" directory from screenshot 1 (R:\Temp): see screenshot 4. This seems wrong for two reasons: i) The documented behaviour of Firefox is to save downloaded PDFs in the web cache, so that they get cleared when the cache is cleared. ii) In screenshot 1, I've instructed Firefox to always ask me where to save files. But FF has instead assumed it can save files in a directory without asking me. This can be sort-of worked around by changing the handling choice to "Open in Firefox". In that case, PDFs do seem to be stored in the cache, not in the filesystem. Then if I want to save a PDF, I can manually save it from the tab it opens in. But is there a better way to fix this?
Attached screenshots

All Replies (1)

more options

Now tracked on Bugzilla here: https://bugzilla.mozilla.org/show_bug.cgi?id=1762955

(in case anyone finds this and is interested)

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.