Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After 89.0.1 update on Windows, Firefox will not release the audio device, not allowing the computer to sleep.

more options

Since the 89.0.1 update on Windows 10 21H1 (Build 19043.1055), Firefox will not let my PC sleep, unless I quit and re-open Firefox. There is no audio playing on any tabs, but after a while of using Firefox on YouTube or whatnot, it will not release the audio device to let Windows put my monitors to sleep even though all playback has ended.

This can clearly be seen by running "powercfg /requests" as an administrator.

With videos playing, as expected Firefox reserves the audio device, as well as an Execution request.

Output: [ PS C:\WINDOWS\system32> powercfg /requests DISPLAY: [PROCESS] \Device\HarddiskVolume6\Program Files\Mozilla Firefox\firefox.exe display request

SYSTEM: [DRIVER] High Definition Audio Device (HDAUDIO\FUNC_01&VEN_10EC&DEV_0900&SUBSYS_10438581&REV_1000\4&2d156fef&0&0001) An audio stream is currently in use.

AWAYMODE: None.

EXECUTION: [PROCESS] \Device\HarddiskVolume6\Program Files\Mozilla Firefox\firefox.exe non-display request

PERFBOOST: None.

ACTIVELOCKSCREEN: None. ]

But after you stop playing the video the output becomes: [ PS C:\WINDOWS\system32> powercfg /requests DISPLAY: [PROCESS] \Device\HarddiskVolume6\Program Files\Mozilla Firefox\firefox.exe display request

SYSTEM: [DRIVER] High Definition Audio Device (HDAUDIO\FUNC_01&VEN_10EC&DEV_0900&SUBSYS_10438581&REV_1000\4&2d156fef&0&0001) An audio stream is currently in use.

AWAYMODE: None.

EXECUTION: None.

PERFBOOST: None.

ACTIVELOCKSCREEN: None. ]

You can see the audio device doesn't get released, and the only resolution is to quit and restart Firefox.

This doesn't always happen, but does happen after a while.

All Replies (3)

more options

Hi, - Try to disable "Use hardware acceleration when available." then restart Firefox - Try to disable Firefox add-ons then restart in Safe Mode or Refresh Firefox (restore Firefox settings to default) - Go to Setting -> System -> Sound -> App volume and device preferences, set the preferred output device on Firefox to Default then restart Firefox - Update your audio driver to latest version

  • If the problem still exists

- Uninstall Firefox, make sure the Firefox installation folder located in one of these folders is removed: C:\Program Files\Mozilla Firefox C:\Program Files (x86)\Mozilla Firefox - Go to Firefox official website to download latest version of Firefox

Helpful?

more options

None of that really makes sense, since this started after a Firefox update and Firefox isn't releasing the audio device. Windows thinks Firefox is still playing audio when it's not.

Restarting Firefox will fix this temporally, but a solution isn't erasing everything and starting over again, because one, it doesn't guarantee a fix, and two it doesn't tell us what the problem or the possible solution is.

What it DOES guarantee is a whole bunch of wasted time, and effort in having to set everything else up again, for likely no gain.

Helpful?

more options

I'm having this exact problem across multiple Windows machines. It used to be if I had an active tab like Youtube playing something it would prevent sleep as intended, but now it seems like it doesn't release the audio device or is opening it when it shouldn't be.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.