Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Addons are getting disabled automatically

  • 5 fhreagra
  • 1 leis an bhfadhb seo
  • 9 views
  • Freagra is déanaí ó FredMcD

more options

Looking for any help or advice,

I only use 2 addons in firefox, they are Bitdefender Wallet and Adblock and since the last Firefox update I cannot get either working. I can install adblock, it will work until the browser is closed, next time I open the browser it will be disabled with no option to re enable it and no explanation as to why it was disabled. I have tried a few addons as a test and after the browser is closed all will be automatically disabled. With Bitdefender wallet trying to install the extension results in an error of the download is corrupt.

I have used Firefox for years with both of these options and no errors. To try and fix I have reinstalled both Firefox and Bitdefender but the issue remains the same.

Current Firefox build is at 84.0.2

Any advise would be brilliant as I really do not want to resort to Chrome (which is working perfectly).

Many thanks.

Réiteach roghnaithe

Many thanks for all your help the issue now seems to be resolved.

From what I can tell since the last update it would seem that an old 32 bit version of firefox that was residing on my D drive (since 2015) had somehow been activated and was causing the issues. After todays automatic update to 64 bit 85.0 I was able to see the old 32 bit version inexplicably pop up, this led me to do a complete uninstall, registry clean and removal of the old 32 bit version from my D drive. After a fresh install all appears to be working perfectly again.

Many thanks for your time and efforts on this, they are truly appreciated.

Read this answer in context 👍 0

All Replies (5)

more options

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

Helpful?

more options

Many thanks for the response, I have tried all as suggested (twice) result is that addons stay active maybe for a day or so but are then automatically disabled again with no option to re enable.

I have once again uninstalled and re installed firefox and bitdefender to do complete refreshes of the apps and have tried multiple adblock software titles and the issue remains with all I have added.

Any further suggestions would be very welcome

Helpful?

more options

I called for more help.

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Helpful?

more options

Réiteach Roghnaithe

Many thanks for all your help the issue now seems to be resolved.

From what I can tell since the last update it would seem that an old 32 bit version of firefox that was residing on my D drive (since 2015) had somehow been activated and was causing the issues. After todays automatic update to 64 bit 85.0 I was able to see the old 32 bit version inexplicably pop up, this led me to do a complete uninstall, registry clean and removal of the old 32 bit version from my D drive. After a fresh install all appears to be working perfectly again.

Many thanks for your time and efforts on this, they are truly appreciated.

Helpful?

more options

That was very good work. Well Done.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.