Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

About opening a tab in a new tab (not new window) conveniently

  • 5 fhreagra
  • 2 leis an bhfadhb seo
  • 160 views
  • Freagra is déanaí ó qtluom

more options

I found when pressing Alt+Enter in the address bar, the link will open in a new tab, which is nice. But if I press Alt+click a link in the page, the link does not open in a new tab (while Shift+click can open in a new window as expected). I'm not sure if it's a problem, but I hope Firefox can have this feature so that opening a link in a new tab can be more convenient.

Besides, in some browsers, drag a link to a nearby place will open in a new tab. However, in Firefox, this manner does not work, unless I drag a link to the tabs bar.

All Replies (5)

more options

For opening a link in a new tab you need to hold down the Ctrl key and not the Alt key (Holding Alt can trigger a download action). You can also click the link with the mouse wheel to force opening the link in a new tab.

Helpful?

more options

Réiteach Roghnaithe

Helpful?

more options

Thanks. The link you provided helps a lot.

Helpful?

more options

I usually want ALL links to open in a new tab. Opening even one new window for link is confusing and inconvenient compared to having all just listed in the same window. Until this week there was no problem. In results from a Google search I would right click on the link and choose "Open link in new tab" or "Open link in new window" as I desired. It all worked. Now each time I choose "Open in new tab" I get instead a new window. I have tried several combinations of settings in about:config, tried using Ctrl-click and mouse wheel click as suggested in this and other forums. No joy. Please fix this. I believe it is a result of very recent update. I think I recall I accepted it as suggested by Mozilla, around 15 Apr 2021.

Helpful?

more options

Regarding previous post, the unwanted behavior seems to have disappeared. I am not sure why, I did not re-boot but only closed FF and restarted it, as I do every day but this time it behaves correctly.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.