Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't open html files without first closing Firefox (

more options

Everytime I try to open an html file, I need to first close Firefox. A message with the error message "Firefox is already running but is not responding the old firefox process must be closed" appears, and the file only opens if I select the "close" option. After the first time I do it, the problem stops and the next tries open the files without any issues. If I drag a html file to a firefox tab it also opens normaly, without any issue.

This problem started after I set up more than one profile in Firefox. The issue occur both on the default profile or other profiles.

Based on some advice I found online, I tried two solutions: - Run firefox with the -no-remote option. - Delete the parent.lock file on the profile folder.

Neither solved the problem.

Does anyone had a similar problem? Did you manage to solve it? It is a minor issue, but it happens every single day and gets very annoying.

I uploaded an screenshot of the error message that appears when I try to open the file for the first time. I also recorded a video for more details: https://imgur.com/a/P0Qpz8f

Attached screenshots

Réiteach roghnaithe

You need to run Firefox without the -no-remote command line switch because using this switch will hide this Firefox instance.
Also make sure that you do not have a MOZ_NO_REMOTE environment variable.

Read this answer in context 👍 1

All Replies (3)

more options

Réiteach Roghnaithe

You need to run Firefox without the -no-remote command line switch because using this switch will hide this Firefox instance.
Also make sure that you do not have a MOZ_NO_REMOTE environment variable.

Helpful?

more options

Hi cor-el, thanks for the reply.

It worked! I did test both with and without the -no-remote parameter before, but I messed up and the firefox shortcut on my taskbar kept the -no-remote parameter.

Helpful?

more options

Hello Gustavo:

There is an alternative way to do this.

I use windows 10. I assume from the screen shot you do also.

Right click the file you want to open. Select "Open with" then choose the Firefox shortcut. It will open the profile manager. From there you can choose whatever profile you want including the default profile.

I do page design and open html files directly from the folder they are held in. I can see the html file I open as I do this. The html file opens in a new window of an already open and running Firefox profile/ process. Again, note that when opening an html file by right click and going through the context menu there are no issues with using an already running process. You can open the files in a new window or a new tab of an already running process. Go into the option of firefox menu and on the general tab and toggle box with "Open links in tabs instead of new windows"

Athraithe ag GIlbert Bigelow ar

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.