Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox not displaying icons on some webpages correctly like magnifying glass icons?

  • 4 fhreagra
  • 1 leis an bhfadhb seo
  • 2174 views
  • Freagra is déanaí ó speedery

more options

Hello,

I have a weird issue with firefox, it shows icons incorrectly on some webpages like magnifying glass icons and arrows, but it shows text instead of icons. a wrong image. a correct image.

Attached screenshots

Réiteach roghnaithe

hello speedery,

Those missing icons are actually supplied by a font that is downloaded from the server (@font-face) as you can see by the little boxes that show the hex code of the characters.

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

Make sure that you allow pages to choose their own fonts.

Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

I hope resolve your problem then reply back to me .

Thank you

Read this answer in context 👍 2

All Replies (4)

more options

Réiteach Roghnaithe

hello speedery,

Those missing icons are actually supplied by a font that is downloaded from the server (@font-face) as you can see by the little boxes that show the hex code of the characters.

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

Make sure that you allow pages to choose their own fonts.

Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

I hope resolve your problem then reply back to me .

Thank you

more options

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

   Click the menu button New Fx Menu and click History button, and then Clear Recent History... .
   Under "Time range to clear", select "Everything".
   Now, click the arrow next to Details to toggle the Details list active.
   From the details list, check Cache and Cookies and uncheck everything else.
   Now click the Clear now button. 

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

more options

Hello...


Those missing icons are actually supplied by a font that is downloaded from the server (@font-face) as you can see by the little boxes that show the hex code of the characters.

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

Make sure that you allow pages to choose their own fonts.

   Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" 

thank you..

more options

ARMAN KHAN said

hello speedery, Those missing icons are actually supplied by a font that is downloaded from the server (@font-face) as you can see by the little boxes that show the hex code of the characters. You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value). Make sure that you allow pages to choose their own fonts. Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" I hope resolve your problem then reply back to me . Thank you

Thank you, it works.