Search Support

Latest reason why the "don't let Flash run automatically" decision was a FAIL

  • 12 freagra
  • 1 leis an bhfadhb seo
  • 45 views
  • Freagra is déanaí ó Kymber

more options

Once again, we have a new release (74.0). Once again, the developers who believe themselves to be gods do not think users should be allowed to set Firefox to allow Flash on specific sites without asking EVERY SESSION, somehow believing that inconveniencing the users is somehow going to force website admins to move away from Flash before the announced deprecation at the END of the year.

Now one of my daily-visited sites (the one for Daily Jumble) will not wait for me to enable Flash, and when I do enable it I then have to refresh the page to make it work. It is obvious that if what I have been asking for all along -- being able to tell Firefox to enable Flash always FOR THIS SITE ONLY -- would alleviate the problem, but since the gods cannot see through the eyes of the users, I am now further inconvenienced by their decision.

I maintain that they moved too quickly and too drastically to implement this change, and I have no reason to believe posting this will make any difference, but I again want them to know that instead of Firefox being the most user-friendly browser in the world (as it USED to be) it now has enough user-UNfriendliness to be as despised as Internet Explorer was.

I do not believe it to be an unreasonable request to allow this, because they could simply put that functionality in, then take it out along with all Flash support in the first release of 2021. But they think they know better. Sorry, guys, but you DO NOT.

Réiteach roghnaithe

Your policies.json isn't valid JSON as you can see under errors and you should also use one Allow key with the value being an array of origins (scheme + host). Try this code:

{
  "policies": {
    "FlashPlugin": {
     "Allow": ["http://www.shockwave.com/","https://www.jumble.com/","http://www.uclickgames.com/","https://www.mindgames.com/"]}
  }
}
Read this answer in context 👍 1

All Replies (12)

more options

https://support.mozilla.org/en-US/forums/support-forum-contributors/713656 Filed a Bug Report - Users complaining of removing Always Allow for flash player

Helpful?

more options

Thanks, Fred, but I note that all of the conversation on that bug ended back in December, and this is now March with the developers apparently unwilling to make the change, even though it was pointed out how simple it would be to add the function in about:config and then delete that line when Flash fully deprecates.

This just proves their attitude is "never mind the users, WE know what's right and wrong." Arrogance of the highest order going on there.

Helpful?

more options

Hello Kymber,

Well, you said you would keep doing this and here you are again .....

https://support.mozilla.org/en-US/questions/1279705

Please, talk to the sites that still use Flash; talk to Adobe, but don't blame Firefox, the browser that is only doing what every other browser is doing.

Granted, Firefox could have made life a little easier for users with a preference that can be set to always allow Flash, which no other browser does, so why should Mozilla developers go through all the trouble just for a few more months ?

It will be the end-of-life for Flash at the end of this year and maybe even sooner.

Again : it's the sites that still use Flash you should be talking to if you want to see this annoyance gone.

Helpful?

more options

Replying in order: Yes, I said I'd be back and I am, but I am still trying to be reasonably polite about the whole thing.

Yes, the developers could have done this, and the "why" is because that would have set Firefox apart from the rest as being the most user-friendly browser available. It could have been done as easily as you suggested in that bug report ... but NO, they think they know better. I just want to keep pointing that out. It still strikes me as arrogance.

I have contacted the sites. And all I get is a template e-mail reply that the sites will be compliant "by the time Flash deprecates in December". So I have the exact same problem with them. The inconvenience to the users ranks low on the list. (They're probably more worried about finding ways around ad blockers.)

So for me, it's about needing to vent because I'm still being inconvenienced when I know it could have been handled differently if the developers had wanted to be responsive to actual use patterns. Sure, all the browsers are doing it. Firefox could have stood apart and stood with its users.

End of polite rant.

Helpful?

more options

Oh, and I even tried that fix in the bug report by creating that .json file allowing Flash to auto-run. Firefox recognizes that I have given special permissions (the little icon shows up in the address window) but the prompt to run Flash still happens. So either I did something wrong or this version of Firefox doesn't accept that permission as valid.

Helpful?

more options

To be continued ......

(which will be April 7, I guess)

https://wiki.mozilla.org/Release_Management/Calendar

Helpful?

more options

Helpful?

more options

Yes, that is what I have tried. I must have made an error in creating the policies.json file because even though Firefox is reading it (at least that means I have it in the correct folder!) Flash is not being auto-allowed at the sites I specified.

If a user who has some working knowledge about these things has trouble implementing this, the average user is essentially screwed. This could have been so simple ...

But thank you for trying to help.

Helpful?

more options

Can you post the content of policies.json ?

Are there active policies or errors shown on the about:policies page ?

Do other policies you add to the file work ?

Helpful?

more options

Sure ... maybe you can tell me where I must have erred.

{

 "policies": {
   "FlashPlugin": {
     "Allow": ["http://www.shockwave.com/"]
     "Allow": ["https://www.jumble.com/"]
     "Allow": ["http://www.uclickgames.com/"]
     "Allow": ["https://www.mindgames.com/"]
   }
 }

}

---

about:policies "The Enterprise Policies service is inactive." and under Errors, Error parsing JSON file

I sort of knew about that error (or at least suspected it) since it wasn't working.  :D

---

I have no other policies, so can't answer the third question.

Helpful?

more options

Réiteach Roghnaithe

Your policies.json isn't valid JSON as you can see under errors and you should also use one Allow key with the value being an array of origins (scheme + host). Try this code:

{
  "policies": {
    "FlashPlugin": {
     "Allow": ["http://www.shockwave.com/","https://www.jumble.com/","http://www.uclickgames.com/","https://www.mindgames.com/"]}
  }
}

Helpful?

more options

See? I was right in presuming the policies.json file didn't work because I made mistakes. (I always presume I will make mistakes when I'm doing something unfamiliar. Safer to make that presumption.)

I replaced the content with a cut-and-paste of your code. It worked.

Thank you for the assist. It is very, very much appreciated. Now I can shut up (much to McCoy's relief, no doubt).

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.