X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

YouTube will not load - "Secure Connection Failed" Error

Postáilte

YoueTube will not load in FireFox - it gives error:-


Secure Connection Failed

An error occurred during a connection to www.youtube.com. You are attempting to import a cert with the same issuer/serial as an existing cert, but that is not the same cert.

Error code: SEC_ERROR_REUSED_ISSUER_AND_SERIAL

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the web site owners to inform them of this problem.

However, YouTube works OK in Chrome and IE11.

It used to work OK until recently. Are there some settings that require changing ?

The version is 72.0.2 (64-bit)

Regards,

Nick.

YoueTube will not load in FireFox - it gives error:- ----- Secure Connection Failed An error occurred during a connection to www.youtube.com. You are attempting to import a cert with the same issuer/serial as an existing cert, but that is not the same cert. Error code: SEC_ERROR_REUSED_ISSUER_AND_SERIAL The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the web site owners to inform them of this problem. ---- However, YouTube works OK in Chrome and IE11. It used to work OK until recently. Are there some settings that require changing ? The version is 72.0.2 (64-bit) Regards, Nick.
Luaigh

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Shockwave Flash 32.0 r0

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

Tuilleadh Eolais

jscher2000
  • Top 10 Contributor
8873 réiteach 72604 freagra

Hi Nick, you should not get the SEC_ERROR_REUSED_ISSUER_AND_SERIAL code with real website certificates from well-run sites, but that may appear for certificates generated by another source. Do you know whether your browsing is proxied, filtered or otherwise intercepted by a "man in the middle"?

This article has examples of common security software that may intercept your browsing: How to troubleshoot security error codes on secure websites.

It might provide a clue to check the issuer shown while you are viewing a page on this site. Normally, if you call up the certificate using, for example

  • right-click a blank area of the page and choose View Page Info > Security > View Certificate button
  • (menu bar) Tools menu > Page Info > Security > View Certificate button

It will show the issuer is Amazon (because the site runs on the Amazon cloud). Does yours agree?

Hi Nick, you should not get the SEC_ERROR_REUSED_ISSUER_AND_SERIAL code with real website certificates from well-run sites, but that may appear for certificates generated by another source. Do you know whether your browsing is proxied, filtered or otherwise intercepted by a "man in the middle"? This article has examples of common security software that may intercept your browsing: [[How to troubleshoot security error codes on secure websites]]. It might provide a clue to check the issuer shown while you are viewing a page on this site. Normally, if you call up the certificate using, for example * right-click a blank area of the page and choose View Page Info > Security > View Certificate button * (menu bar) Tools menu > Page Info > Security > View Certificate button It will show the issuer is Amazon (because the site runs on the Amazon cloud). Does yours agree?
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

Hello,

There is no View Certificate Button on the YouTube failed page - see screenshot.

I did one on Google and the View Certificate Button and details are there to be seen - see screenshot.

Hello, There is no View Certificate Button on the YouTube failed page - see screenshot. I did one on Google and the View Certificate Button and details are there to be seen - see screenshot.
An bhfuil an freagra seo cabhrach?
Luaigh
jscher2000
  • Top 10 Contributor
8873 réiteach 72604 freagra

The one for Google definitely points to Kaspersky, but if other secure sites are working normally, then your Firefox is already set up to work with Kaspersky's fake certificates.

Let's see whether you have an old "exception" saved for YouTube. Here's how:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type cert and Firefox should filter to the "Certificates" section. Click the "View Certificates" button to launch the Certificate Manager.

There are several tabs here; click the one labeled Servers and see whether you have anything saved for YouTube. If so, select and Delete it. (Please ignore the ones with asterisks, those are blocks that come with Firefox.)

Anything there?


More generally:

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

The one for Google definitely points to Kaspersky, but if other secure sites are working normally, then your Firefox is already set up to work with Kaspersky's fake certificates. Let's see whether you have an old "exception" saved for YouTube. Here's how: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''cert'' and Firefox should filter to the "Certificates" section. Click the "View Certificates" button to launch the Certificate Manager. There are several tabs here; click the one labeled '''Servers''' and see whether you have anything saved for YouTube. If so, select and Delete it. (Please ignore the ones with asterisks, those are blocks that come with Firefox.) Anything there? ---- More generally: '''Cache and Cookies:''' When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that. In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help?
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

Hello,

Seems we are getting near to curing this.

There was no certificates in the Servers tab relating to YouTube.

In Cookies and Site Data I selected the Clear Data.

After this YouTube loaded OK. I could close FireFox and re-start and it was still OK.

However, after shuting down the computer and re-starting the problem came back. Using Clear Data got it working again.

Something I forgot to mention at first was that for a while when I first start FireFox I get the same Secure Connection Failed message. I have the Home page set to Google. If I then close FireFox and re-start it Google loads OK but YouTube fails, but will run if I use the Clear Data button which I now know about thanks to your answer.

Thinking about it, the problem with YouTube probably started at the same time the issue with the home page (Google) failing on start up of FireFox for the first time after the computer has been switched on.

Hello, Seems we are getting near to curing this. There was no certificates in the Servers tab relating to YouTube. In Cookies and Site Data I selected the Clear Data. After this YouTube loaded OK. I could close FireFox and re-start and it was still OK. However, after shuting down the computer and re-starting the problem came back. Using Clear Data got it working again. Something I forgot to mention at first was that for a while when I first start FireFox I get the same Secure Connection Failed message. I have the Home page set to Google. If I then close FireFox and re-start it Google loads OK but YouTube fails, but will run if I use the Clear Data button which I now know about thanks to your answer. Thinking about it, the problem with YouTube probably started at the same time the issue with the home page (Google) failing on start up of FireFox for the first time after the computer has been switched on.
An bhfuil an freagra seo cabhrach?
Luaigh
jscher2000
  • Top 10 Contributor
8873 réiteach 72604 freagra

Do you use multiple network connections? For example, your regular connection and a VPN? Just wondering whether cached data or cookies from one network might be incompatible with connecting on the other network.

Do you use multiple network connections? For example, your regular connection and a VPN? Just wondering whether cached data or cookies from one network might be incompatible with connecting on the other network.
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

Just normal with a Draytek router - no VPN.

Just normal with a Draytek router - no VPN.
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

I.ve found a workaround that seems to be working at the moment.

I have changed the Home Page from Google to another site.

On the last three computer switch ons Firefox has not displayed the Secure Connection Failed Page and has loaded the new site correctly.

I can then open YouTube with no problems.

When I set the Home Page back to Google the problem returns.

So for some reason something has changed that prevents FireFox working when Google is the Home Page.

For the time being I will leave it with a different site on the Home Page and monitor what happens over the next few weeks. Maybe I will try setting the Home Page back to Google after a while to see if it will work OK, but somehow I suspect it will fail again.

Interesting problem - Chrome and IE11 work OK and both have Google as the Home Page. Pity - FireFox is my favourite browser....

I.ve found a workaround that seems to be working at the moment. I have changed the Home Page from Google to another site. On the last three computer switch ons Firefox has not displayed the Secure Connection Failed Page and has loaded the new site correctly. I can then open YouTube with no problems. When I set the Home Page back to Google the problem returns. So for some reason something has changed that prevents FireFox working when Google is the Home Page. For the time being I will leave it with a different site on the Home Page and monitor what happens over the next few weeks. Maybe I will try setting the Home Page back to Google after a while to see if it will work OK, but somehow I suspect it will fail again. Interesting problem - Chrome and IE11 work OK and both have Google as the Home Page. Pity - FireFox is my favourite browser....
An bhfuil an freagra seo cabhrach?
Luaigh
Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.