Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Suddenly always redirecting to https

  • 4 fhreagra
  • 15 leis an bhfadhb seo
  • 30034 views
  • Freagra is déanaí ó GPraz

more options

I am running a local apache server for website development. I have always accessed these local sites with http://

Suddenly today firefox is redirecting to https:// and I receive the "Secure Connection Failed" error.

I have completely removed the firefox profile by deleting the ~/.mozilla and ~/.cache/mozilla directories, but the problem persists.

I have set browser.urlbar.autoFill to false, but the problem persists.

I am not running any extensions or add ons.

No changes to the apache configuration have been made.

No system updates have been installed since it was working yesterday.

Even with apache stopped, the local sites still immediately redirect to https://

The sites are directed to localhost via the /etc/hosts file, for example: 127.0.0.1 examplelocalsite.dev

I have restarted the computer and the problem persists.

The problem is not occurring in Chrome.

The problem is not occurring with external http:// websites.

I am not running any type of security software other than a basic firewall configuration with ufw

The problem persists with ufw disabled.

I have purged the firefox installation with apt purge firefox and reinstalled fresh but the problem persists.

Athraithe ag tekhi ar

Réiteach roghnaithe

hi, in case you're using a .dev domain as local development environment - that's a top level domain belonging to google and enforcing a valid ssl certificate since recently: https://ma.ttias.be/chrome-force-dev-domains-https-via-preloaded-hsts/ https://medium.engineering/use-a-dev-domain-not-anymore-9521977

Read this answer in context 👍 6

All Replies (4)

more options

Réiteach Roghnaithe

hi, in case you're using a .dev domain as local development environment - that's a top level domain belonging to google and enforcing a valid ssl certificate since recently: https://ma.ttias.be/chrome-force-dev-domains-https-via-preloaded-hsts/ https://medium.engineering/use-a-dev-domain-not-anymore-9521977

more options

That was it. Strange that it is working in chrome since google is responsible.

Athraithe ag tekhi ar

more options

Hi the solution is simple and it's detailed here : How to prevent firefox from redirecting to https. Be cafeful as you will be modifiying sensitive configuration.

more options

philipp said

hi, in case you're using a .dev domain as local development environment - that's a top level domain belonging to google and enforcing a valid ssl certificate since recently: https://ma.ttias.be/chrome-force-dev-domains-https-via-preloaded-hsts/ https://medium.engineering/use-a-dev-domain-not-anymore-9521977

It took me 3 hours before I finally found this answer. Too bad they published this in the end of 2017; my colleagues was having problem why their local .dev host suddenly stopped working.

Athraithe ag GPraz ar