Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Want to overturn a SSL_ERROR_INTERNAL_ERROR_ALERT error

  • 7 bhfreagra
  • 3 leis an bhfadhb seo
  • 14623 views
  • Freagra is déanaí ó cor-el

more options

http://i.imgur.com/pzgtxcr.png Let me be clear, I know this website, I don't give any single fuck about any potential security issue, the website doesn't even have any auth, I just want to access to it and i don't CARE about security for that. I think a browser should let me overturn security alerts and doesn't have the right to block me from doing something if I really want to.

Thanks

Réiteach roghnaithe

Do you use any add-ons that force HTTPS, such as HTTPS Everywhere? If so, you need to make an exception for sites that are not set up to use HTTPS.


If this problem is not caused by an add-on:

Possibly Firefox has mistakenly stored an instruction from the server to switch to HTTPS (HSTS). You can remove the file that stores those instructions to see whether that fixes it. Here's how, apologies that I only know the names in English:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename SiteSecurityServiceState.txt to something like SiteSecurityServiceState-old.txt (just in case you decide you want to restore it).

Start Firefox back up again. If the site does not once again demand you use HTTPS, then you should be able to access it using HTTP now.

Read this answer in context 👍 1

All Replies (7)

more options

This is an unfamiliar error to me, an internal error on the server. I think the server is not set up to use HTTPS.

Try editing the URL in the address bar from https to http and then load it that way.

more options

Thanks for answering! It turns it into https again, and fai. I tried to add an exemption but it refuses to do it http://i.imgur.com/IID2ItL.png

more options

Réiteach Roghnaithe

Do you use any add-ons that force HTTPS, such as HTTPS Everywhere? If so, you need to make an exception for sites that are not set up to use HTTPS.


If this problem is not caused by an add-on:

Possibly Firefox has mistakenly stored an instruction from the server to switch to HTTPS (HSTS). You can remove the file that stores those instructions to see whether that fixes it. Here's how, apologies that I only know the names in English:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename SiteSecurityServiceState.txt to something like SiteSecurityServiceState-old.txt (just in case you decide you want to restore it).

Start Firefox back up again. If the site does not once again demand you use HTTPS, then you should be able to access it using HTTP now.

Athraithe ag jscher2000 ar

more options

It worked! I just removed the line matching the website in the file you quoted, and then relaunched firefox. Thanks a lot, I would have never guessed this kind of configuration was stored in a file.

Thanks!

more options

I have no problems using Firefox to access

  1. syriancivilwararchive.com/Videos
  2. But I do get a problem with
    https://syriancivilwararchive.com/Videos
    • error An error occurred during a connection to syriancivilwararchive.com. Peer reports it experienced an internal error. Error code: SSL_ERROR_INTERNAL_ERROR_ALERT

Sorry but I do not fully understand that error. However you could try the first link above. That works for me. Does it work for you ?

Of course the error could be meaningful. You may know and trust the site you think you are connecting to, but you may in fact be connecting to something else. I suppose the most likely explanation is that the site is old and not secure and is having a problem with connecting securely with Firefox.

more options

I have the same issues for the same links that you. My non educated guess is that the owner tried to set up a certificate and it failed.. I should contact him with a link to this discussion for his certificate

more options

The server doesn't seem to have SSL configured, so you can only access this server via an open HTTP connection.