Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

untrusted connection! (On Google)

  • 23 freagra
  • 5 leis an bhfadhb seo
  • 125 views
  • Freagra is déanaí ó LMAO

more options

When I try to search up something on Google form the taskbar, it says Untrusted connection, and it doesn't allow you to "Understand The Risks" and continue through. I don't know what it's happening. I just updated firefox, and I also refreshed it and it still doesn't work. When I go to Google.com, it loads, but as soon as I search for something on the site, it appears glitched and the other features of it such as Images, Videos, News, Search tools, automatically takes me to Untrusted Connection.

Athraithe ag cor-el ar

Réiteach roghnaithe

Thanks for everyone's effort in trying to help me, I was never able to fix the problem but since reinstalling the issue is gone. thanks again.

Read this answer in context 👍 0

All Replies (20)

more options

There is security software like Avast and Kaspersky and BitDefender that intercept secure connections and send their own certificate.

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

more options

Generally speaking, you should not need to create security exceptions in Firefox, especially on mainstream sites. The fact that you are familiar with how to do it suggests that you have a pattern of secure connection problems.

When you get this for pretty much all secure sites, the problem usually is one of the following:

(1) Error in your system's date, time, or time zone, which throws off certificate validity checks. Sometimes allowing computers to use an internet-based time source can introduce this problem.

(2) Firefox not being set up to work with your security software that intercepts and filters secure connections. Products with this feature include Avast, BitDefender, ESET, and Kaspersky; AVG has a Search Shield feature which can cause this error on search sites.

(3) On Windows 10, Firefox not being set up to work with the parental control software Microsoft Family Safety.

(4) Malware on your system intercepting secure connections.

So... which is it?

If you have any of those specific security products, that would be the first thing to check. We might be able to assist with specific next steps based on what you have if you tell us.


To investigate further, try viewing certificates you saved as exceptions to see whether they reveal the culprit. You can open the Certificate Manager here:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Advanced Options panel, there is a row of mini-tabs along the top. Click the Certificates mini-tab, and then the View Certificates button.

That should open the Certificate Manager. Click the "Servers" tab to find site-specific exceptions. Ignore the ones where the server is designated as "*", those were not ones you added. Select one for a site you recognize and click the View button. Then inspect the "Issued by" and "Certificate Hierarchy" for clues.

more options

Did you check the issuer of the certificate via the above posted steps?

more options

cor-el said

There is security software like Avast and Kaspersky and BitDefender that intercept secure connections and send their own certificate. If you can't inspect the certificate via "I Understand the Risks" then try this: Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:
  • chrome://pippki/content/exceptionDialog.xul
In the location field of this window type or paste the URL of the website.
  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer
You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

Here's what I saw..

more options

Hi LMAO, unless you intentionally installed the Fiddler software from Telerik, you probably have a malware program like Browser Safeguard which is intercepting all of your browsing.

Open the Windows Control Panel, Uninstall a Program. After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Look for unknown titles, and take out as much trash as possible.

more options

thanks for the reply, I'll try uninstalling the most recent stuff. I'll let you know if it solves my problem

more options

Okay, I tried uninstalling the recent stuff I've installed, whether I thought it could have had something on it or not, and now Google.com won't even load, it just eventually goes to connection has timed out.

Also I downloaded malewarebytes and did a scan, it found nothing.

So any other ideas?

more options

LMAO said

cor-el said
There is security software like Avast and Kaspersky and BitDefender that intercept secure connections and send their own certificate. If you can't inspect the certificate via "I Understand the Risks" then try this: Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:
  • chrome://pippki/content/exceptionDialog.xul
In the location field of this window type or paste the URL of the website.
  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer
You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

Here's what I saw..


Okay, I tried uninstalling the recent stuff I've installed, whether I thought it could have had something on it or not, and now Google.com won't even load, it just eventually goes to connection has timed out.

Also I downloaded malewarebytes and did a scan, it found nothing.

So any other ideas?

more options

Hey LMAO,Try Clearing your search history now and see.

more options

Roopak said

Hey LMAO,Try Clearing your search history now and see.

still not working, and it also went back to Untrusted Connection. I'm getting nowhere! :(

more options

What is the scope of the current problem:

  • Only Google cannot connect
  • No secure sites can connect
  • Firefox is completely unable to connect to anything

Some classic "Google redirect" viruses use a rootkit, so it is worth also running this scanner from Kaspersky: Anti-rootkit utility TDSSKiller.

more options

jscher2000 said

What is the scope of the current problem:
  • Only Google cannot connect
  • No secure sites can connect
  • Firefox is completely unable to connect to anything
Some classic "Google redirect" viruses use a rootkit, so it is worth also running this scanner from Kaspersky: Anti-rootkit utility TDSSKiller.

Hey thanks for the quick replies, I really appreciate it, I'll try that Anti-rootkit.

more options

jscher2000 said

What is the scope of the current problem:
  • Only Google cannot connect
  • No secure sites can connect
  • Firefox is completely unable to connect to anything
Some classic "Google redirect" viruses use a rootkit, so it is worth also running this scanner from Kaspersky: Anti-rootkit utility TDSSKiller.

Okay I downloaded that software and tried it but suddenly my pc was freezing up, I finally had to restart my pc but then it wouldn't start up right, it was going to the desktop but not finishing loading the toolbar and freezing. Finally I had to do a system restore to get the software off my pc. So I don't think I'll be downloading that software again. any other suggestions? BTW I have Eset Smart Security 8 and I already ran a scan on it as well as MalewareBytes scan.

more options

Hmm, that's strange, I've never heard of that happening before with TDSSKiller.

So what is the current status of which sites Firefox can connect to, if any?

more options

You could try to run the program in Windows Safe Mode. Such a hang in a security program could indicate a more serious malware problem. You might want to take this to a malware oriented forum just to be sure.

more options

jscher2000 said

Hmm, that's strange, I've never heard of that happening before with TDSSKiller. So what is the current status of which sites Firefox can connect to, if any?

Hmm, Well I can get into pretty much any other site, besides most search engines, such as Yahoo, Bing, and Google all are messed up in some way.

more options

LMAO said

jscher2000 said
Hmm, that's strange, I've never heard of that happening before with TDSSKiller. So what is the current status of which sites Firefox can connect to, if any?

Hmm, Well I can get into pretty much any other site, besides most search engines, such as Yahoo, Bing, and Google all are messed up in some way.

It's starting to get annoying, I'm thinking about just backing up my laptop and reinstalling windows on it.

more options

Do you want to try this three-minute experiment first?

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager using Start > search box (or Run):

firefox.exe -P

Don't delete anything here!

Any time you want to switch profiles, exit Firefox and return to this dialog.

Click the Create Profile button, assign a name like TEST111615, and skip the option to relocate the profile folder. After creating the profile, select it and start Firefox in that profile.

Any difference with search engines?

When returning to the Profile Manager, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

more options

You can try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

You can use this button to go to the current Firefox profile folder:

Firefox will rebuild the search.json file from the default built-in search engines that come with Firefox and the searchplugins folder in the Firefox profile folder.

more options

jscher2000 said

Do you want to try this three-minute experiment first? Create a new Firefox profile A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder. Exit Firefox and start up in the Profile Manager using Start > search box (or Run): firefox.exe -P Don't delete anything here! Any time you want to switch profiles, exit Firefox and return to this dialog. Click the Create Profile button, assign a name like TEST111615, and skip the option to relocate the profile folder. After creating the profile, select it and start Firefox in that profile. Any difference with search engines? When returning to the Profile Manager, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

I'll let you know how it works out.

  1. 1
  2. 2