Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Rechercher dans l’assistance

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot open .jnlp file when asked to open with firefox web browser in ubuntu 11.10 using firefox 6

  • 2 réponses
  • 210 ont ce problème
  • 68723 vues
  • Dernière réponse par mrguga

more options

After upgrading to ubuntu 11.10 the firefox 6 browser cannot download and open .jnlp file from the interactivebrokers website. Usually I go to the IB website and download tws.jnlp file which is opened in the firefox web browser. But now when I click on the Open with Firefox Browser button, the firefox browser opens a new tab and display the same open window again.

Solution choisie

Seems that after upgrading to 11.10, jnlp files open with firefox instead of javaws (Java Web Start). If you right click the file on the download folder and choose "open with" you can manually select java web start. Ubuntu bug...

You can right click any .jnlp file and select "properties", go to "Open With" tab, mark Sun Java 6 Web Start and click "Set as Default". Should fix it. I don't know what would happen if you have the default ubuntu java instead of Sun's. Maybe this wouldn't be necessary.

Lire cette réponse dans son contexte 👍 30

Toutes les réponses (2)

more options

Solution choisie

Seems that after upgrading to 11.10, jnlp files open with firefox instead of javaws (Java Web Start). If you right click the file on the download folder and choose "open with" you can manually select java web start. Ubuntu bug...

You can right click any .jnlp file and select "properties", go to "Open With" tab, mark Sun Java 6 Web Start and click "Set as Default". Should fix it. I don't know what would happen if you have the default ubuntu java instead of Sun's. Maybe this wouldn't be necessary.

Modifié le par mrguga

more options

delete this...

Modifié le par mrguga