Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Dead keys not working only in a specific profile

  • 1 réponse
  • 0 a ce problème
  • 1 vue
  • Dernière réponse par Kazuma

more options

Today I noticed that typing characters with accents like á, ã, â, etc. doesn't seem to work at all from firefox, they all end up ignoring the dead key and just typing the letter itself. It can render them just fine and I can paste them from another app normally too, but actually typing them is impossible from firefox.

After trying to troubleshoot, I eventually found out a few things: - iBus is not at fault, since it works in every other app and I even restarted it, but the problem persists - This only happens in my main profile, newly created profiles don't have that problem - The problem still happens on troubleshoot mode (as long as it is my main profile) - Compose key also doesn't work (I don't want to use compose key anyway, because my keyboard has specialized dead keys, but I at least tried it)

I suspect the problem lies in a setting on about:config that's different from newly created profiles, but I have no idea which and Ctrl+F searching this site doesn't show any relevant configuration that might be the culprit.

Today I noticed that typing characters with accents like á, ã, â, etc. doesn't seem to work at all from firefox, they all end up ignoring the dead key and just typing the letter itself. It can render them just fine and I can paste them from another app normally too, but actually typing them is impossible from firefox. After trying to troubleshoot, I eventually found out a few things: - iBus is not at fault, since it works in every other app and I even restarted it, but the problem persists - This only happens in my main profile, newly created profiles don't have that problem - The problem still happens on troubleshoot mode (as long as it is my main profile) - Compose key also doesn't work (I don't want to use compose key anyway, because my keyboard has specialized dead keys, but I at least tried it) I suspect the problem lies in a setting on about:config that's different from newly created profiles, but I have no idea which and Ctrl+F searching [https://kb.mozillazine.org/About:config_entries this site] doesn't show any relevant configuration that might be the culprit.

Solution choisie

It turned out that the problem was the focusmanager.testmode setting set to true because of Flutter or something. Setting it to default (false) solved the problem.

I found this setting was the problem by cloning my profile and repeatedly deleting a bunch of settings in prefs.js, opening the cloned profile with the changes and closing when the problem persisted.

Leaving this short issue here for the next confused person. :)

Lire cette réponse dans son contexte 👍 1

Toutes les réponses (1)

more options

Solution choisie

It turned out that the problem was the focusmanager.testmode setting set to true because of Flutter or something. Setting it to default (false) solved the problem.

I found this setting was the problem by cloning my profile and repeatedly deleting a bunch of settings in prefs.js, opening the cloned profile with the changes and closing when the problem persisted.

Leaving this short issue here for the next confused person. :)

Cela vous a-t-il été utile ?

Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.