Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Disable tab refresh when switching - no solution

  • 4 réponses
  • 1 a ce problème
  • 163 vues
  • Dernière réponse par dubado

more options

I have tried all of the about:config options to disable the auto-reload of the tabs. I have this working fine on my old machine macbook pro 2015 (same firefox version), but on the macbook pro 2019 i cannot get it to stop. Any help would be great as I need to switch between tabs during meetings and dont want them to keep relaoding

I have tried all of the about:config options to disable the auto-reload of the tabs. I have this working fine on my old machine macbook pro 2015 (same firefox version), but on the macbook pro 2019 i cannot get it to stop. Any help would be great as I need to switch between tabs during meetings and dont want them to keep relaoding

Solution choisie

Your System Details show the Total Suspender extension that is probably causing this.

A minimalistic web extension for firefox that suspends natively (with tabs.discard) all non-active tabs and requires only minimal permissions to store it's settings and filter URL's.

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
Lire cette réponse dans son contexte 👍 1

Toutes les réponses (4)

more options

Is this about loading tabs when you start Firefox or when Firefox is running and you go to another tab ?

Firefox will detect if your computer's memory is running low, which is defined as lower than 400MB, and suspend unused tabs that you haven't used or looked at in a while. The new tab unload feature is controlled on the about:config page with a preference that you can set to false to disable this feature. Keep in mind that this makes you vulnerable to low memory issues.

  • browser.tabs.unloadOnLowMemory = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


Cela vous a-t-il été utile ?

more options

Thanks for responding. This is occurring when the browser is open and running. I have done all of the suggested config options. Restarted and it’s still refreshing after 10 seconds of leaving one tab for another. Not sure if it’s a setting in my Mac or not beyond Firefox

Cela vous a-t-il été utile ?

more options

Solution choisie

Your System Details show the Total Suspender extension that is probably causing this.

A minimalistic web extension for firefox that suspends natively (with tabs.discard) all non-active tabs and requires only minimal permissions to store it's settings and filter URL's.

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Cela vous a-t-il été utile ?

more options

Thanks cor-el that fixed the problem! It was still active on my old machine with no problems so that was interesting to find. Thanks for your help

Cela vous a-t-il été utile ?

Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.