Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

PDF Form Filling in Version 81

  • 3 réponses
  • 1 a ce problème
  • 18 vues
  • Dernière réponse par jscher2000

more options

Hello, I just upgraded from version 80.1 to version 81 on my Win7 system. I was looking forward to using the new PDF form filling feature but when I open a PDF document containing forms and try to enter data into a field, I get the following message:

This PDF file contains forms. The filling of form fields is not supported.

Do I need to configure something to allow Firefox to fill fields in a PDF form document?

The What's New page says this feature is available in version 81 and higher but does not say how to enable it. Thanks

Solution choisie

I really have no idea why this wasn't turned on automatically, whether that was an oversight or they discovered a glitch at the last moment or it is rolling out slowly. To test out the new feature, you can turn it on manually:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste pdfjs.r and pause while the list is filtered

(3) If the pdfjs.renderInteractiveForms preference is set to to false, double-click it to switch the value to true

More info on about:config: Configuration Editor for Firefox.

Lire cette réponse dans son contexte 👍 0

Toutes les réponses (3)

more options

Solution choisie

I really have no idea why this wasn't turned on automatically, whether that was an oversight or they discovered a glitch at the last moment or it is rolling out slowly. To test out the new feature, you can turn it on manually:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste pdfjs.r and pause while the list is filtered

(3) If the pdfjs.renderInteractiveForms preference is set to to false, double-click it to switch the value to true

More info on about:config: Configuration Editor for Firefox.

Cela vous a-t-il été utile ?

more options

Thank you jscher2000. This resolved the issue.

Note that, in addition to the pdfjs.renderInteractiveForms, there is an entry pdfjs.r which was set to true. Perhaps someone saw this entry and thought because it was true form filling was enabled.

Anyway, thanks again.

Cela vous a-t-il été utile ?

more options

Oh, sorry, pdfjs.r shows you a bar that allows you to add a new preference (it has a choice of preference types and a + button). But that isn't necessary and has no effect because there is no real preference by that name.

Cela vous a-t-il été utile ?

Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.