Corriger les problèmes d'impression dans Firefox | Résolution de problèmes

Corriger les problèmes d'impression dans Firefox

Cet article décrit comment résoudre les problèmes d'impression dans Firefox.

Vérifier les paramètres de page Firefox

Si une page Web ne s'imprime pas correctement dans Firefox :

  1. En haut de la fenêtre de Firefox, cliquez sur le bouton Firefox, survolez le menu Imprimer... (sous Windows XP, cliquez sur le menu Fichier), puis sélectionnez Aperçu avant impression. La fenêtre de l'aperçu avant impression apparaît.
  2. Dans la fenêtre de l'aperçu avant impression, assurez-vous que Échelle est défini à Adapter à la page.
  3. Assurez-vous que la page est en mode Portrait.
  4. Cliquez sur Mise en page.... La fenêtre de mise en page apparaît.
  5. Dans la fenêtre de mise en page, cliquez sur l'onglet Marges, en-têtes et pieds de page.
  6. Dans la section « Marges », assurez-vous que les marges de page sont correctement définies (le paramètre par défaut est 12.7 mm ou 0.5 in).
  7. Cliquez sur OK pour fermer la fenêtre de mise en page et retourner à la fenêtre d'aperçu avant impression.
  8. De retour dans la fenêtre d'aperçu avant impression, cliquez sur Imprimer.... La fenêtre d'impression apparaît.
  9. Assurez-vous que la bonne imprimante est affichée à côté du champ Nom.
  10. Assurez-vous que la case « Imprimer dans un fichier » n'est pas cochée.

Si vous avez fait des changements, continuez et essayez d'imprimer de nouveau la page. Sinon, suivez les instructions ci-dessous.

Vérifier les paramètres de page de Firefox

Si une page Web ne s'imprime pas correctement dans Firefox :

  1. En haut de la fenêtre de Firefox, cliquez sur Fichier, puis sélectionnez Aperçu avant impression. La fenêtre de l'aperçu avant impression apparaît.
  2. Dans la fenêtre de l'aperçu avant impression, assurez-vous que Échelle est défini à Adapter à la page.
  3. Assurez-vous que la page est en mode Portrait.
  4. Cliquez sur Imprimer. La fenêtre d'impression apparaît.
  5. Assurez-vous que la bonne imprimante est affichée à côté du champ Nom.
  6. Cliquez sur l'onglet Mise en page et assurez-vous que les marges de page sont correctement définies (le paramètre par défaut est 12.7 mm ou 0.5 in).

Si vous avez fait des changements, continuez et essayez d'imprimer de nouveau la page. Sinon suivez les instructions ci-dessous.

Vérifier les autres navigateurs et imprimantes

Vous pouvez voir si votre problème est avec Firefox, votre imprimante ou le site Web que vous êtes en train de visiter :

  • Vérifiez si la page s'imprime correctement dans un autre navigateur (comme Internet ExplorerSafariEpiphany)

Si la page ne s'imprime pas correctement dans un autre navigateur également :

  • Il pourrait y avoir un problème avec votre imprimante : si vous avez une autre imprimante, essayez d'imprimer la page avec celle-ci. Si la seconde imprimante imprime correctement la page, mettez à jour votre pilote d'imprimante depuis le site Web du fabricant de l'imprimante.
  • Il pourrait y avoir un problème avec la page. Contactez le webmestre.

Si la page s'imprime correctement dans un autre navigateur, suivez les instructions des sections suivantes.

Réinitialiser le paramètre imprimante de Firefox

Plusieurs problèmes d'impression peuvent être résolus en réinitialisant le paramètre imprimante de Firefox :

  1. Dans la barre d'adresse, saisissez about:config, puis appuyez sur EntréeRetour.

    • La page d'avertissement « Attention, danger ! » doit apparaître. Cliquez sur Je ferai attention, promis ! pour accéder à la page « about:config ».
  2. Dans le champ FiltrerRechercher, saisissez print_printer.
  3. Faites un clic droitMaintenez la touche Ctrl enfoncée pendant que vous cliquez sur la préférence print_printer et sélectionnez Réinitialiser.
  4. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

    .

Au redémarrage de Firefox, essayez d'imprimer la page avec laquelle vous aviez des problèmes précédemment.

Note : Dans Firefox 5.0 et les versions précédentes print.print_printer est le nom de préférence. L'ancien nom de cette préférence peut continuer à apparaître en même temps que le nouveau nom dans un profil en cours qui était aussi utilisé avec toutes les versions antérieures à Firefox 6.0. L'ancienne préférence peut être supprimée avec un clic droit et Réinitialiser, il vous suffit ensuite de redémarrer Firefox et d'imprimer quelque chose. L'ancienne préférence ne réapparaîtra pas, c'est seulement la nouvelle qui devrait apparaître.

Réinitialiser tous les paramètres d'imprimante de Firefox

Si la procédure ci-dessus n'a pas fonctionné, vous devriez réinitialiser tous les paramètres d'imprimante de Firefox :

  1. Ouvrez votre dossier de profil :

    En haut de la fenêtre Firefox, cliquez sur le bouton Firefox, allez sur le menu AideSur la barre de menus, cliquez sur le menu AideEn haut de la fenêtre Firefox, cliquez sur le menu Aide, puis sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.Cliquez sur le bouton menu New Fx Menu , puis cliquez sur le bouton Aide Help-29 et sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.

  2. Sous la section Paramètres de base de l'application, cliquez sur le bouton Ouvrir le dossier correspondantAfficher dans le FinderOuvrir le dossier correspondant. Une fenêtre avec vos fichiersvotre dossier de profil s'ouvre.
  3. Note : Si vous n'arrivez pas à ouvrir ou utiliser Firefox, suivez les instructions dans Trouver votre profil sans ouvrir Firefox.

  4. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

    .
  5. Dans votre dossier de profil, copiez le fichier prefs.js vers un autre dossier pour avoir une sauvegarde.
  6. Ouvrez le fichier prefs.js original dans un éditeur de texte (tel que WordpadTextEditEmacs).
  7. Supprimez toutes les lignes dans prefs.js qui commencent par print_ et enregistrez le fichier.

Si quelque chose ne vas pas quand vous ouvrez Firefox, fermez-le de nouveau et ré-écrasez prefs.js avec la sauvegarde que vous avez faite.

Changer la police par défaut

La police « Time New Roman » peut ne pas être reconnue par votre imprimante. Changez la police par défaut en une police similaire, telle que « Trebuchet MS » :

  1. En haut de la fenêtre de Firefox, cliquez sur le bouton Firefox, puis sélectionnez OptionsEn haut de la fenêtre de Firefox, cliquez sur le menu Outils, puis sélectionnez OptionsSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Préférences…En haut de la fenêtre de Firefox, cliquez sur le menu Édition, puis sélectionnez Préférences

    Cliquez sur le bouton menu New Fx Menu et sélectionnez OptionsPréférences

  2. Sélectionnez le panneau Contenu.
  3. Sous Polices et couleurs, sélectionnez « Trebuchet MS » pour la police par défaut.
  4. Cliquez sur OK pour fermer la fenêtre « Options »Cliquez sur Fermer pour fermer la fenêtre « Préférences »Fermez la fenêtre « Préférences »



Partager cet article : http://mzl.la/MCCq7H

Cet article vous a-t-il été utile ?

Veuillez patienter…

Ces formidables personnes ont aidé à écrire cet article : Goofy_BZ, scoobidiver, irahal, dattaz. Vous pouvez également aider - découvrez comment.
Obtenir de l'aide pour une autre plateforme :
Personnaliser cet article

Firefox