Etsi tuesta

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Remove "... - Visit" and "Search with ..." entries in location bar

  • 4 vastausta
  • 21 henkilöllä on sama ongelma
  • 27 näyttöä
  • Viimeisin kirjoittaja dynamite

more options

I would like the "... - Visit" and "Search with ..." entries not to show up when I type an address in location bar. So far, it was possible to do so by setting browser.urlbar.unifiedcomplete to false but this pref has been removed in Firefox 49 (https://bugzilla.mozilla.org/show_bug.cgi?id=1223728).

In Nightly 49.0a1, adding the following to userChrome.css works and hides the "Search" entry:

  #PopupAutoCompleteRichResult richlistitem[actiontype="searchengine"] {
  display: none;
  }
  .autocomplete-richlistbox { height: auto !important; }


The following works for "Visit" entry but after every Firefox restart, the first time I type an address, it shows zero items in the drop-down:

  #PopupAutoCompleteRichResult richlistitem[actiontype="visiturl"] {
  display: none;
  }
  .autocomplete-richlistbox { height: auto !important; }


If I add both these snippets to userChrome.css at the same time, none of them work. Both "Visit" and "Search" entries are still visible.

Is there any other way that works without any side-effects?

Thanks.

EDIT: code formatting.

Muokattu , muokkaaja dynamite

Valittu ratkaisu

Try this code in the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#PopupAutoCompleteRichResult .autocomplete-richlistbox {max-height:none!important;height:auto!important}
#PopupAutoCompleteRichResult .autocomplete-richlistitem[actiontype="visiturl"]{display:none!important}
#PopupAutoCompleteRichResult .autocomplete-richlistitem[actiontype="searchengine"]{display:none!important}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

Lue tämä vastaus kontekstissaan 👍 3

Kaikki vastaukset (4)

more options

Valittu ratkaisu

Try this code in the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#PopupAutoCompleteRichResult .autocomplete-richlistbox {max-height:none!important;height:auto!important}
#PopupAutoCompleteRichResult .autocomplete-richlistitem[actiontype="visiturl"]{display:none!important}
#PopupAutoCompleteRichResult .autocomplete-richlistitem[actiontype="searchengine"]{display:none!important}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

more options

May I selfishly ask someone to check whether this userstyle still works in Firefox 49 (you can click the Show CSS link to copy out the CSS rather than using Stylish):

https://userstyles.org/styles/122394/url-bar-tweaks-remove-visit-search-scroll-bar

This is the key part:

#PopupAutoCompleteRichResult richlistitem[type*="heuristic"] {
  display:none !important;
}
more options

It is still in the source code, but I do not know what steps you would need to get this item.

See:

more options

@cor-el Yes, your suggested CSS works. Thank you so much !

@jscher2000 Unfortunately, the CSS included in that userstyle no longer works. I tested with Nightly 49.0a1. In fact, I had tried this approach before posting the question.