Etsi tuesta

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

In Firefox 38.5, how do I ensure it will only use tls 1.2 and not fallback to lower versions or ssl?

  • 2 vastausta
  • 4 henkilöllä on sama ongelma
  • 785 näyttöä
  • Viimeisin kirjoittaja mmarino

more options

I'm using Firefox 38.5 on CentOS 5.6. My current settings in about:config are as follows: security.tls.version.fallback-limit = 3 security.tls.version.max = 3 security.tls.version.min = 1

Are these settings already correct to only allow tls 1.2 or do I need to change the min value to 3 as well?

I'm using Firefox 38.5 on CentOS 5.6. My current settings in about:config are as follows: security.tls.version.fallback-limit = 3 security.tls.version.max = 3 security.tls.version.min = 1 Are these settings already correct to only allow tls 1.2 or do I need to change the min value to 3 as well?

Valittu ratkaisu

You would have to set security.tls.version.min = 3 if you really only want to enable TLS 1.2 Note that this will break servers that do not support TLS 1.2

0 means SSL 3.0, 1 means TLS 1.0, 2 means TLS 1.1, 3 means TLS 1.2 etc.

Lue tämä vastaus kontekstissaan 👍 4

Kaikki vastaukset (2)

more options

Valittu ratkaisu

You would have to set security.tls.version.min = 3 if you really only want to enable TLS 1.2 Note that this will break servers that do not support TLS 1.2

0 means SSL 3.0, 1 means TLS 1.0, 2 means TLS 1.1, 3 means TLS 1.2 etc.

Muokattu , muokkaaja cor-el

more options

Thanks - excellent answer.