Laitteistoa ei enää tueta

Tämän artikkelin sisältöä ei enää ylläpidetä, joten se saattaa olla vanhentunutta.

Jos tietokoneesi prosessori on vanhempi kuin Pentium 4, Firefox ei enää versiosta 49 alkaen tue sitä.

Jos Firefox on jo asennettu tietokoneellesi, voit edelleen jatkaa sen käyttöä, mutta et enää saa uudempia kuin versioon 48 liittyviä päivityksiä. Jos lataat Firefoxin version 49 tai uudemman, ja yrität asentaa sitä, saat virheilmoituksen Firefox cannot be installed. This version of Firefox requires a processor with SSE2 support.

Firefox Extended Support Release (ESR) versio 45 jatkaa toimintaansa vanhempien prosessoreiden kanssa, mutta sitä ei enää päivitetä. 7.3.2017 julkaistua Firefox ESR:n versiota 52 ei enää tueta.

Useiden muiden ohjelmien tapaan Firefoxin uudemmat versiot edellyttävät paremman turvallisuuden ja suorituskyvyn vuoksi prosessoria, joka tukee Streaming SIMD Extensions 2 (SSE2) -käskykantalaajennusta. Suosittelemme uusimman Firefoxin käyttämiseen tietokonetta, jossa on SSE2:ta tukeva Pentium 4 -prosessori tai uudempi.

Jos tietokoneesi prosessori on vanhempi kuin Pentium 4, Firefox ei enää versiosta 53 alkaen tue sitä.

Jos Firefox on jo asennettu tietokoneellesi, voit edelleen jatkaa sen käyttöä, mutta et enää saa uudempia kuin versioon 52 liittyviä päivityksiä. Jos lataat Firefoxin version 53 tai uudemman ja yrität käynnistää sen, saat stderr-virheilmoituksen This browser version requires a processor with the SSE2 instruction set extension. You may be able to obtain a version that does not require SSE2 from your Linux distribution.

Useiden muiden ohjelmien tapaan Firefoxin uudemmat versiot edellyttävät paremman turvallisuuden ja suorituskyvyn vuoksi prosessoria, joka tukee Streaming SIMD Extensions 2 (SSE2) -käskykantalaajennusta. Suosittelemme uusimman Firefoxin käyttämiseen tietokonetta, jossa on SSE2:ta tukeva Pentium 4 -prosessori tai uudempi.

Firefox Extended Support Release (ESR) versio 52 jatkaa toimintaansa vanhempien prosessoreiden kanssa, mutta sitä ei enää päivitetä. 9.5.2018 julkaistua Firefox ESR:n versiota 60 ei enää tueta.

Linux-jakelun mukana toimitetun Firefoxin prosessorivaatimukset saattavat poiketa Mozillan toimittaman Firefoxin prosessorivaatimuksista, joten saattaa olla, että linux-jakelijasi pystyy toimittamaan ajantasaisen Firefox-version, joka ei vaadi SSE2-tukea.

Huomaa: Ohjeet Firefox-version löytämiseen löytyvät artikkelista Firefoxin versionumeron löytäminen.
// Nämä mahtavat henkilöt auttoivat kirjoittamaan tämän artikkelin:Jarmo. Sinäkin voit auttaa.
Ilmoittaudu avustajaksi