Päivitysten etsiminen on estetty

Tämän artikkelin sisältöä ei enää ylläpidetä, joten se saattaa olla vanhentunutta.

Tässä artikkelissa kerrotaan, miksi Ohje-valikon Hae päivityksiä...-valinta ja ohjelmistopäivitystoiminto ovat estettyjä joissain järjestelmissä. Yleistä tietoa päivittämisestä löytyy artikkelista Päivitä Firefox sen uusimpaan versioon.


Linuxin paketinhallintajärjestelmä

Firefoxin oma päivitystoiminto voidaan estää joissain Linux-järjestelmissä riippuen Linux-jakelun tavasta päivittää Firefox. Päivittääksesi Firefoxin tällaisilla järjestelmillä, sinun pitää käyttää jakelun omaa paketinhallintaa (esimerkiksi Synaptic).

Monet jakelut tarjoavat vain turvallisuus- ja vakauspäivitykset Firefoxille. Ne antavat sinun siirtyä esimerkiksi versiosta 2.0.0.19 versioon 2.0.0.20, mutta ei versioon 3.0. Suorittaaksesi suuremman päivityksen, sinun pitää asentaa Firefox paketinhallinnan ulkopuolella. Katso Firefoxin asentaminen Linuxille.


Käyttöoikeudet

Firefox saattaa estää päivitystoiminnon, jos käyttäjätilillä, jolla Firefoxia käytetään, ei ole oikeuksia muuttaa tiedostoja Firefoxin asennuskansiossa. Päivittääksesi Firefoxin, kirjaudu sisään käyttäjätilillä, jolla on tarvittavat oikeudet, esimerkiksi järjestelmänvalvojana. Hae päivityksiä...-valinta pitäisi tämän jälkeen olla käytettävissä. Tehdäksesi valinnan käytettäväksi aina, muuta Firefoxin asennuskansion käyttöoikeuksia.

Nämä mahtavat henkilöt auttoivat kirjoittamaan tämän artikkelin: funky. Sinäkin voit auttaa - lue lisää.