Πως θα διορθώσετε προτιμήσεις που δεν αποθηκεύονται

Μερικές φορές, οι επιλογέςπροτιμήσεις του Firefox μπορεί να μην αποθηκεύονται αφού τις μεταβάλλετε. Για παράδειγμα, μπορεί να αλλάξετε μια ρύθμιση στο παράθυρο ΕπιλογέςΠροτιμήσεις και να τη δείτε να επιστρέφει στην προηγούμενη τιμή της μόλις ανοίξετε ξανά το παράθυρο ΕπιλογέςΠροτιμήσεις. Αυτό το άρθρο μπορεί ακόμα να σας αφορά αν δείτε πως έπειτα από μια ενημέρωση του Firefox, η καρτέλα Ο Firefox ενημερώθηκε ανοίγει σε μια σελίδα που δηλώνει Ο Firefox έχει αναβαθμιστεί στην τελευταία έκδοση κάθε φορά που ξεκινά ο Firefox. Οι πιθανές αιτίες και λύσεις ποικίλουν ανάλογα με το αν δε μπορείτε να αποθηκεύσετε μερικές προτιμήσεις ή δε μπορείτε να αποθηκεύσετε καμία προτίμηση. Το πρόβλημα σας μπορεί ακόμη να οφείλεται σε κακόβουλο λογισμικό. Δείτε Troubleshoot Firefox issues caused by malware για περισσότερες λεπτομέρειες.

Επαναφέρετε τον Firefox για να διορθώσετε το πρόβλημα

Ο πιο εύκολος τρόπος να λύσετε αυτό το πρόβλημα είναι να επαναφέρετε τον Firefox στην αρχική του κατάσταση ενώ παράλληλα αποθηκεύετε τις σημαντικές για εσάς πληροφορίες. Έτσι επιλύεται ένα μεγάλο εύρος προβλημάτων. Εάν θέλετε να δοκιμάσετε μια πιο ακριβή επίλυση, παραλείψτε αυτή την ενότητα και δοκιμάστε τις λύσεις παρακάτω.

Σημείωση: Όταν χρησιμοποιείτε τη λειτουργία ανανέωσης, οι σελιδοδείκτες, το ιστορικό περιήγησης, οι ανοικτές καρτέλες, τα παράθυρα, οι κωδικοί πρόσβασης, τα cookies και οι πληροφορίες αυτόματης συμπλήρωσης διαδικτυακών φορμών θα αποθηκευτούν. Ωστόσο, οι επεκτάσεις και τα θέματά σας θα αφαιρεθούν, ενώ οι προτιμήσεις σας θα επαναφερθούν.Όταν χρησιμοποιείτε τη λειτουργία επαναφοράς, οι σελιδοδείκτες, το ιστορικό περιήγησης, οι ανοικτές καρτέλες, τα παράθυρα, οι κωδικοί πρόσβασης, τα cookies και οι πληροφορίες αυτόματης συμπλήρωσης διαδικτυακών φορμών θα αποθηκευτούν. Ωστόσο, οι επεκτάσεις και τα θέματά σας θα αφαιρεθούν, ενώ οι προτιμήσεις σας θα επαναφερθούν.Όταν χρησιμοποιείτε τη λειτουργία επαναφοράς, οι σελιδοδείκτες, το ιστορικό περιήγησης, οι κωδικοί πρόσβασης, τα cookies και οι πληροφορίες αυτόματης συμπλήρωσης διαδικτυακών φορμών θα αποθηκευτούν. Ωστόσο, οι επεκτάσεις και τα θέματά σας θα αφαιρεθούν· οι ανοικτές καρτέλες, τα παράθυρα και οι ομάδες καρτελών δεν θα αποθηκευτούν· τέλος, οι προτιμήσεις σας θα επαναφερθούν. Μάθετε περισσότερα.
  1. Στο επάνω μέρος του παραθύρου Firefox, κάντε κλικ στο μενού Βοήθεια (Help) και επιλέξτε Πληροφορίες Αντιμετώπισης Προβλημάτων (Troubleshooting Information).Στο επάνω μέρος του παραθύρου Firefox, κάντε κλικ στο κουμπί Firefox, μεταβείτε στο υπό-μενού Βοήθεια (Help) και επιλέξτε Πληροφορίες Αντιμετώπισης Προβλημάτων (Troubleshooting Information).On the menu bar, click the Help menu and select Troubleshooting Information.
    Reset Firefox 1 - WinXP Troubleshooting info - win Troubleshooting info - mac Troubleshooting info - lin
    Αν δεν μπορείτε να αποκτήσετε πρόσβαση στο μενού Βοήθεια (Help), πληκτρολογήστε about:support στη γραμμή διευθύνσεων για εμφάνιση της σελίδας Πληροφορίες Αντιμετώπισης Προβλημάτων (Troubleshooting Information).
  2. Κάντε κλικ στο κουμπί Επαναφορά Firefox (Reset Firefox) στην επάνω δεξιά γωνία στη σελίδα Πληροφορίες Αντιμετώπισης Προβλημάτων.
    Reset Firefox 2 - WinXP Reset Firefox - Win - 1 Reset Firefox - Mac - 1 Reset Firefox - Lin - 1
  3. Για να συνεχίσετε, κάντε κλικ στο Επαναφορά Firefox (Reset Firefox) στο παράθυρο επιβεβαίωσης που ανοίγει.Για να συνεχίσετε, κάντε κλικ στο Επαναφορά Firefox (Reset Firefox) στο αναδυόμενο παράθυρο που κατεβαίνει από κάτω.
  4. Firefox will close and be reset. When it's done, a window will list the information that was imported. Click Finish and Firefox will open.Το Firefox θα κλείσει και θα επαναφερθεί. Όταν ολοκληρωθεί η διαδικασία, ένα παράθυρο θα προβάλει σε λίστα τις πληροφορίες που εισήχθησαν. Κάντε κλικ στο Τέλος (Done) και το Firefox θα ανοίξει.
  1. Κάντε κλικ στο κουμπί μενού New Fx Menu και έπειτα, στο κουμπί Βοήθεια Help-29 .
  2. Από το μενού Βοήθεια (Help), επιλέξτε Πληροφορίες Αντιμετώπισης Προβλημάτων (Troubleshooting Information).
    Αν δεν μπορείτε να αποκτήσετε πρόσβαση στο μενού Βοήθεια (Help), πληκτρολογήστε about:support στη γραμμή διευθύνσεων για εμφάνιση της σελίδας Πληροφορίες Αντιμετώπισης Προβλημάτων (Troubleshooting Information).
  3. Κάντε κλικ στο κουμπί Επαναφορά Firefox… (Reset Firefox…) στην επάνω δεξιά γωνία στη σελίδα Πληροφορίες Αντιμετώπισης Προβλημάτων.
    Reset 29 Win Reset 29 Mac Reset 29 Lin
  4. Για να συνεχίσετε, κάντε κλικ στο Επαναφορά Firefox (Reset Firefox) στο παράθυρο επιβεβαίωσης που ανοίγει.
  5. Το Firefox θα κλείσει και θα επαναφερθεί. Όταν ολοκληρωθεί η διαδικασία, ένα παράθυρο θα προβάλει σε λίστα τις πληροφορίες που εισήχθησαν. Κάντε κλικ στο Ολοκλήρωση (Finish) και το Firefox θα ανοίξει.
  1. Κάντε κλικ κατευθείαν σε αυτό το κουμπί Refresh Firefox, αν προβάλλετε αυτή τη σελίδα στο Firefox (δεν θα λειτουργήσει αν χρησιμοποιείτε έναν άλλο περιηγητή). Μπορείτε επίσης να βρείτε ένα κουμπί Ανανέωσης στην επάνω δεξιά γωνία της σελίδας Πληροφορίες Αντιμετώπισης Προβλημάτων στο about:support του Firefox.
  2. Για να συνεχίσετε, κάντε κλικ στο Ανανέωση Firefox (Refresh Firefox) στο παράθυρο επιβεβαίωσης που ανοίγει.
  3. Το Firefox θα κλείσει για να ανανεωθεί. Όταν τελειώσει, ένα παράθυρο θα προβάλλει όλες τις εισαγόμενες πληροφορίες σας. Κάντε κλικ στο κουμπί Ολοκλήρωση (Finish) και το Firefox θα ανοίξει.

Σημείωση: Υπάρχει επίσης ένα κουμπί Ανανέωση FirefoxΕπαναφορά Firefox στο παράθυρο Ασφαλούς Λειτουργίας του Firefox, αν δεν μπορείτε να εκκινήσετε κανονικά το Firefox.

Επαναφέρετε το αρχείο προτιμήσεων

Εάν δε νιώθετε άνετα με την εκτέλεση οποιουδήποτε από τα παρακάτω βήματα, μπορείτε να επιλέξετε απλά να επαναφέρετε όλες τις προτιμήσεις, για να δείτε αν αυτό λύνει το πρόβλημα. Δείτε στο Επαναφέρετε τις προτιμήσεις του Firefox για να αντιμετωπίσετε και να διορθώσετε προβλήματα για λεπτομερείς οδηγίες. Αυτό θα επαναφέρει όλες τις προτιμήσεις στην αρχική τους κατάσταση, εκτός από όποιες ρυθμίσεις είναι αποθηκευμένες σε κάποιο αρχείο user.js, αν υπάρχει κάποιο.

Συγκεκριμένες προτιμήσεις δεν αποθηκεύονται

Εάν μια συγκεκριμένη ρύθμιση στον Firefox επιμένει να επανέρχεται ή δεν είναι δυνατό να αλλάξετε μια συγκεκριμένη ρύθμιση μα άλλες ρυθμίσεις αποθηκεύονται κανονικά, ίσως έχετε κάποιο από τα παρακάτω ζητήματατο παρακάτω ζήτημα.

Προγράμματα τρίτων μεταβάλλουν τις ρυθμίσεις του Firefox

Μερικά προγράμματα επιβάλλουν στον Firefox να χρησιμοποιεί συγκεκριμένες ρυθμίσεις. Παρακάτω βρίσκεται μια λίστα από προγράμματα γνωστά για αυτό καθώς και ενέργειες που μπορείτε να κάνετε ώστε να τα κάνετε να σταματήσουν να επιβάλλουν ρυθμίσεις στον Firefox:

  • Το πρόγραμμα Creative ZenCast μεταβάλλει τον user agent του Firefox , παρεμβαίνοντας στη Java.
    • Απεγκαταστήστε το πρόγραμμα.
  • Η υπηρεσία McAfee Privacy Service απενεργοποιεί τον pop-up blocker του Firefox.
  • Το πρόγραμμα Norton 360 περιλαμβάνει ένα χαρακτηριστικό "Firefox Privacy Cleanup" το οποίο, αν είναι ενεργοποιημένο, υπερισχύει των ρυθμίσεων ιδιωτικότητας του Firefox και σας αποτρέπει να κρατήσετε το Ιστορικο Περιήγησης σας, Cookies ή άλλα προσωπικά δεδομένα μεταξύ συνεδριών.
    • Δείτε Firefox Privacy Cleanup για περισσότερες πληροφορίες σχετικά με το πως θα το απενεργοποιήσετε.

Μερικές εργαλειοθήκες τρίτων και πρόσθετα αλλάζουν την αρχική σελίδα του Firefox καθώς και ρυθμίσεις αναζήτησης. Μπορείτε να τις επαναφέρετε γρήγορα με το πρόσθετο SearchReset.

Το αρχείο user.js file υπερισχύει των προτιμήσεων

Εάν δεν έχετε εγκαταστήσει κάποιο από τα παραπάνω προγράμματα, ή αν έχετε ακολουθήσει τις προτάσεις και συγκεκριμένες προτιμήσεις εξακολουθούν να μην αποθηκεύονται, ίσως χρειάζεται να επεξεργαστείτε μόνοι σας τα αρχεία ρυθμίσεων του Firefox. Μην πανικοβάλλεστε, είναι αρκετά εύκολο. Να πως θα το κάνετε.

  1. Ανοίξτε τον φάκελο του προφίλ σας:

    Στο επάνω μέρος του παραθύρου του Firefox, κάνετε κλικ στο κουμπί Firefox , πηγαίνετε στο υπο-μενού ΒοήθειαΣτη γραμμή μενού, κάνετε κλικ στο μενού ΒοήθειαΣτο επάνω μέρος του παραθύρου του Firefox, κάνετε κλικ στο μενούΒοήθεια και επιλέξτε Αντιμετώπιση προβλημάτων. Η καρτέλα Αντιμετώπιση προβλημάτων θα ανοίξει.Κάντε κλικ στο κουμπί μενού New Fx Menu , κάντε κλικ στο Βοήθεια Help-29 και επιλέξτε Αντιμετώπιση προβλημάτων. Η καρτέλα Αντιμετώπιση προβλημάτων θα ανοίξει.

  2. Στην ενότητα Βασικά εφαρμογής κάνετε κλικ στο κουμπί Προβολή φακέλουShow in FinderΆνοιγμα καταλόγου. Ένα παράθυρο με τους φακέλουςφακέλους του προφίλ σας θα ανοίξει.
  3. Σημείωση: Εάν δεν μπορείτε να ανοίξετε ή να χρησιμοποιήσετε τον Firefox, ακολουθήστε τις οδηγίες στο Πως να βρείτε το φάκελο του προφίλ σας χωρίς να ανοίξετε το Firefox.

  4. Στο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο κουμπίFirefox και επιλέξτε το υπο-μενού ΈξοδοςΣτο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε το υπο-μενού ΈξοδοςΣτη γραμμή μενού, κάντε κλικ στο μενού Firefox και επιλέξτε το υπο-μενού Quit FirefoxΣτο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε Έξοδος

    Κάντε κλικ στο κουμπί μενού New Fx Menu και μετά κάντε κλικ στο ΈξοδοςΈξοδος Close 29

  5. Ανοίξτε το αρχείο user.js με έναν επεξεργαστή κειμένου (όπως NotepadGedit ή KateTextEdit).
    • Εάν δεν υπάρχει κανένα αρχείο user.js, αυτά τα βήματα δε θα σας βοηθήσουν.
  6. Αφαιρέστε τις γραμμές για τις επιλογέςπροτιμήσεις που θέλετε να έχετε τη δυνατότητα να αλλάξετε. Μπορείτε να διαράψετε όλες τις γραμμές στην περίπτωση που θέλετε να έχετε τη δυνατότητα να αλλάξετε τα πάντα.
  7. Αποθηκεύστε το αρχείο και κλείστε τον επεξεγραστή κειμένου.

Θα πρέπει τώρα να έχετε τη δυνατότητα να αλλάξετε τις ρυθμίσεις του Firefox.

Το αρχείο του προγράμματος του Firefox κλειδώνει ή αποτρέπει αλλαγές σε συγκεκριμένες προτιμήσεις

Η εγκατάσταση του Firefox μπορεί να έχει διαμορφωθεί ώστε να προσθέτει ένα αρχείο ρυθμίσεων προγράμματος το οποίο κλειδώνει συγκεκριμένες προτιμήσεις ή αποτρέπει συγκεκριμένες αλλαγές να αποθηκευτούν. Ακολουθήστε το βήμα Reinstall Firefox στο άρθρο Troubleshoot and diagnose Firefox problems για να απομακρύνετε το πρόγραμμα του Firefox από τον υπολογιστή σας και έπειτα να επανεγκαταστήσετε ένα νεο αντίγραφο του Firefox. (Η επανεγκατάσταση του Firefox με αυτό τον τρόπο δε θα αφαιρέσει τα δεδομένα και τις ρυθμίσεις σας, καθώς αυτά βρίσκονται αποθηκευμένα σε μια ξεχωριστή τοποθεσία από τα αρχεία του προγράμματος.)

Δεν έχετε τη δυνατότητα να αποθηκεύσετε οποιαδήποτε από τις προτιμήσεις ή τις ρυθμίσεις

Εάν καμία από τις ρυθμίσεις δεν αποθηκεύεται, αν λαμβάνετε την καρτέλα Ο Firefox ενημερώθηκε κάθε φορά που ξεκινά ο Firefox, ή αν έχετε δοκιμάσει τα παραπάνω βήματα χωρίς αποτέλεσμα, τότε το αρχείο που χρησιμοποιεί ο Firefox για να αποθηκεύει τις προτιμήσεις σας μπορεί να είναι κλειδωμένο ή κατεστραμμένο.

Κλειδωμένο αρχείο προτιμήσεων

Ο Firefox μπορεί να μην είναι δυνατόν να αποθυκεύσει τις ρυθμίσεις σας αν το αρχείο prefs.js (ή το αρχείο prefs.js.moztmp, αν υπάρχει) έχει προστασία εγγραφής ή αν υπάρχουν άλλα αρχεία προτιμήσεων.

  1. Ανοίξτε τον φάκελο του προφίλ σας:

    Στο επάνω μέρος του παραθύρου του Firefox, κάνετε κλικ στο κουμπί Firefox , πηγαίνετε στο υπο-μενού ΒοήθειαΣτη γραμμή μενού, κάνετε κλικ στο μενού ΒοήθειαΣτο επάνω μέρος του παραθύρου του Firefox, κάνετε κλικ στο μενούΒοήθεια και επιλέξτε Αντιμετώπιση προβλημάτων. Η καρτέλα Αντιμετώπιση προβλημάτων θα ανοίξει.Κάντε κλικ στο κουμπί μενού New Fx Menu , κάντε κλικ στο Βοήθεια Help-29 και επιλέξτε Αντιμετώπιση προβλημάτων. Η καρτέλα Αντιμετώπιση προβλημάτων θα ανοίξει.

  2. Στην ενότητα Βασικά εφαρμογής κάνετε κλικ στο κουμπί Προβολή φακέλουShow in FinderΆνοιγμα καταλόγου. Ένα παράθυρο με τους φακέλουςφακέλους του προφίλ σας θα ανοίξει.
  3. Σημείωση: Εάν δεν μπορείτε να ανοίξετε ή να χρησιμοποιήσετε τον Firefox, ακολουθήστε τις οδηγίες στο Πως να βρείτε το φάκελο του προφίλ σας χωρίς να ανοίξετε το Firefox.

  4. Στο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο κουμπίFirefox και επιλέξτε το υπο-μενού ΈξοδοςΣτο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε το υπο-μενού ΈξοδοςΣτη γραμμή μενού, κάντε κλικ στο μενού Firefox και επιλέξτε το υπο-μενού Quit FirefoxΣτο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε Έξοδος

    Κάντε κλικ στο κουμπί μενού New Fx Menu και μετά κάντε κλικ στο ΈξοδοςΈξοδος Close 29

  5. Εντοπίστε το αρχείο prefs.js (και, αν υπάρχει, το αρχείο prefs.js.moztmp).
  6. Κάνετε δεξί κλικ σε κάθε αρχείο με τη σειρά και επιλέξτε Ιδιότητες από το αντίστοιχο μενού. Ελέγξτε ότι κάτω από τις Ιδιότητες, δεν είναι επιλεγμένο το κουτί δίπλα στο Μόνο για Ανάγνωση για κανένα από τα αρχεία.
    • Εάν το RealPlayer είναι ανοιχτό, τότε μπορεί αυτό να κλειδώνει το αρχείο prefs.js. Το κλείσιμο του RealPlayer θα πρέπει να το ξεκλειδώσει.
  7. Διαγράψτε όλα τα αρχεία prefs-n.js όπου n είναι ένας αριθμός (π.χ. prefs-2.js).
  8. Διαγράψτε το Invalidprefs.js εάν αυτό υπάρχει.
  9. Επανεκκινήστε τον Firefox. Θα πρέπει τώρα να έχετε τη δυνατότητα να αποθηκεύσετε προτιμήσεις.
  1. Ανοίξτε τον φάκελο του προφίλ σας:

    Στο επάνω μέρος του παραθύρου του Firefox, κάνετε κλικ στο κουμπί Firefox , πηγαίνετε στο υπο-μενού ΒοήθειαΣτη γραμμή μενού, κάνετε κλικ στο μενού ΒοήθειαΣτο επάνω μέρος του παραθύρου του Firefox, κάνετε κλικ στο μενούΒοήθεια και επιλέξτε Αντιμετώπιση προβλημάτων. Η καρτέλα Αντιμετώπιση προβλημάτων θα ανοίξει.Κάντε κλικ στο κουμπί μενού New Fx Menu , κάντε κλικ στο Βοήθεια Help-29 και επιλέξτε Αντιμετώπιση προβλημάτων. Η καρτέλα Αντιμετώπιση προβλημάτων θα ανοίξει.

  2. Στην ενότητα Βασικά εφαρμογής κάνετε κλικ στο κουμπί Προβολή φακέλουShow in FinderΆνοιγμα καταλόγου. Ένα παράθυρο με τους φακέλουςφακέλους του προφίλ σας θα ανοίξει.
  3. Σημείωση: Εάν δεν μπορείτε να ανοίξετε ή να χρησιμοποιήσετε τον Firefox, ακολουθήστε τις οδηγίες στο Πως να βρείτε το φάκελο του προφίλ σας χωρίς να ανοίξετε το Firefox.

  4. Στο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο κουμπίFirefox και επιλέξτε το υπο-μενού ΈξοδοςΣτο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε το υπο-μενού ΈξοδοςΣτη γραμμή μενού, κάντε κλικ στο μενού Firefox και επιλέξτε το υπο-μενού Quit FirefoxΣτο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε Έξοδος

    Κάντε κλικ στο κουμπί μενού New Fx Menu και μετά κάντε κλικ στο ΈξοδοςΈξοδος Close 29

  5. Εντοπίστε το αρχείο prefs.js (και, αν υπάρχει, το αρχείο prefs.js.moztmp).
  6. Για καθένα από αυτά, βεβαιωθείτε πως έχετε δικαιώματα εγγραφής στο αρχείο.
  7. Διαγράψτε όλα τα αρχεία prefs-n.js όπου n είναι ένας αριθμός (π.χ. prefs-2.js).
  8. Διαγράψτε το Invalidprefs.js αν αυτό υπάρχει.
  9. Επανεκκινήστε τον Firefox. Θα πρέπει τώρα να έχετε τη δυνατότητα να αποθηκεύσετε προτιμήσεις.
  1. Ανοίξτε τον φάκελο του προφίλ σας:

    Στο επάνω μέρος του παραθύρου του Firefox, κάνετε κλικ στο κουμπί Firefox , πηγαίνετε στο υπο-μενού ΒοήθειαΣτη γραμμή μενού, κάνετε κλικ στο μενού ΒοήθειαΣτο επάνω μέρος του παραθύρου του Firefox, κάνετε κλικ στο μενούΒοήθεια και επιλέξτε Αντιμετώπιση προβλημάτων. Η καρτέλα Αντιμετώπιση προβλημάτων θα ανοίξει.Κάντε κλικ στο κουμπί μενού New Fx Menu , κάντε κλικ στο Βοήθεια Help-29 και επιλέξτε Αντιμετώπιση προβλημάτων. Η καρτέλα Αντιμετώπιση προβλημάτων θα ανοίξει.

  2. Στην ενότητα Βασικά εφαρμογής κάνετε κλικ στο κουμπί Προβολή φακέλουShow in FinderΆνοιγμα καταλόγου. Ένα παράθυρο με τους φακέλουςφακέλους του προφίλ σας θα ανοίξει.
  3. Σημείωση: Εάν δεν μπορείτε να ανοίξετε ή να χρησιμοποιήσετε τον Firefox, ακολουθήστε τις οδηγίες στο Πως να βρείτε το φάκελο του προφίλ σας χωρίς να ανοίξετε το Firefox.

  4. Στο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο κουμπίFirefox και επιλέξτε το υπο-μενού ΈξοδοςΣτο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε το υπο-μενού ΈξοδοςΣτη γραμμή μενού, κάντε κλικ στο μενού Firefox και επιλέξτε το υπο-μενού Quit FirefoxΣτο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε Έξοδος

    Κάντε κλικ στο κουμπί μενού New Fx Menu και μετά κάντε κλικ στο ΈξοδοςΈξοδος Close 29

  5. Εντοπίστε το αρχείο prefs.js (και, αν υπάρχει, το αρχείο prefs.js.moztmp).
  6. Για καθένα από αυτά, κραττε πατημένο το πλήκτρο Ctrl καθώς κάνετε κλικ στο αρχείο και έπειτα επιλέξτε Get Info.
  7. Βεβαιωθείτε πως η επιλογή Κλειδωμένο δεν είναι επιλεγμένη.
  8. Διαγράψτε όλα τα αρχεία prefs-n.js όπου n είναι ένας αριθμός (π.χ. prefs-2.js).
  9. Διαγράψτε το Invalidprefs.js αν αυτό υπάρχει.
  10. Επανεκκινήστε τον Firefox. Θα πρέπει τώρα να έχετε τη δυνατότητα να αποθηκεύσετε προτιμήσεις.

Κατεστραμμένο αρχείο προτιμήσεων

Το αρχείο προτιμήσεων μπορεί να είναι κατεστραμμένο, αποτρέποντας τον Firefox να εγγράψει σε αυτό. Εάν διαγράψετε αυτό το αρχείο, ο Firefox θα δημιουργήσει αυτόματα άλλο ένα μόλις χρειαστεί.

Να πως θα διαγράψετε το αρχείο prefs.js.

Αυτό θα απομακρύνει όλες τις προσαρμοσμένες ρυθμίσεις σας, όπως και τις ρυθμίσεις για πολλά πρόσθετα.
  1. Ανοίξτε τον φάκελο του προφίλ σας:

    Στο επάνω μέρος του παραθύρου του Firefox, κάνετε κλικ στο κουμπί Firefox , πηγαίνετε στο υπο-μενού ΒοήθειαΣτη γραμμή μενού, κάνετε κλικ στο μενού ΒοήθειαΣτο επάνω μέρος του παραθύρου του Firefox, κάνετε κλικ στο μενούΒοήθεια και επιλέξτε Αντιμετώπιση προβλημάτων. Η καρτέλα Αντιμετώπιση προβλημάτων θα ανοίξει.Κάντε κλικ στο κουμπί μενού New Fx Menu , κάντε κλικ στο Βοήθεια Help-29 και επιλέξτε Αντιμετώπιση προβλημάτων. Η καρτέλα Αντιμετώπιση προβλημάτων θα ανοίξει.

  2. Στην ενότητα Βασικά εφαρμογής κάνετε κλικ στο κουμπί Προβολή φακέλουShow in FinderΆνοιγμα καταλόγου. Ένα παράθυρο με τους φακέλουςφακέλους του προφίλ σας θα ανοίξει.
  3. Σημείωση: Εάν δεν μπορείτε να ανοίξετε ή να χρησιμοποιήσετε τον Firefox, ακολουθήστε τις οδηγίες στο Πως να βρείτε το φάκελο του προφίλ σας χωρίς να ανοίξετε το Firefox.

  4. Στο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο κουμπίFirefox και επιλέξτε το υπο-μενού ΈξοδοςΣτο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε το υπο-μενού ΈξοδοςΣτη γραμμή μενού, κάντε κλικ στο μενού Firefox και επιλέξτε το υπο-μενού Quit FirefoxΣτο επάνω μέρος του παραθύρου του Firefox, κάντε κλικ στο μενού Αρχείο και επιλέξτε Έξοδος

    Κάντε κλικ στο κουμπί μενού New Fx Menu και μετά κάντε κλικ στο ΈξοδοςΈξοδος Close 29

  5. Εντοπίστε το αρχείο prefs.js (και, αν υπάρχει, το αρχείο prefs.js.moztmp).
  6. Διαγράψτε αυτά τα αρχεία και όλα τα αρχεία prefs-n.js όπου n είναι ένας αριθμός (π.χ. prefs-2.js).
  7. Διαγράψτε το Invalidprefs.js αν αυτό υπάρχει.
  8. Επανεκκινήστε τον Firefox. Θα πρέπει τώρα να έχετε επαναφέρει όλες τις προτιμήσεις σας.




Βασισμένο σε πληροφορίες από το Preferences not saved (mozillaZine KB)

 

Was this article helpful? Please wait...

These fine people helped write this article: ideato, user832823. You can help too - find out how.