Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Disable touchscreen gestures (scrolling, etc.)

  • 2 Antworten
  • 0 haben dieses Problem
  • 14 Aufrufe
  • Letzte Antwort von beibotanov

more options

I've got a legacy transformer laptop with an integrated wacom-type sensor screen. Despite all shortcomings of it's age, the laptop's got class.

The main web browser installed is Firefox ESR. In tablet mode, control was handled by the Windows - mouse-like drag'n'drop, marking, but with added scrolling gesture by swinging quickly up and down. Using it in the tablet mode is actually very practical.

Recently, after updating from 91 to 101, browser started to interpret the pen as a finger, controls became clumsy and frustrating. The only way of turning finger gestures off, parameter gestures.enable_single_finger_input described in that question (https://support.mozilla.org/en-US/questions/973974) had no visible effect. Have fallen back to 91esr, but this is obviously just a temporary solution. Is there any way to add force-disable parameter or something?

I've got a legacy transformer laptop with an integrated wacom-type sensor screen. Despite all shortcomings of it's age, the laptop's got class. The main web browser installed is Firefox ESR. In tablet mode, control was handled by the Windows - mouse-like drag'n'drop, marking, but with added scrolling gesture by swinging quickly up and down. Using it in the tablet mode is actually very practical. Recently, after updating from 91 to 101, browser started to interpret the pen as a finger, controls became clumsy and frustrating. The only way of turning finger gestures off, parameter '''gestures.enable_single_finger_input''' described in that question (https://support.mozilla.org/en-US/questions/973974) had no visible effect. Have fallen back to 91esr, but this is obviously just a temporary solution. Is there any way to add force-disable parameter or something?

Ausgewählte Lösung

Sorry for not replying for so long.

Changing dom.w3c_touch_events.enabled to 0 did not help. But i have found another nearby parameter, dom.w3c_pointer_events.dispatch_by_pointer_messages, setting it to false did the trick!

Thank you for the help!

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (2)

more options

Does changing this pref has effect ?

  • about:config => dom.w3c_touch_events.enabled = 0

WARNING: modifying prefs directly via the about:config page can sometimes break Firefox or cause strange behavior, and there is no guarantee that this will keep working in future Firefox releases, so be cautious with modifying prefs if you aren't sure you understand their purpose. You should only do this if you know what you're doing.

Hilfreich?

more options

Ausgewählte Lösung

Sorry for not replying for so long.

Changing dom.w3c_touch_events.enabled to 0 did not help. But i have found another nearby parameter, dom.w3c_pointer_events.dispatch_by_pointer_messages, setting it to false did the trick!

Thank you for the help!

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.