Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox not asking where to download files

more options

I have always had my browser set to ask me where to save anything I'm downloading, as you can see by the attached screenshot. However, every single file I have downloaded for the past 2-3 days has first gone into my Downloads folder instead, forcing me to re-download the file in order to get it into the correct folder. If this was for personal usage, I wouldn't care, but having to continually download business files is getting old very very quickly. Firefox has been my default browser for the better part of two decades. I really don't want to switch to Chrome or Safari just because Firefox won't let a power user customize their usage experience.

I have always had my browser set to ask me where to save anything I'm downloading, as you can see by the attached screenshot. However, every single file I have downloaded for the past 2-3 days has first gone into my Downloads folder instead, forcing me to re-download the file in order to get it into the correct folder. If this was for personal usage, I wouldn't care, but having to continually download business files is getting old very very quickly. Firefox has been my default browser for the better part of two decades. I really don't want to switch to Chrome or Safari just because Firefox won't let a power user customize their usage experience.
Angefügte Screenshots

Ausgewählte Lösung

I can't replicate this problem. There must be some unusual factor I'm not thinking of.

There is a temporary preference to revert from defaulting to Save File to defaulting to Always Ask for unassigned content types. This probably will only last a couple of versions but could be a viable option for the moment until we get more reports and can better isolate what is happening on your Firefox.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.download.improvements_to_download_panel and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

Does that have any effect on your Firefox?

Diese Antwort im Kontext lesen 👍 10

Alle Antworten (16)

more options

Yeah,

You need to go into Tools -> Settings -> General and set the Action for the types of downloads to Always Ask for those types you want it to. If it's set to just Save File then it just saves it in whatever the download directory you've set is.

more options
more options

cmjross1 said

I have always had my browser set to ask me where to save anything I'm downloading, as you can see by the attached screenshot. However, every single file I have downloaded for the past 2-3 days has first gone into my Downloads folder instead, forcing me to re-download the file in order to get it into the correct folder.

With your setting, you should always be prompted for the save folder on the first try and not need to re-do the download a second time:

At the risk of making a "turn it off and on again" suggestion, could you try switching around between a set folder and the Always ask setting to see whether you can get it to work on the first try.

more options

I appreciate the responses regarding the recent change and turning it off and then on again. I did all of that —repeatedly— before I posted here. And the computer has been fully rebooted multiple times since I discovered the issue. Yet the problem persists, and I am forced to download files a second time and then go clean out my Downloads folder. After close to 2.0 years, Firefox has finally let me down, and I guess I need to switch to Chrome or Safari in order to remain efficient.

Geändert am von cmjross1

more options

Ausgewählte Lösung

I can't replicate this problem. There must be some unusual factor I'm not thinking of.

There is a temporary preference to revert from defaulting to Save File to defaulting to Always Ask for unassigned content types. This probably will only last a couple of versions but could be a viable option for the moment until we get more reports and can better isolate what is happening on your Firefox.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.download.improvements_to_download_panel and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

Does that have any effect on your Firefox?

more options

Checking the config and switching to false seems to have worked on my personal computer. I'll check my work computer on Monday, and see what happens since that's where I do the bulk of my downloading.

Geändert am von cmjross1

more options

Making that change in config did the trick. Thank you!!!

more options

Note that it isn't recommended to disable a feature by toggling a master control pref like in this case browser.download.improvements_to_download_panel as it isn't guaranteed that this will keep working properly in the future when old code is being removed once the devs think this feature is working properly and the major bugs are fixed. When the old code is partly removed then having the control pref set to false can have weird effects and break things, so do this at your own risk.

more options

The OP is not the only one with this problem. I've observed it to over the last several days, probably longer. Possibly since moving to V99.0. On every Firefox instance that I've ever set up over the last couple of decades, I've always configured it to ask me where to download a file to. That hasn't changed, but the behaviour recently has.

I can understand attempts to increase security in applications, but as someone with thousands (at least) of folders on my computer, hundreds of which could potentially be the desired destination of a saved file, not being able to select the folder to which a file is downloaded to is completely unacceptable. Fix the root security problem, don't dis-allow people the ability to determine the download location of their files. I can live with not being able to select on demand what program to open the file with. That's the least of my worries. I just want to tell the browser where to save the file to.

The about:config setting change worked for me. With regards to the warning above on this being 'not recommended', if the software worked as advertised, we wouldn't have to resort to 'hacks' to make it operate correctly. Advise us of when your software is fixed and I'll gladly undo the hack. In the meantime I have work to do...

more options

T1E1 said

On every Firefox instance that I've ever set up over the last couple of decades, I've always configured it to ask me where to download a file to. That hasn't changed, but the behaviour recently has.

Firefox should still honor this setting as always:

What changed is, you do not get the Download dialog (Open vs. Save vs. Cancel) before getting the Windows dialog to choose where to save the file.

If yours isn't showing that dialog, you can go under the covers to confirm that the Settings page is reflected in the preferences list:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we have had this setting for a long time and I use it myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste browser.download.useDownloadDir and pause while the list is filtered

When you select "Always ask you where to save files" Firefox should automatically set this to false.

(3) If this preference is not false, double-click it to switch the value from true to false.

more options

I've been experiencing this problem lately and have just found what is causing it in my case. Right underneath the download settings in "applications", there are more file-type specific settings. I had .pdf files set to "open in firefox". I think it used to open pdf files without downloading them in permanent storage, but now it seems to download to the default download folder when opening. I had to change this setting to "ask every time" for pdf files specifically. This must be an oversight due to recent changes, so hopefully it will be adjusted, but for now I guess you have to change the download setting for specific file-types as well to ensure it behaves as desired.

more options

Changes to how file downloads are handled in Firefox version 98 https://support.mozilla.org/en-US/kb/manage-downloads-preferences-using-downloads-menu

more options

Firefox 102.0 (64bits) has the same problem yet.

Geändert am von Mineirinho da Silva

more options

Mineirinho da Silva said

Firefox 102.0 (64bits) has the same problem yet.

Are you having a problem with files you want to SAVE or files you want to OPEN?

more options

I had the same "problem". But I think I had figured out what's going on : I always configured "Always ask you where to save files". But in parallel, the by-mimetype behavior list is containing the following (at least for me) : Filetype: pdf => View in firefox And for some reason now, Firefox is downloading temporary 'viewed' files in the $Downloads folder instead of $tmp folder.

I switched back the file association to "Ask me" and I was able to confirm the behavior. First try, ask => selecting save => saving where I want Second try, ask => select 'open in firefox' => auto-download to $Downloads folder => the viewing in Firefox

I'm not yet convince if I prefer this new default tmp file location or the previous one (to /tmp) ....

Regards,

more options

Hi Sancho, it's a little complicated right now. When you have "Open in Firefox" selected:

(1) For sites that serve the PDF normally without trying to force a download, Firefox stores the PDF in the web content cache, so it's neither in the "Save files to" folder nor the temp folder, and when you view it in a tab, it has the original URL.

(2) For sites that serve the PDF with the instruction to download the file, Firefox saves it to the "Save files to" folder and when it displays in a new tab, it has a file:/// address.

If you strongly prefer that #2 save like #1, you can use an add-on to strip off the instruction to download the file. On the other hand, if you want #2 to save without opening, I don't think we know of a workaround for that at the moment.


Regarding the folder change -- Firefox 98 changed from saving downloads in the Windows Temp folder for "Open with [relevant application]" or "Use [relevant application]" to saving them in your default downloads folder (the one next to "Save files to" on the Settings page) -- there is a new option in Firefox 102 to roll that back. Here's how you access it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.download.start_downloads_in_tmp_dir and pause while the list is filtered

(3) Double-click the preference to switch the value from false to true