Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Address Bar

  • 16 Antworten
  • 4 haben dieses Problem
  • 144 Aufrufe
  • Letzte Antwort von tunesrcoolII

more options

how can i get this new thing wear the address bar gets all big everytime i start a new tab. i have a chrome.css file

Angefügte Screenshots

Ausgewählte Lösung

Alle Antworten (16)

more options

Hello tunesrcoolll,

This is a temporary fix, but I am hoping that they will change their mind
and give us the option to permanently disable this new behavior.

Would you do this please :

Type in the address bar about:config and press Enter. (ignore the warning)

Type in the search bar and look for the preference :

browser.urlbar.openViewOnFocus

and set its value to false

Do the same with these preferences :

browser.urlbar.update1

browser.urlbar.update1.interventions

browser.urlbar.update1.searchTips

Then close and restart Firefox.

more options

Ausgewählte Lösung

thank you

more options

tunesrcoolII said

thank you

My pleasure !

You inadvertently marked your own post as Chosen Solution; you can recitify it by clicking on the "Undo" button to the right and then mark my (first) post as Chosen Solution ("Solved the problem" button to the right).

Thank you in advance !

more options

I just noticed that you have a userChrome.css file; would
you please take a look at cor-el's post in this thread :

https://support.mozilla.org/en-US/questions/1284231

But what might interest you more is this, what I call "masterpiece"
written by my brilliant fellow contributor jscher2000 :

https://www.userchrome.org/megabar-styling-firefox-address-bar.html

Geändert am von McCoy

more options

If you toggled the update1 preference to false, this would be for future reference only because it applies to the "new" bar:

Since you are a userChrome.css user, I'll mention that I posted some code to tame the enlargement and tweak the drop-down. If you have time on your hands, you could take a look.

https://www.userchrome.org/megabar-styling-firefox-address-bar.html#mbarstyler

more options

@ jscher2000 :

See my last post ......

more options

there was a firefox update and i set ll these already to false, they didnt change. but its doing it again can someone help

more options

Hi tunesrcoolII, it's true, the browser.urlbar.update1 preference has no effect in Firefox 77+.

You can tame the enlargement effect using custom style rules. Since you already have a userChrome.css file, you can find a set of rules to add in this file:

https://www.userchrome.org/samples/userChrome-ZeroEnlargement.css

Does that work on your Firefox?

more options

i got it off without userchrome

https://geekermag.com/how-to-restore-classic-address-bar-in-firefox-v75/

but it takes suggestions off if anyone can help id like those back

userchrome will not work for me. maybe because i use mac

more options

The browser.urlbar.disableExtendForTests pref is meant for testing purposes when the code has been compiled and has some side effects like you probably noticed.
You will have to use code in userChrome.css to make this work properly.

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a plain text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted. On Mac you can use the TextEdit utility to create the userChrome.css file as a plain text file.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file.

See also:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

more options

no userchrome doesnt work for me, i tried 5 different times

more options

Can you give more detail what you have tried ?

You did create the chrome folder in the profile folder and made sure that userChrome.css (name is case sensitive) is a plain text file (i.e. not a rich text file) ?

Can you attach a screenshot ?

more options

ive had a userchrome file for 5 or 6 years, i know where it goes, i have code in there now i know is working

more options

Some code might not work with the XUL @namespace line, so you can try to place the CSS code above this line.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */
more options

i just looked i dont have the namespace line. maybe because its mac is why it doesnt work

more options

heres a good way with userchrome, i couldnt get it to work like everyone else but this worked. version 77

it has preferences, just choose what you want and the page creates the css for you

https://www.userchrome.org/megabar-styling-firefox-address-bar.html#mbarstyler