Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Web/Country drop-down missing from Google search-tools

  • 4 Antworten
  • 38 haben dieses Problem
  • 13062 Aufrufe
  • Letzte Antwort von td47

more options

After updating to 35.01 and now to 36.0, the Google search results page now behaves differently between Chrome and Mozilla Firefox. The issue is that the "search tools" used to ALWAYS show the web/country choice filter (drop-down), but now only shows 2 options, that is the anytime filter, and the all-results filter. Chrome still shows consistently, all four options (web/country, anytime, all-results, local-location).

After reading various articles on this, and checking likely options in about:config, I found that the ONLY way I could get this back to "normal" was to override the "browser.newtab.url" setting as follows: browser.newtab.url;https://www.google.com.au

NOTE: I have NO problem or blockage in changing my home page (it is set to www.google.com.au) and do NOT have any malware, or the Trovi/SearchProtect/Conduit add-in.

This can still occasionally get the missed options, but it is now 90% consistent. It would be good to get a permanent and proper fix for this. If anyone has a better more rbust method, please let me know. TD

Ausgewählte Lösung

Hi jscher2000, that search engine plugin on the MYCROFT site was very useful thanks. I used the AU Google search as the default, un-ticked the ones I was not interested in, and added the Google UK to the list too (as we are originally from the UK) and occasionally need UK based searches).

This now seems to be more like the original search functionality, so many thanks for that, and I have learned a few more tricks about cookies too!

I did try removing all cookies on previous attempts at fixing this, but nothing seemed to work until I made the config change and used your suggested search alteration plug-in. It is neat that the search provider list can be dragged up and down to sort how you want, in my case all the Google ones at the top.

Diese Antwort im Kontext lesen 👍 2

Alle Antworten (4)

more options

Does the problem occur only when searching from one of Firefox's built-in bars, such as the Search Bar, address bar, search box on the built-in home page, or search box on the built-in new tab page? In that case, it's possible you might need to install a custom search engine pointed directly at Google Australia instead of using the built-in one. This page has lots of search engine plugins to consider:

http://mycroftproject.com/google-search-plugins.html

more options

Hi thanks for the response jscher2000, I will certainly try a custom search add-in later when I get more time. I have found that the first time I use a new tab for a new search (based on https://www.google.com.au) the search works as expected, from either the FF URL/Search bar OR the Google page search. However, another search using the page just used will revert to the "generic" US search, but does NOT then show the 4 drop-downs (only the 2 as in the main post, with NO country selection option). I have anti-malware bytes and NIS fully up to date, and no threats shown, so I am malware free as far as I know.

Spawning a new tab will work the first time just fine. This issue seems to be specific to FF, and Chrome is fine (as is IE V11 but I rarely use it).

more options

Hmm, maybe I should have mentioned the more general advice to clear cache and your Google cookies, in case something "stuck" is causing this problem.

Cookies - While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, google.com.au should already be entered at the top to drill down to just their cookies. You can remove the cookies individually. I suggest also changing the filter at the top to google.com and removing those as well. Then do a "full" reload using Ctrl+Shift+r.

Does it make any difference?

Cache - To flush the cache, you can use:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

more options

Ausgewählte Lösung

Hi jscher2000, that search engine plugin on the MYCROFT site was very useful thanks. I used the AU Google search as the default, un-ticked the ones I was not interested in, and added the Google UK to the list too (as we are originally from the UK) and occasionally need UK based searches).

This now seems to be more like the original search functionality, so many thanks for that, and I have learned a few more tricks about cookies too!

I did try removing all cookies on previous attempts at fixing this, but nothing seemed to work until I made the config change and used your suggested search alteration plug-in. It is neat that the search provider list can be dragged up and down to sort how you want, in my case all the Google ones at the top.