PDF-Dateien in Firefox öffnen

PDF-Dokument Ein PDF-Anzeige-Plugin kann dazu verwendet werden, eine PDF-Datei innerhalb des Firefox-Fensters anzuzeigen. Gibt es ein Problem mit dem Plugin, kann es sein, dass dies nicht mehr möglich ist. Wenn Sie versuchen, eine PDF-Datei anzuzeigen, könnte Firefox versuchen, diese stattdessen herunter zu laden.

Einige PDF-Anzeige-Plugins sind:

Nur die erste Seite ist sichtbar (Mac 10.5 und älter)

Wenn PDF-Dokumente in Firefox geöffnet werden, jedoch nur die erste Seite davon sichtbar ist, stellen Sie sicher, dass das QuickTime-Plugin nicht so eingestellt ist, dass es PDF-Inhalte verarbeitet:

  1. Gehen Sie ins Apple-Menü und wählen Sie Systemeinstellungen.

    e05dfa26d042e50e96172239cb698b18-1260009314-209-1.png

  2. Öffnen Sie dort QuickTime.

    e05dfa26d042e50e96172239cb698b18-1280690961-184-1.png

  3. Gehen Sie zum Reiter Erweitert und klicken Sie auf MIME-Einstellungen....

    e05dfa26d042e50e96172239cb698b18-1280690961-184-2.png

  4. Klicken Sie in der Liste der MIME-Typen auf das Dreieck neben „Bilder – Einzelbild-Dateien“.
  5. Wenn „PDF-Bild“ angewählt ist, klicken Sie darauf, um die Auswahl aufzuheben.

    e05dfa26d042e50e96172239cb698b18-1260009314-209-4.png

  6. Klicken Sie auf OK.

Einstellungen von Firefox überprüfen

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie Einstellungen.Klicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie Einstellungen.Klicken Sie in der Menüleiste auf das das Menü Firefox und wählen Sie Einstellungen....Klicken Sie oben im Firefox-Fenster auf das Menü Bearbeiten (oder auf die Schaltfläche Firefox, wenn die Menüleiste ausgeblendet ist) und wählen Sie Einstellungen....

    Einstellungen - Fx20 - Win7


    EinstellungenFx4Win7.png


    Einstellungen - Fx20 - WinXP


    Einstellungen_Fx4_Linux


    010897fd58f6e294a60e43bbcf0ffe51-1281982768-69-1.png

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Einstellungen.

    Einstellungen öffnen - Fx29 - Win7



    Einstellungen öffnen - Fx29 - Win8



    Einstellungen öffnen - Fx29 - Linux

  2. Gehen Sie zum Abschnitt Anwendungen.
  3. Suchen Sie nach Adobe Acrobat Document in der Liste und klicken Sie darauf, um es auszuwählen.
  4. Klicken Sie auf die Auswahlliste in der Spalte Aktion und wählen Sie Adobe Acrobat (in Firefox) verwenden aus.

    e05dfa26d042e50e96172239cb698b18-1261903940-26-1.png e05dfa26d042e50e96172239cb698b18-1255252986-187-1.png

    • Falls Adobe Acrobat (in Firefox) verwenden nicht als Option aufgelistet ist, folgen Sie der Anleitung Download-Aktionen zurücksetzen weiter unten und wiederholen Sie dann diese Schritte hier erneut.
  5. Klicken Sie auf OK, um das Einstellungen-Fenster zu schließenKlicken Sie auf Schließen, um das Einstellungen-Fenster zu schließenSchließen Sie das Einstellungen-Fenster .

Versuchen Sie nun, eine PDF-Datei in Firefox anzusehen. Wenn die Datei in einem Browserfenster oder in einem neuen Tab erscheint, ist das Problem gelöst. Wenn nicht, fahren Sie bitte mit der nächsten Anweisung fort.

Download-Aktionen zurücksetzen

  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder zu verwenden, folgen Sie der Anleitung unter Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    Profilordner öffnen - Fx29 - Win8

    Profilordner öffnen - Fx29 - Linux

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  4. Löschen Sie die Datei mimetypes.rdf.

Weitere Tipps

Weitere Hilfen, falls das Plugin nicht funktioniert, finden Sie bei Ubuntuusers.de.

Einstellungen von Adobe Reader überprüfen

  1. Öfnnen Sie den Adobe Reader.
  2. Klicken Sie oben im Fensterin der Menüleiste des Adobe Readers auf das Menü Bearbeiten und klicken Sie auf Voreinstellungen.... Das Fenster mit den Voreinstellungen öffnet sich.
  3. Gehen Sie zur Kategorie Internet in der linken Spalte.
  4. Stellen Sie sicher, dass bei PDF in Browser anzeigen ein Häkchen gesetzt ist.

    e05dfa26d042e50e96172239cb698b18-1278343632-105-1.png

  5. Klicken Sie auf OK, um das Fenster zu schließen. Schließen Sie danach den Adobe Reader.

Versuchen Sie nun, eine PDF-Datei in Firefox anzusehen. Wenn die Datei in einem Browserfenster oder in einem neuen Tab erscheint, ist das Problem gelöst. Wenn nicht, fahren Sie bitte mit der nächsten Anweisung fort.

Das Plugin neu installieren

  1. Schließen Sie Firefox.
  2. Gehen Sie zum Programmordner von Adobe Reader. Über einen Dateimanager wie den Windows Explorer müssen Sie dazu in den Ordner C:\Programme\Adobe\Reader x.0\Reader wechseln – wenn Sie Adobe Reader im vorgegebenen Installationsordner installiert haben (ersetzen Sie „x“ durch die von Ihnen verwendete Version, z.B. 9 oder 10).
  3. Gehen Sie dort in den Unterordner Browser.
  4. Kopieren Sie die Datei nppdf32.dll in den Plugin-Ordner von Firefox: Klicken Sie dazu mit der rechten Maustaste auf die Datei und wählen Sie im Kontextmenü Kopieren. Wechseln Sie dann mit dem Windows Explorer in Ihren Firefox-Installationsordner und dort in den Plugin-Ordner. Normalerweise befindet sich dieser unter C:\Programme\Mozilla Firefox\plugins. Gehen Sie dann in das Menü Bearbeiten und klicken auf Einfügen.
  5. Öffnen Sie Firefox und tippen Sie in die Adressleiste about:plugins, um die Plugin-Übersichtsseite zu öffnen.
  6. Suchen Sie den Eintrag Adobe Acrobat.

Wenn der Eintrag vorhanden ist, versuchen Sie, eine PDF-Datei in Firefox anzusehen. Wenn die Datei in einem Browserfenster oder in einem neuen Tab erscheint, ist das Problem gelöst. Wenn nicht, fahren Sie bitte mit der nächsten Anweisung fort.

Die Plugin-Datenbank reinitialisieren

Befolgen Sie die Anleitung Die Plugin-Datenbank reinitialisieren im Artikel Fehlerbehebung bei Plugins.

Damit erzwingen Sie, dass Firefox die Plugin-Datenbank neu erstellt. Versuchen Sie nun, eine PDF-Datei in Firefox anzusehen. Wenn die Datei in einem Browserfenster oder in einem neuen Tab erscheint, ist das Problem gelöst.

Adobe Reader neu installieren

Wenn die obigen Schritte nicht geholfen haben, deinstallieren Sie den Adobe Reader und installieren Sie ihn erneut:

Weitere Informationen

Wenn keine der oben beschriebenen Lösungsmöglichkeiten funktioniert, lesen Sie Adobes Fehlersuchseite (auf Englisch) für weitere Anweisungen.

War der Artikel hilfreich? Bitte warten…

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: ThomasLendo, Wawuschel. Auch Sie können helfen – erfahren Sie, wie.