Prohledat stránky podpory

Vyhněte se podvodům. Za účelem poskytnutí podpory vás nikdy nežádáme, abyste zavolali nebo poslali SMS na nějaké telefonní číslo nebo abyste sdělili své osobní údaje. Jakékoliv podezřelé chování nám prosím nahlaste pomocí odkazu „Nahlásit zneužití“.

Learn More

How do I make 'Never remember history' actually work ?

  • 5 odpovědí
  • 4 mají tento problém
  • 2 zobrazení
  • Poslední odpověď od ian_macf

more options

I have Firefox 9.0.1 installed on Windows XP. I have selected 'Never remember history' but Firefox unfortunately *does* remember history if I close it then start it again. The only way to get rid of history is to select 'clear all current history'. I thought the 'Never remember' option would mean Firefox would clear current history automatically.

I have Firefox 9.0.1 installed on Windows XP. I have selected 'Never remember history' but Firefox unfortunately *does* remember history if I close it then start it again. The only way to get rid of history is to select 'clear all current history'. I thought the 'Never remember' option would mean Firefox would clear current history automatically.

Všechny odpovědi (5)

more options

If Clear Recent History works then you are not in Private Browsing mode (CRH is grayed in PB mode) and you may have an extension that prevents entering PB mode.

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

As I said, I selected 'Never remember history' NOT 'Use custom settings' and 'Always use private browsing'. 'clear recent history' is not greyed so I can use it. However I find if I do try to set 'custom' and 'private' then when I go back to Options again, it is 'Never remember history' which is shown as selected and CRH is available. And history is still remembered !

I started in Safe Mode and went to the DEFAULT theme but I do not see what I need to do, at that point, to check if one of the extensions or hardware acceleration is causing the problem. Or even find out what add-ons, if any, are installed. When in default mode, I have the same symptoms as above.

more options

Further investigation : when I select Extensions, on the Add-ons screen, it says 'You don't have any add-ons of this type installed'. When I select 'Plug-ins' it lists 4 but all are shown as 'disabled'.

more options

Do you see any extensions if you start in Save mode or check the Help > Troubleshooting Information page?

In Firefox 4+ versions you can use one of these to start in Safe mode:

  • Hold down the Shift key while double clicking the Firefox desktop shortcut (Windows)
  • Help > Restart with Add-ons Disabled
more options

There are no extensions installed and no plug-ins enabled.

I completely uninstalled Firefox, and then reinstalled. Same results as previously.

As I said above 'custom' plus 'private' is accepted by Firefox but then ignored, so if I go into Options again, 'Never remember history' is the selected option. But unfortunately, in spite of that, Firefox does remember history.

I have discovered that if I select 'custom' but NOT 'private', then *do* select 'Clear history when Firefox closes' the result is that no history is kept while Firefox is executing and no history is remembered. That's what I want, so that's how I'll leave it.