সহায়তা খুঁজুন

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to disable protection, or enable dark mode, for Firefox pages

  • 6 উত্তরসমূহ
  • 2 এই সমস্যাটি আছে
  • 113 দেখুন
  • শেষ জবাব দ্বারা zeroknight

more options

I've always liked the Firefox New Tab page, with Pocket, and until today, DarkReader plugin has always worked. But now it says that it can't because the page is protected.

I tried the solution to use bookmarklets, suggested in https://support.mozilla.org/en-US/questions/1350781, but it didn't have any effect (https://sanketmehta7.github.io/DarkMode-JS-BookMark/

If I can't find a solution, I'll just ditch Pocket, and use Google as my first page, or something. Or maybe ditch Firefox, which doesn't seem to think that dark mode is important. I don't like being blinded by the light.

I've always liked the Firefox New Tab page, with Pocket, and until today, DarkReader plugin has always worked. But now it says that it can't because the page is protected. I tried the solution to use bookmarklets, suggested in https://support.mozilla.org/en-US/questions/1350781, but it didn't have any effect (https://sanketmehta7.github.io/DarkMode-JS-BookMark/ If I can't find a solution, I'll just ditch Pocket, and use Google as my first page, or something. Or maybe ditch Firefox, which doesn't seem to think that dark mode is important. I don't like being blinded by the light.

সমাধান চয়ন করুন

You can use code in userContent.css to override the color scheme for webpages where extensions do not work, but that usually involves much effort.

Are you using the Dark Website Appearance setting as that should work on built-in about pages like the Firefox Home page ? That won't work with this forum, only userContent.css can work here.

You can check the Website Appearance setting.

প্রেক্ষাপটে এই উত্তরটি পড়ুন। 👍 0

All Replies (6)

more options

চয়ন করা সমাধান

You can use code in userContent.css to override the color scheme for webpages where extensions do not work, but that usually involves much effort.

Are you using the Dark Website Appearance setting as that should work on built-in about pages like the Firefox Home page ? That won't work with this forum, only userContent.css can work here.

You can check the Website Appearance setting.

more options

.....

Terry দ্বারা পরিমিত

more options

The new tab page supports dark mode without DarkReader. Try changing your browser theme to the built-in Dark theme.

more options

Apparently, the Firefox Auto theme doesn't work for me.

I had tried the Dark theme, but since it didn't change the appearance of the settings page where I selected it, I figured it wasn't working. But it is: turning that on fixes the "New tab" page.

Note that I still need DarkReader to handle quite a number of pages that render brightly despite using the Firefox Dark theme, no doubt due to the way the pages are written. And sadly, that doesn't work on this forum, though the DarkMode bookmarklet does (though not terribly well.)

more options

Mozilla appears to believe its sites do not need dark mode support of any kind, and also appears to believe all users should be perfectly fine with this, because their sites alone are flawless and would never need extensions of any kind. So there's no point in letting you use any.

You can thankfully disable this by going to about:config and blanking out extensions.webextensions.restrictedDomains.

Dark Reader specifically needs extra steps to work on some of these sites, because apparently even the Dark Reader devs think users should be forcefully blinded for daring attempt to install an extension.

more options

Mozilla sites have special access to the inner workings of the browser which should not be exposed to extensions. The fact that the Dark Reader developers are onboard with this restriction should tell you something.