Търсене в помощните статии

Избягвайте измамите при поддръжката. Никога няма да ви помолим да се обадите или изпратите SMS на телефонен номер или да споделите лична информация. Моля, докладвайте подозрителна активност на "Докладване за злоупотреба".

Learn More

Userchrome.css not recognised

  • 5 отговора
  • 1 има този проблем
  • 52 изгледи
  • Последен отговор от jscher2000

more options

I used to run Firefox 88.0.1 (64 bit) on a Windows 7 PC. With lots of help from this forum I wrote a userchrome.css file to make several changes to the appearance.

On a new Windows 10 machine I installed the same version of Firefox (since I don't care for the latest one). I added my old profle to the new installation and selected it as the default.

Unfortunately, when I opened the program I was prompted to create a new profile; there didn't seem to be any way around this. So I let it happen and tried simply copying my old chrome folder into it - I thought at least I could make the visual changes even if I couldn't import my bookmarks and so on.

But this didn't work either: when I run the program, none of the expected changes are there.

Presumably I've done something wrong, but what, exactly? I'd be grateful for any thoughts. Ideally, I'd like to use the whole of the old Win7 profile but if that's not possible at least changing the appearance would be pleasant.

Many thanks.

Променено на от mail226

Избрано решение

Apologies for the duplicate posts, now erased; I've no idea how that happened.

Прочетете този отговор в контекста 👍 0

Всички отговори (5)

more options

I've now solved this. I found a post here by Trevor George, who says, in part:

'...you must enable - css - in Firefox, by typing about:config into your address bar, and search for toolkit. When all the toolkit options appear change the one which says toolkit.legacyUserProfileCustomizations.stylesheets to TRUE by click the icon in the right hand column. Than close Firefox and reopen, and check how it looks This will enable your - css - file to be read, and interpreted and accepted by the Firefox browser. ' The fix worked with a few minor hitches: the separate tabs are no longer different colours, and the text on unselected tabs is now white which is tricky to read. Clearly, I must play around a little with the css file.

Thank you, Trevor George! Here is his post .

Променено на от mail226

Полезно?

more options

Apologies for the duplicate post, now erased; I've no idea how that happened.

Променено на от mail226

Полезно?

more options

Apologies for the duplicate posts, now erased; I've no idea how that happened.

Променено на от mail226

Полезно?

more options

Избрано решение

Apologies for the duplicate posts, now erased; I've no idea how that happened.

Променено на от mail226

Полезно?

more options

If you submit a reply that contains a URL to a non-Mozilla site, it typically will be queued for review by the spam moderators and won't appear immediately. There's a small message when this happens, but many people do not notice and submit the same reply again. Either way, sounds like the main issue was resolved. I suggest trying the community on r/FirefoxCSS for detailed CSS assistance:

https://www.reddit.com/r/FirefoxCSS/

Полезно?

Задаване на въпрос

Трябва да влезете в профила си, за да отговаряте на публикации. Моля, започнете нов въпрос, ако все още нямате акаунт.