Showing questions tagged: اعرض كل الأسئلة
  • حُلّت

Add-ons sign in

I am not able to sign in to the Mozilla add-ons page. When I click the login button, a new page is shown with my Mozilla account email, picture, and a sign in button. Aft… (read more)

I am not able to sign in to the Mozilla add-ons page. When I click the login button, a new page is shown with my Mozilla account email, picture, and a sign in button. After clicking "Sign in" I expect a page to appear to input my authenticator code, but instead what appears is the window in the attached partial screen shot. Any ideas? Thanks!

Asked by cjw 2 months ago

Answered by cjw 2 months ago

  • حُلّت

How to disable that Firefox automatically saves PDFs?

I have the following settings in Settings/Preferences>General: Files and Applications Downloads Save all files in the following folder: Downloads Ticked Ask every ti… (read more)

I have the following settings in Settings/Preferences>General:

Files and Applications

Downloads Save all files in the following folder: Downloads Ticked Ask every time where to save a file

Applications Portable Document Format (PDF): Open in Firefox How should Firefox deal with other files? Ticked Ask whether to open or save files

On specific websites when I click on a pdf link, Firefox opens and automatically saves the file to Downloads folder without asking whether to save and where to save despite the above settings. As far as I remember, on other websites when clicking a pdf link Firefox only opens the corresponding file and doesn't save.

I found this with a internet search https://connect.mozilla.org/t5/discussions/stop-saving-pdfs-to-downloads-when-viewing-in-firefox/td-p/10225.

How can it be disabled that Firefox automatically saves PDFs?

Asked by bernd1-1 2 months ago

Answered by cor-el 2 months ago

  • حُلّت

Default browser on linux fails on file:/// URLs.

I just wrote this blog post and someone suggested I contact you. I have my default browser set to Firefox on Linux (Debian Bookworm). When I open an http:// or https:// … (read more)

I just wrote this blog post and someone suggested I contact you.

I have my default browser set to Firefox on Linux (Debian Bookworm). When I open an http:// or https:// URL, it opens in Firefox, but when I open a file:/// URL, it opens in Chromium. It seems that file:/// URL makes it resort to the MIME type.

Is there anything Firefox can do here or is this a Debian or freedesktop.org issue?

Thanks!

Tim

Asked by oylenshpeegul 2 months ago

Answered by oylenshpeegul 2 months ago

  • حُلّت

Have problem after 170 version with arping on my site

Hello, after your last updates from 170 version above, I lost the option to be able to arping through my site. On version 170 it worked after that it stopped working is t… (read more)

Hello, after your last updates from 170 version above, I lost the option to be able to arping through my site. On version 170 it worked after that it stopped working is there a way to enable arping on the latest browser versions. To one pictures is show error on second is from old version and work perfectly. Please if have some think to make work i love Mozilla browser and i wont to use. Thanks and regards

Asked by epoc 2 months ago

Answered by epoc 2 months ago

  • حُلّت

Google Voice image uploads

Texting images via Google Voice had always worked in the past. Now it does not in FF, but succeeds in Chrome. "Server error" is the FF response. What has changed? La… (read more)

Texting images via Google Voice had always worked in the past.

Now it does not in FF, but succeeds in Chrome. "Server error" is the FF response.

What has changed? Latest FF on Win11.

Asked by borate 2 months ago

Answered by borate 2 months ago

  • حُلّت

Can't pin extensions to the tool bar (url bar)

Installed Firefox 122 in a new Windows 10 installation and added some extensions (e.g. Gesturefly, Update Scanner, uBlock Origin, Uppity). These pinned fine on my old in… (read more)

Installed Firefox 122 in a new Windows 10 installation and added some extensions (e.g. Gesturefly, Update Scanner, uBlock Origin, Uppity). These pinned fine on my old installation. But I cannot find how to pin them on the new.

All the help I have found Googling, or using search here, says go to the Add-ons Manager page and right-click the extension and use "pin to toolbar". Alternatively click the extension and click the gear icon and use "pin to toolbar". But when I right-click there is no pin to toolbar context menu entry. If I left-click the gear I get "Check for Updates, View Recent Updates, Install Add-on From File, Debug Add-ons, Update Add-ons Automatically, Reset All Add-ons to Update Automatically, Manage Extension Shortcuts". If I right-click the gear I get a line of icons (left, right, reload, star) followed by "Open Image in New Tab, Copy Image Link, Email Image, Save Page As, Select All, View Pate Source, Inspect Accessibility Properties, Inspect (Q)". If I right-click the extension in the Add-ons Manager page itself, I get a very similar list. In no case is there a pin to toolbar option.

How do I pin an extension, given the above? What have I messed up?

Asked by OneMoreName 2 months ago

Answered by cor-el 2 months ago

  • حُلّت

How To Measure Memory Usage Per Extension?

I noticed my laptop was being slow, so I looked at the memory usage. Firefox was using a whopping 5GB of memory on Windows 11. I then looked at about:process and it repor… (read more)

I noticed my laptop was being slow, so I looked at the memory usage. Firefox was using a whopping 5GB of memory on Windows 11. I then looked at about:process and it reported that extensions were using 4GB. I disabled each of my extensions and it still said it was using 4GB of memory. I then uninstalled two of them and re-enabled some extensions and it dropped to 781MB. This is still to much in my opinion, and I want to know how to figure out which extension is being so wasteful. Even a technique on how to figure it out would be appreciated.

Asked by Elijah Lopez 1 month ago

Answered by zeroknight 1 month ago

  • حُلّت

Bulk user name delete

I would like to select and delete a subset of user names and passwords in Firefox. I have a group of about 80 logins for an old account which I no longer use. I know I ca… (read more)

I would like to select and delete a subset of user names and passwords in Firefox. I have a group of about 80 logins for an old account which I no longer use. I know I can delete individual logins one at a time but doing this 80 times is a pain!

I can search for the particular account in the password list and Firefox lists them all, which is great. What I would like to do then is right click and select all followed by delete.

Is there a shortcut somewhere?

Asked by Spencer.greystrong 2 months ago

Answered by Spencer.greystrong 2 months ago

  • حُلّت

Opening new tab causes Firefox to completely hang

Any method I open a new tab, it always takes up to 7s to load, while completely suspending my browser. This also happens in troubleshoot mode but not in incognito. Direct… (read more)

Any method I open a new tab, it always takes up to 7s to load, while completely suspending my browser. This also happens in troubleshoot mode but not in incognito. Directly opening websites in a new tab doesn't trigger that bug. I don't recall when this started to happen, it might be after some new Windows update.

I have included screenshots from Firefox Profiler, both from regular window and incognito one.

Asked by Adam Kasprzycki 3 months ago

Answered by cor-el 3 months ago

  • حُلّت
  • Locked

Fixed - After A Bookmarks' Library [Restore] Function, Tag Bookmark Names & Folders Show Duplicated

Something went wrong w/ the mouse, some of my tags disappeared & wasn't able to recover them via Ctrl+Z, so I decided to perform my 1st [Restore] (never had to do 1 b… (read more)

Something went wrong w/ the mouse, some of my tags disappeared & wasn't able to recover them via Ctrl+Z, so I decided to perform my 1st [Restore] (never had to do 1 before), since I had just recently done an [Export Bookmarks] & a [Backup]. Everything seems to have gone Ok, except that for every tag, all of the bookmarks listed under the [Name] column are duplicated. When I right-click & [Show In Folder], they both show in the same folder. When going onto their folder, they are only shown once, so there are no duplicates there. When I attempt to [Delete] 1 of the 2 duplicate entries they both get [Deleted], so I can only conclude that they are 1 in the same. But the question remains, "How can I fix this duplicate condition?"

Another related & interesting behavior is that, from any bookmark folder where you can clearly see there are no duplicated bookmarks, when you do a [Search] from the top-right-hand search-box, the "results" are also "duplicated", although you might need to sort them by clicking on the [Name] column control. So, I can go to any bookmark folder & clearly see that there are no duplicate bookmarks, but when you do a [Search], that's when you get duplicate entries. That leads me to believe that this is the result of the [Search] function, & thus for some odd reason the [Search] is generating "duplicate entries". And then perhaps, both the [Tag]s & the [Search] function are related.

Also, this "duplication" does not happen on newer added bookmarks, after the [Restore] was executed, & it's only a phenomenon that affects those bookmarks that were saved by the Bookmarks' Library [Backup] function, & thus this anomaly was introduced by the [Backup].

Actually, I just realized the problem is more complicated than I thought. The reason any search results in "duplicate bookmarks" is because there are 2 sets of folders, 1 set above the other, & if you don't scroll down all the way you won't see it. So that's why there are actually "2 Sets Of Bookmarks", because there are "2 Sets Of Folders", 1 above the other. The problem is that when you delete any "Duplicate Bookmark" you delete them both, & not just 1 of the 2 bookmarks.

I wonder if it would work, to "Delete All Bookmarks" & then do a [Restore]?

Could "Mozilla Support" answer that?

Don't know why every time I attempt to [Post A Reply] & get an "Error",... So I'm going to post my reply right here,...

Fix: (2024-02-19) Of course, I did some testing before I concluded what was the best approach, but since I noticed all of the "Bookmarks Folders" were duplicated under [Bookmarks Menu], an easy fix is to go to the "bottom duplicated folder", right on top of the [Other Bookmarks] folder, & "Select It" (by clicking on it) & [Delete] it (w/ the [Delete] key on your keyboard). Do this 1 by 1, until you reach the "bottom folder" of the bookmarks' folder you certainly don't want to delete. Close Firefox & then reopen it - to make sure Firefox takes care of any garbage-collection. Then do your Bookmarks' Library [Export Bookmarks To HTML] followed by a [Backup], & you are good to go.

Actually, I don't know what introduced the error. Don't know if it was Firefox's [Restore] function, or it could have been me (by accident) w/ some "unnoticed & unexpected" move of the mouse/trackball, which accidentally duplicated all of the folders w/o me noticing, & that is why all of the "Bookmarks" were "duplicated".

Happy Firefox Browsing,...

Asked by Jimmy 2 months ago

Answered by Jimmy 2 months ago

  • حُلّت

Secure Connection Failed, Error Code: PR_END_OF_FILE_ERROR

I have been trying to solve this problem on and off for about a year now, but 99.99% of the time I try to access https://en.wiktionary.org/ , I get the following error: S… (read more)

I have been trying to solve this problem on and off for about a year now, but 99.99% of the time I try to access https://en.wiktionary.org/ , I get the following error: Secure Connection Failed An error occured during a connection to en.wikitionary.org PR_END_OF_FILE ERROR Error code: PR_END_OF_FILE_ERROR

  • The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
  • Please contact the website owners to inform them of this problem.

Learn more... Try Again

I have NEVER gotten this error message for any other website. And the strangest thing? Sometimes I CAN access Wikitionary with zero problems, but this phenomena tends to only happen when I attempt to access the website very late at night or really early in the morning. I cannot think of a single thing I have done differently when this happens.

By the way, I am able to access Wikitionary from Microsoft Edge just fine, it is ONLY Firefox where I have this problem.

Asked by lucasp1337 2 months ago

Answered by lucasp1337 1 month ago

  • حُلّت

Peer’s Certificate has been revoked.

I encounter this message "Peer’s Certificate has been revoked. Error code: SEC_ERROR_REVOKED_CERTIFICATE" when connecting to "Site A" using Firefox version 122.0 (64), my… (read more)

I encounter this message "Peer’s Certificate has been revoked. Error code: SEC_ERROR_REVOKED_CERTIFICATE" when connecting to "Site A" using Firefox version 122.0 (64), my primary browser. I have successfully connected to "Site A" using Firefox in the recent past.

I can connect to "Site A" without errors using my backup browser, MS Edge Version 121.0.2277.83 (Official build) (64-bit).

This seem to be a Firefox related problem.

Help

Asked by JIML 2 months ago

Answered by JIML 2 months ago

  • حُلّت

Problem with default browser

Firefox is my default browser. I clicked on a link in my email and it came up on Edge, and asked permission to open in Edge. I thought it was just for that link, but ever… (read more)

Firefox is my default browser. I clicked on a link in my email and it came up on Edge, and asked permission to open in Edge. I thought it was just for that link, but ever since, all my links are opening in Edge. I checked my computer settings and confirmed that Firefox is my default browser, but it doesn't seem to make any difference.

Asked by bpmilham 2 months ago

Answered by bpmilham 2 months ago

  • حُلّت

Streaming Video issues on Philo / Paramount+ / Amazon Prime (see comments for full error message)

Trying to stream shows on Firefox and video does not start / errors out. Philo returns with this error: Philo is having trouble streaming this content. [Error code: pf-1… (read more)

Trying to stream shows on Firefox and video does not start / errors out. Philo returns with this error: Philo is having trouble streaming this content.

[Error code: pf-1.5-5bb2f]

Paramount+ Also freezes up and returns error message. As does Amazon Prime.

Adblockers disabled. Youtube is fine.

Tried refreshing Firefox / renistalling but same error. Prefer to use Firefox as default browser but having to go to Google to stream shows.

Debating rolling back a version but it was working fine the other day but could have had an update and didn't notice and now streaming is erroring out.

Suggestions? Thanks.

Asked by wedschilde 2 months ago

Answered by wedschilde 2 months ago

  • حُلّت

Firefox always sets address to https

I assume that it's the same problem as this: https://support.mozilla.org/en-US/questions/1388431 but there is no solution. https only mode is not active browser.fixup.a… (read more)

I assume that it's the same problem as this: https://support.mozilla.org/en-US/questions/1388431 but there is no solution.

https only mode is not active

browser.fixup.alternate.protocol is set to http from https browser.urlbar.autoFill is set to false

Nothing helped.

I get that this default makes sense but since so many local tools don't use http there should be at least 1 working option to disable this behavior at least for certain sites.

Asked by danielw90.dw+firefox 2 months ago

Answered by Terry 2 months ago

  • حُلّت

Sorting bookmarks by name in folders stopped working

The right click on a Folder on the Bookmarks Toolbar and choosing Sort by name stopped working. Please, fix it. Version: 122.0.1 (64-bit) Both selected folder is suppos… (read more)

The right click on a Folder on the Bookmarks Toolbar and choosing Sort by name stopped working. Please, fix it.

Version: 122.0.1 (64-bit)

Both selected folder is supposed to be ordered by name:

Asked by Ádám Péter 2 months ago

Answered by cor-el 2 months ago

  • حُلّت

Save bookmark and open bookmark seem to be different lists

When I save new bookmarks I can't find them to open them. The list of folders I see in the "Choose . . ." selection is different from the list of folders l see when tryin… (read more)

When I save new bookmarks I can't find them to open them. The list of folders I see in the "Choose . . ." selection is different from the list of folders l see when trying to open a bookmark. The bookmarks seem to be saving in one list but opening from a different list. How do I replace the list Firefox opens bookmarks from with the list the new bookmarks are saved in?

Asked by cmedearis 2 months ago

Answered by cor-el 2 months ago

  • حُلّت

Email images not displaying on Mozilla

Hi there. I use mailjet for sending email newsletters and campaigns. The images that i was uploading into the mailjet templates where displaying fine both on mailjet and … (read more)

Hi there. I use mailjet for sending email newsletters and campaigns. The images that i was uploading into the mailjet templates where displaying fine both on mailjet and when sent to mozilla firefox users.

The problem is that for 10 days now; when i upload images in mailjet and sending newsletters; the images are not displaying in mozilla. In contrast, when i use chrome everything displays fine, both mailjet and email accounts.

I had a long chat history with mailjet support and they requested to follow these instructions to fix this issue first: https://documentation.mailjet.com/hc/en-us/articles/360058211453-Why-are-my-images-not-displayed-missing-in-the-Email-Editor I did this but i had no success so they requested me to use chrome instead of mozilla. But that is not the solution of the problem because this must address all different browser users.

Can you please help me on this?

Thank you,

Asked by St P 2 months ago

Answered by zeroknight 2 months ago

  • حُلّت

Firefox manual proxy config, port number not accepted

I'm trying to use a manual proxy server for Firefox. When entering the proxy address and port number, Firefox outlines the port number field in red and disables the OK bu… (read more)

I'm trying to use a manual proxy server for Firefox. When entering the proxy address and port number, Firefox outlines the port number field in red and disables the OK button thus refusing to accept my assigned port number. I'm trying to use port number 29842 which was given to me by the proxy provider.

Asked by kent30 2 months ago

Answered by kent30 2 months ago